Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
127 Views

FGA tool crashing at startup on centos7

Hi there,

I downloaded and installed intel advisor, in order to use the FGA tool.  The advisor gui works fine but if I try to start fga tool I get the following crash:

#0  0x00007f795e4eefc8 in QXcbCursor::queryPointer(QXcbConnection*, QXcbVirtualDesktop**, QPoint*, int*) ()
   from /lib64/libQt5XcbQpa.so.5
#1  0x00007f795e4dace2 in QXcbDrag::init() () from /lib64/libQt5XcbQpa.so.5
#2  0x00007f795e4dadd5 in QXcbDrag::QXcbDrag(QXcbConnection*) () from /lib64/libQt5XcbQpa.so.5
#3  0x00007f795e4cff82 in QXcbConnection::QXcbConnection(QXcbNativeInterface*, bool, unsigned int, char const*) ()
   from /lib64/libQt5XcbQpa.so.5
#4  0x00007f795e4d3942 in QXcbIntegration::QXcbIntegration(QStringList const&, int&, char**) () from /lib64/libQt5XcbQpa.so.5
#5  0x00007f796bf47a0b in ?? () from /home/allopis/intel/advisor_2020.1.0.605410/fga/fga/platforms/libqxcb.so
#6  0x00007f7967ce4fbb in QPlatformIntegrationFactory::create(QString const&, QStringList const&, int&, char**, QString const&)
    () from /home/allopis/intel/advisor_2020.1.0.605410/fga/fga/libQt5Gui.so.5
#7  0x00007f7967cf16fd in QGuiApplicationPrivate::createPlatformIntegration() ()
   from /home/allopis/intel/advisor_2020.1.0.605410/fga/fga/libQt5Gui.so.5
#8  0x00007f7967cf270d in QGuiApplicationPrivate::createEventDispatcher() ()
   from /home/allopis/intel/advisor_2020.1.0.605410/fga/fga/libQt5Gui.so.5
#9  0x00007f79678d2bf3 in QCoreApplicationPrivate::init() ()
   from /home/allopis/intel/advisor_2020.1.0.605410/fga/fga/libQt5Core.so.5
#10 0x00007f7967cf33dc in QGuiApplicationPrivate::init() ()
   from /home/allopis/intel/advisor_2020.1.0.605410/fga/fga/libQt5Gui.so.5
#11 0x00007f79683195d9 in QApplicationPrivate::init() ()
   from /home/allopis/intel/advisor_2020.1.0.605410/fga/fga/libQt5Widgets.so.5
#12 0x00005648e5deaff8 in main ()

Looks like a QT5 issue. My system is centos 7.5 64 bit Linux.

Is this a bug in fga? Is there a workaround?

 

Thanks!

 

0 Kudos
3 Replies
Highlighted
127 Views

Hi Andres,

Thank you for your submission - we will try to reproduce it and see if there's a workaround.

--Vasanth

0 Kudos
Highlighted
Employee
127 Views

Andres,

FGA is normally packaged with an appropriate version of Qt.

Looking at the logs, it looks like FGA is picking Qt from some other location.(/lib64/libQt5XcbQpa.so.5)

Starting FGA with the run_fga.sh script ensures that the packaged Qt is picked up rather than any that might be on the system.

Please refer to the link below for directions to start FGA with the run_fga.sh script.

https://software.intel.com/content/www/us/en/develop/documentation/advisor-user-guide/top/flow-graph...

Do not hesitate to let us know if you have any further issues.

Thanks,

Elvis.

0 Kudos
Highlighted
Beginner
127 Views

Elvis,

thank you very much, running using the sh script does work indeed! great!

 

Thanks!

0 Kudos