Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
15 Views

Faile to recognize executable

Im evaluating VTune 9.1 for linux. Im useing the Eclipse GUI interface with the wizard. When trying to select the application to run, VTune failed to recognize it as an executable. It claims that the file is a text file and not an application. I have played with it and came to the conclusion that it happens when the path contains the word "text", i.e. it will not work for /a/b/context/a.out nor for /a/b/text1234/a.out etc.
Can anybody confirm the problem?
Is there a workaround? I need the word "context" in the path since I cannot move the application to a some other path.
0 Kudos
11 Replies
Highlighted
Black Belt
15 Views

Does a symlink, or a script, get past this?
0 Kudos
Highlighted
Employee
15 Views

Im evaluating VTune 9.1 for linux. Im useing the Eclipse GUI interface with the wizard. When trying to select the application to run, VTune failed to recognize it as an executable. It claims that the file is a text file and not an application. I have played with it and came to the conclusion that it happens when the path contains the word "text", i.e. it will not work for /a/b/context/a.out nor for /a/b/text1234/a.out etc.
Can anybody confirm the problem?
Is there a workaround? I need the word "context" in the path since I cannot move the application to a some other path.

Assume that you are using latest v9.1 U2. You should be able to run app or script with VTune Analyzer GUI.

1. If you ran appin aconsole, please run vtlec in this console - so all environment variables (required by your app) can be used in vtlec
-OR-
2. If you ran vtlec in another console - please modify vtune activity, use "Activity Configuration"->click "Configure..." button for "Application/Module Profile(s):" -> click "Advanced" button -> uncheck "Use default environment" to add new environment variables.

3. Use "Activity Configuration"->click "Configure..." button for "Application/Module Profile(s):" -> change "Working directory:" as you worked on console

Hope it helps.

Regards, Peter

0 Kudos
Highlighted
15 Views

Quoting - tim18
Does a symlink, or a script, get past this?

No
0 Kudos
Highlighted
15 Views


Assume that you are using latest v9.1 U2. You should be able to run app or script with VTune Analyzer GUI.

1. If you ran appin aconsole, please run vtlec in this console - so all environment variables (required by your app) can be used in vtlec
-OR-
2. If you ran vtlec in another console - please modify vtune activity, use "Activity Configuration"->click "Configure..." button for "Application/Module Profile(s):" -> click "Advanced" button -> uncheck "Use default environment" to add new environment variables.

3. Use "Activity Configuration"->click "Configure..." button for "Application/Module Profile(s):" -> change "Working directory:" as you worked on console

Hope it helps.

Regards, Peter


Mybe I did not explain myslef well. The problem is that I'm trying to run my application from /a/b/context/myapp.
Though "myapp" is executable the GUI tellls me that the application is a "text file".
The reason for it (according to my tests is that the path includes the word "text". i.e. /a/b/context/myapp. Chanheing the path to /a/b/c/myapp works fine. My problem is that my application must run in the /a/b/context/myapp to peoform correctly so I can't simply move it to /a/b/c/myapp.

Thanks,

Oron.



0 Kudos
Highlighted
Employee
15 Views


Mybe I did not explain myslef well. The problem is that I'm trying to run my application from /a/b/context/myapp.
Though "myapp" is executable the GUI tellls me that the application is a "text file".
The reason for it (according to my tests is that the path includes the word "text". i.e. /a/b/context/myapp. Chanheing the path to /a/b/c/myapp works fine. My problem is that my application must run in the /a/b/context/myapp to peoform correctly so I can't simply move it to /a/b/c/myapp.

Thanks,

Oron.




Hi Oron,

Thank you for detail explanations.

However I tried to reproduce this problem on my side, it failed.
1) I copied VTune example named gsexample2a, gsexample2a.c and datafile.txt to /home/peter/a/b/context
2) I ran vtlec then create a new sampling activity to specify "/home/peter/a/b/context/gsexample2a" as launched application, "/home/peter/a/b/context" as working directory, "datafile.txt" as command line parameters.

Everything went well.

Is this problem for your app specific?Do you have any problem to do above on your side?

Regards, Peter
0 Kudos
Highlighted
Employee
15 Views

I tried absolute path "/a/b/context" instead of "/home/peter/a/b/context", the result is same.

-peter

0 Kudos
Highlighted
15 Views

I tried absolute path "/a/b/context" instead of "/home/peter/a/b/context", the result is same.

-peter


I have tried it on my end and it sill does the same thing. I even called my application context and it did the same so calling /a/b/context ("context" is the name of my application ....) produced the same result the "GUI" vtlec still assumes the context is not an executable but a script. Just to make sure we are using the same version i run vtl --version and I got 9.1 build 226 (How do I see the version for vtlec ?)
0 Kudos
Highlighted
Employee
15 Views


I have tried it on my end and it sill does the same thing. I even called my application context and it did the same so calling /a/b/context ("context" is the name of my application ....) produced the same result the "GUI" vtlec still assumes the context is not an executable but a script. Just to make sure we are using the same version i run vtl --version and I got 9.1 build 226 (How do I see the version for vtlec ?)

I changed "gsexample2a" name to "context", as "/a/b/context"- no problem to run this with vtlec. My version is build #226, you can get info from "About Intel Software Development Products" on vtlec, besides "vtl version".

Can you attach your app on this thread, so I can verify this problem on my side?

What is the result (output) for "vtl activity -c sampling -app /a/b/context run"?

Thanks, Peter

BTW> you can use "Reply is Private" (above "Add your Post" button), if you want toprotect your app.
0 Kudos
Highlighted
15 Views


I changed "gsexample2a" name to "context", as "/a/b/context"- no problem to run this with vtlec. My version is build #226, you can get info from "About Intel Software Development Products" on vtlec, besides "vtl version".

Can you attach your app on this thread, so I can verify this problem on my side?

What is the result (output) for "vtl activity -c sampling -app /a/b/context run"?

Thanks, Peter

BTW> you can use "Reply is Private" (above "Add your Post" button), if you want toprotect your app.

It has nothing to do with my application. Attached is the "hello world" application, compiled in two ways:
g++ -g hello.cpp -o hello
g++ -g hello.cpp -o context

The file in http://software.intel.com/file/24685 contains the two programs and 3 jpg images:
hellow_1.jpg - The GUI when "hello" application is used
context_1.jpg - The GUI when "context" is used. This is the first difference - it claims that "context" hes no debug infomation, thoughI compiled it with the -g flag (same as hello).
context_2.jpg - The GUI when "context" is used and the finish button is pressed... A new dialog is oppened claiming that the file is a script / text.

Versions are:

---------------------
Eclipse Platform

Version: 3.2.1.r321_v20060921-b_XVA-INSQSyMtx
Build id: M20060921-0945
----------------------
Eclipse RCP

Version: 3.2.1.r321_v20060801-2ekW2BxmcpPUOoq
Build id: M20060921-0945
---------------------------
Intel Software Development Products
Version: 2.0.4
---------------------------
Eclipse C/C++ Development Tools

Version: 3.1.1.200609270800
Build id: 200609270800
------------------------------
VTune Performance Analyzer

Version: 9.1.0
Build id: 20090219226
------------------------
Thanks,

Oron
0 Kudos
Highlighted
15 Views


Thew version I'm using is

VTune Performance Analyzer

Version: 9.1.0
Build id: 20090219226
0 Kudos
Highlighted
Employee
15 Views

Thanks for your screen shots, finally I can reproduce this problem.

We are using same VTune Analyzer version, but you used "First Use Wizard"

There are two bugs when using "First Use Wizard",

1) It reported "export/home/ovexler/TestCPU/context has no debug information..." thatwas wrong, since we used "-g" compiler option

2)It reported "context is a text file..." thatwas wrong, because it is binary file.

This problemrarely happens, but you have a work around to use "Sampling Wizard" instead of "First Use Wizard" - the problem has gone.

Note that Sampling Wizard uses default events "CPU_CLK_UNHALTED.THREAD" and "INST_RETIRED.ANY", but First Use Wizard uses event "CPU_CLK_UNHALTED.THREAD" only. You canmodify sampling activity to add/remove any event...

Regards, Peter

0 Kudos