Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Athira_A_
Beginner
81 Views

Finding hotspot tutorial related issue

 

As per the Tutorial: Finding Hotspot, I could Build application and create new project, Run Basic Hotspots Analysis, Interpret Result Data. But while trying to Analyze Code and edit the most hotspot region of the code, I was unable to open the editor from Open Source File Editor icon. It was showing "Cannot Open the external text file editor for this file."

I had also given $ "export EDITOR=gedit"  command in the terminal before running amplexe-gui. Kindly help me with the issue and suggest me how to get access to the editor.

Thank You.

 

 

0 Kudos
4 Replies
David_A_Intel1
Employee
81 Views

How are you starting VTune Amplifier, from the Ubuntu GUI or from a console window?  If you started it from the Ubuntu GUI, you need to set a 'system-wide' environment variable, e.g., EDITOR.  VTune Amplifier is going to inherit the environment from the system.

If from a console window, did you set the EDITOR environment variable in the same console window and prior to starting amplxe-gui?  Also, if you enter 'gedit' at the console prompt, does gedit start? 

cole_b_
Beginner
81 Views

I am having the same issue as above. When I double click on a line of code or click "Open Source File Editor", it produces the same error about not being able to open the external text editor. I am launching from the terminal with "sudo ./amplxe-gui". Before I do that, I run "export EDITOR=gedit". I can then open gedit with "gedit". I have also tried setting the VISUAL variable to gedit as well as restarting and re-assigning the EDITOR variable.

Any idea what is going on? 

 

Thanks

David_A_Intel1
Employee
81 Views

Hi cole:

I suspect the 'sudo' is creating a new shell and not inheriting the variable you defined.  Try this: create a script that exports the variable and then starts VTune Amplifier; now 'sudo <script'.

cole_b_
Beginner
81 Views

That makes sense. For some reason I thought running it without sudo was giving me problems, but I'm not seeing any right now. The editor now works. 

Thanks

Reply