Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Mohammed_A_2
Beginner
127 Views

Getting "Error : Cannot connect to data source provider"

Hi

I am using the following free trial version: vtune_amplifier_xe_2016.3.0.463186 on Ubuntu 14.04. This worked fine on one of my boxes. But on another box, I get the analysis running and on stopping or after the configured time, I get an error saying "Cannot connect to data source provider". And no analysis is provided. Cannot open the analysis results by giving the path also. I get the same error.

Can someone provide any clue on what the issue could be. I checked all the kernel flags mentioned and everything looks fine. The exact same steps are done on my another machine where it works. I am testing it with a very simple C code for debugging.

Thanks

Anzal

0 Kudos
3 Replies
127 Views

Hi Anzal,

Sorry for the inconvenience. The issue could be caused by a local firewall settings. The thing is that VTune Amplifier starts a child process called 'node' which serves content for the GUI. The communication with this child process happens via TCP Sockets. Usually local firewalls do not block such local connections, but maybe that's the case on your Ubuntu box. Please check if you have local firewall and whether it blocks local connections (connections to localhost & 127.0.0.1). Also please check if you see this child process 'node' started by amplxe-gui.

Thanks,
Stas Neverov

Pan_D_Intel
Employee
127 Views

I encountered the same issue on vtune_amplifier_xe_2017 gold + win_nda, on APL win10.

the .tb7 file can be generated, but "Error : Cannot connect to data source provider" is still there.

Tried turn off windows firewall, it doesn't work.

thanks

Pan

127 Views

Hi,

Found a more likely reason for this error.

If "localhost" is mapped to an IPv6 loopback address instead of IPv4 (::1 instead of 127.0.0.1) then VTune fails with the "Cannot connect to data source provider" error. Next versions of VTune will not depend on this but for now please try updating your hosts file to use IPv4 loopback address for "localhost" as a temporary workaround:

/etc/hosts or C:\Windows\System32\drivers\etc\hosts:
127.0.0.1       localhost
#   ::1             localhost

Sorry for the inconvenience.

Regards,
Stas

Reply