Talk to fellow users of Intel Analyzer tools (Intel VTune™ Profiler, Intel Advisor)

How do I view my results?


After running:

vtl activity $name -c callgraph -app a.out -moi a.out run

I get at the bottom:

An Activity is currently running and it resides in a project that is about to be closed! Closing the project will cause the Activity to be cancelled, losing any results. Would you like to close the project and cancel the Activity?
Choose (y)es or (n)o.

I typed "n" and then return.

Then I tried:
nht6011-64> vtl view -calls
VTune Performance Analyzer 1.0 for Linux*
Copyright (C) 2000-2002 Intel Corporation. All rights reserved.

The Activity Result was not found. Use 'vtl show' to display the project's contents.


So how do I view my results?

0 Kudos
3 Replies
I'd like to start from the end.

Activity results (AR) can be viewed as long as they were created.

"vtl show"
shows the tree of the project with activities and activity results(AR) created. For example:
r1_____callgraph Results - Wed Feb 26 10:16:43 2003
r2_____callgraph Results - Wed Feb 26 10:19:07 2003

vtl view -calls
will try to show the last AR that was created. (In your case it was probably not created). Moreover, the "-calls" is specific to call graph AR. How can you be sure that the last AR was indeed the call graph one?

So, the preferable way is to name the AR you want to view like:
vtl view a8::r2 -calls

Another problem is that the AR was not created in your case.

Have you done any actions during this run?
If not, does it happen for any other application (like /bin/ls) or only for this specific one?

If it happens only for your specific application please send it to us.


0 Kudos
After I checked all the postings this is the best subject that fits with my problem. I am trying to benchmark an application on IA32 and also on IA64. To be fair I am trying to use the same profiler on both architectures. On IA32 I am using gcc 3.3.3 on a RH7.3 distribution. On IA64 I am using icc 8.0 on a RH-2.1AS. This application is linked to some matemathical libraries (ATLAS, CLAPACK on IA32) and HP-MLIB on IA64. If I run vtune on IA32 using callgraph:
vtl activity -c callgraph -app /home/wlugo/SSI/bin/classifier,"options" -moi /home/wlugo/SSI/bin/classifier run
I could get all the information and the results are there, but If I executed the same command on IA64 I could not get the results. Vtune runs in the same way (checking libraries, starting data collection, finishing data collection, etc) but when you try to get the results:
vtl show
The activity is there but there are no results. I could run the activity again and again and nothings happen. I checked on the documentation and its said this could be a filesystem full problem, or a NFS issue. but I changed all VTUNE environment variables to point to a separate partition with 24GB on a local disk. I also changed the cache-directory variable in the global-options but I can't get the results. There are no errors or warnings during the run. Do you guys have a clue of what it could be happening? If this does not work, Are there any other tool available to profile code on IA64 and IA32? Last time I checked I can't use gprof with icc, still the case?.
0 Kudos
Which version of the VTune analyzer for Linux are you using?
BTW, feel free to create a new post! You don't have to piggyback on an existing post.

Message Edited by DaveA on 08-25-2004 10:14 AM

0 Kudos