Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Xiduo_T_
Beginner
105 Views

How to install Vtune Amplifier 2015 vtsspp on MPSS2.1.6720

I'm using mpss_gold_update_3-2.1.6720, with a uos version of 2.6.38.8-g5f2543d.

I'm now trying to install the vtune amplifier 2015 on this mpss, so I need sep3_15-k1om-2.6.38.8-g5f2543dsmp.ko and vtsspp-k1om-2.6.38.8-g5f2543dsmp.ko. But I can find only sep3_15-k1om-2.6.38.8-g5f2543dsmp.ko and vtsspp-k1om-2.6.38.8-gd50f2a5smp.ko, but not vtsspp-k1om-2.6.38.8-g5f2543dsmp.ko.

So, how can I build a vtsspp-k1om-2.6.38.8-g5f2543dsmp.ko? I've downloaded the mpss_gold_update_3_src-2.1.6720, and extraced the package-full_src-k1om, but I can't build successfully with "/opt/vtune/vtune_amplifier_xe/mic_sepdk/src/vtsspp/build_mic.sh      --build clean all".

Any help, please?

0 Kudos
5 Replies
Peter_W_Intel
Employee
105 Views

My version is 

# /opt/intel/mic/bin/micnativeloadex -V
micnativeloadex -- ver: 3.1
Built against MPSS stack ver: 3.2.3-1 BuildNo: 0
BuildDate: 2014-05-23 17:54:33 -0700

Usually, sep3 driver will be loaded when installing the product. If you cannot find it - "ssh mic0 lsmod | grep sep3", do

# pwd
/opt/intel/vtune_amplifier_xe_2015/bin64/k1om
# ./sep_micboot_install.sh 
SEP configuration files have been successfully installed in the configuration directory.
Please run  "service mpss restart" to start the SEP service.

 

 

Peter_W_Intel
Employee
105 Views

Stack sampling should be supported on MIC, verify:

# ssh mic0 lsmod | grep vtsspp
vtsspp                313866  0 

 

Xiduo_T_
Beginner
105 Views

Peter, thanks for your reply!

Here is my problem. My sep3 driver on mic is O.K., but the vtsspp can't be installed properly. When I tried to run the micboot_install.sh script, I got an error suggesting no prebuilt version available for vtsspp, asking me to compile vtsspp with the source code of the corresponding mpss version. Maybe it's caused by an unsupported mpss version of 2.1.6720? Because I saw you were using mpss 3.2.3.

If the output of micboot_install.sh can help, I can add it here.

Thank you very much!

Peter_W_Intel
Employee
105 Views

Yeah, maybe you need to upgrade mpss version (no prebuilt driver in latest VTune), I guess:-)

I think that old VTune may work with your mpss, but no vtsspp on MIC - this is a new feature in 2015.

Xiduo_T_
Beginner
105 Views

Seems like I have to update my mpss version to 3.x. Thank you all the same.

Reply