Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
136 Views

Intel Vtune is not loading data

Jump to solution

Hello,

I am running an application on Intel Vtune (vtune_amplifier_xe_2013) on the linux system (ubuntu).

using command-lin: /opt/intel/vtune_amplifier_xe_2013/bin64/amplxe-cl -collect snb-bandwidth -app-working-dir /usr/local/hadoop -- /usr/local/hadoop/projwc

However, intel vtune is not loading data into the target file.

amplxe: Collection stopped.
amplxe: Using result path `/usr/local/hadoop/r025ge'
amplxe: Executing actions  0 %                                                 
amplxe: Warning: The result contains a lot of raw data. Finalization may take a long time to complete.
amplxe: Executing actions 14 % Loading data files                              
amplxe: Warning: Cannot load data file `/usr/local/hadoop/r025ge/data.0/tbs1546692947.tb6' (tbrw call "TBRW_dobind(tbrwFile->getHandle(), streamIndex)" failed: invalid string (97)).
amplxe: Executing actions 50 % Generating a report 

The result file r025ge is empty.

If I run the application with small data set, vtune runs smoothly however I am getting above error with big data set.

I have actually posted this question couple of weeks back. I was suggested to check the heap size and it solved my problem. But now I am using different machine and I am facing the same error again. I have increase the heap size. Moreover, it also has been suggested by the one of the intel experts to use "target-duration-type=long" on the command-line. But problem remains the same.

I will appreciate your response.

 

 

0 Kudos
20 Replies
Highlighted
Employee
32 Views

Several comments:

1. Current version is 2015 U4, but you used 2013. Can you please verify if the problem cab be reproduced in latest version?

2. <... I run the concurrency analysis in paused mode and resume it manually after some time...>  do you have insert resume API in code? Or you run "amplxe-cl -command resume -r r???cc. I know that you target process is java, but what will happen if you set "-mrte-mode=auto" option? You can filter result from profiling in whole period.

3. Is there any problem if you run advanced-hotspots or general-exploration instead of concurrency analysis? 

amplxe-cl -collect advanced-hotspots -no-auto-finalize -follow-child -mrte-mode=auto -no-allow-multiple-runs -result-dir /home/ajawan/Spark/kmeans/r00 -- /home/ajawan/Spark/kmeans/kmeans $1

4. As another workaround, you can manually launch app, then use "amplxe-cl -collect advanced-hotspots -analyze-system -duration 30" 

 

0 Kudos