Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
4752 Discussions

Old VTune can display function name in hotspot analysis, but new VTune cannot. [C#][.Net]

HKR
Novice
515 Views

I'm migrating development environment. I find recent VTune cannot work.

In the old environment, VTune can display function names in my codes with "Managed code profiling mode" = Managed.

However, in the new environment,  VTune cannot show function names with the same codes and "Managed code profiling mode" = Managed.

I googled and found I may need to generate native PDB using ngen.exe. Then, I'm facing a few problems.

- I don't understand why the old environment can show function names. 

- Though ngen.exe needs administrative privileges. I don't have administrative privileges.

 

Questions

1. How can VTune work well? 

2. Why does the old VTune work well?

 

My environment is as follows. 

My source codes

- Mixed with C# and C++

 - Main: C#. C++ codes are called in C# codes.

- .Net Framework 4.5.2

 

Old environment

- Win7

- VS2013

- Intel VTune Amplifier XE 2015 Update 4

 

New environment

- Win10

- VS2019

- Intel VTune Profiler 2021

0 Kudos
4 Replies
RahulU_Intel
Moderator
486 Views

Hi,


Thanks for posting in Intel Communities. We looked into your case. We tried reproducing your issue from our end. We are able to see the function names in the Vtune after doing the analysis (both in standalone VTune and part of Visual Studio configuration of VTune) with the following configurations of the System and the Software:

  1. Windows 10 OS
  2. Visual Studio 2019
  3. VTune 2022.0.0
  4. With Managed code profiling mode = Managed

Could you please try updating your VTune to the version which is 2022.0.0.


Hope this help.


Rahul





HKR
Novice
441 Views

Hi Rahul,

 

Thank you so much for your response.

Unfortunately, I can't try the newer version due to the slowness of the software installation procedure in my office.

I'll try the newer version maybe next month.

I'm ok to close this post.

 

Thanks,

HKR

RahulU_Intel
Moderator
464 Views

Hi,


We haven't heard back from you. Could you please confirm if your issue is resolved.


Thanks

Rahul


RahulU_Intel
Moderator
446 Views

Hi,


We haven't heard back from you. We will close this case for now. If you have any query you can post a new question in the community.


Thanks

Rahul


Reply