Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
4724 Discussions

OneAPI advisor_offload scripts segmentation fault

RitaChu
Employee
595 Views

hi

I am trying the offload advisor and was following the training.  But I ran into segmentation fault.  And also it complained about there is no 'dot' program and that I have to install it, but I am in devcloud server am and not allowed to install anything.  I capture the message below.  Anyone knows how to solve/get-around this.

Thanks,

 

 

u119416@login-2:~/oneAPI-samples/Tools/Advisor/matrix_multiply_advisor$ ./advisor_offload.sh
./advisor_offload.sh: line 3: 16197 Segmentation fault advixe-python $APM/collect.py advisor_project --config gen9 -- ./matrix.dpcpp
Info: Results will be stored at '/home/u119416/oneAPI-samples/Tools/Advisor/matrix_multiply_advisor/analyze'. See interactive HTML report in '/home/u119416/oneAPI-samples/Tools/Advisor/matrix_multiply_advisor/advisor_project/e000/report'
Warning: 'dot' program is not found. Program tree in PDF format will not be avaialble.
Please install the dot program, which is usually found in the graphviz package.
Info: Selected accelerator to analyze: Intel(R) Gen9 Integrated Accelerator 24EU.
Survey result cannot be loaded

0 Kudos
5 Replies
AthiraM_Intel
Moderator
512 Views

Hi,


Thank you for posting in Intel Communities.


The issue might be because you are trying to analyze from login node. Can you try the same from compute node.


You could reach an interactive compute node by using the below command:


qsub -I


If the issue still persists, let us know the below details:


1) Analysis type

2) Exact steps to reproduce the issue.

3) Also share the advisor_offload.sh file.



Thanks.


RitaChu
Employee
494 Views


@AthiraM_Intel I haven't got time to try it yet.  I  will update after I try.  thx.

AthiraM_Intel
Moderator
436 Views

Hi,


Did you get a chance to try out ? Is your issue resolved?

If the issue still persists, please share the details we asked in our previous response.


Thanks.


RitaChu
Employee
355 Views

Sorry for the late reply.  I have tried what you suggested and the segmentation fault no longer showed up.  Thanks for your help, please feel free to close the issue.

Best regards,

AthiraM_Intel
Moderator
341 Views

Hi,


Glad to know that your issue is resolved. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.


Thanks.


Reply