Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
4676 Discussions

Problems installing Vtune 3.0 on EL3

Intel_C_Intel
Employee
187 Views
I'm having an issue installing Vtune. It seems to have problems installing DCOM saying it can't find COOL_NTD_INIT_START.

10:37:38 16-12-04 /etc/init.d/ntd: Starting NT daemon (ntd)...
1 NTD 1.0(retail), made at 2003/12/01 16:23:23 with crypto support, build 1
11156, pid 11649, shm size 768 starting...
2 NTD is running...
1 cannot translate environment variable COOL_NTD_INIT_START
1 Ntd is not running on existing shared memory
2 Error: NTD is not running at the moment, please start it before using NT
services.
failed.
10:37:39 16-12-04 /etc/init.d/ntd: Could not start ntd. See /var/log/dcom/ntd.l
og for details.
0 Kudos
3 Replies
TimP
Black Belt
187 Views
Why is anything in /etc/init.d invoked when you try to install Vtune? Do you have it set up to run when you start a shell?
Intel_C_Intel
Employee
187 Views
When it installs the DCOM component, after installation it attemps to load DCOM I assume. Look through your install.log in /var/log if it still exists.
jeffrey-gallagher
187 Views
Hey kwlee2,
Did you ever examine that ntd log file listed out, ntd.1? What did it say?
That aside, it sure does look like something non-default is going on when your ntd shellscript is running, perhaps related to the server environment itself. (You installed as root, right?)
Can you confirm that the first line in your /etc/rc.d/init.d/ntd file looks like this:
#!/bin/sh
which is the guarantee that the script is being run in a Bourne shell, and not some other kind of shell?
cheers
jdg
PS: If this doesn't yield something interesting, it might be time for you to open a premier case at http://premier.intel.com.

Message Edited by jdgallag on 01-10-2005 10:58 AM

Reply