Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Jianbin_F_
Beginner
61 Views

Profiling a program in hStreams

Jump to solution

I am profiling a hStreams program (vector addition) with vtune on a Xeon + KNC heterogeneous platform. It reports the following message. Can anybody shade some lights on the issue?

[jianbin@cn111 vectorAdd-singleStream]$ amplxe-cl -collect-with runsa-knc -target-system=mic-host-launch  -target-duration-type=medium ./bin/host/vecAdd
amplxe: Using target: mic-host-launch:
amplxe: Warning: To collect data on Intel Xeon Phi coprocessor, use -target-system=mic-native or -target-system=mic-hots-launch options. For custom collection on the coprocessor card, add: -collect-with runsa. 
Note: To profile a native Intel Xeon Phi application in the Application to Launch mode, specify a full path on the target. 
amplxe: Collection started. To stop the collection, either press CTRL-C or enter from another console window: amplxe-cl -r /home/jianbin/vectorAdd-singleStream/r004runsa_knc -command stop.
amplxe: Collection stopped.
amplxe: Using result path `/home/jianbin/vectorAdd-singleStream/r004runsa_knc'
amplxe: Executing actions 50 % done                                            
amplxe: Error: 0x4000001d (Cannot find raw collector data)

0 Kudos

Accepted Solutions
Dmitry_P_Intel1
Employee
61 Views

Hello,

Could you please try to replace "runsa-knc" to "runsa" as a value of "-collect-with" option.

amplxe-cl -collect-with runsa -target-system=mic-host-launch  -target-duration-type=medium ./bin/host/vecAdd

Also - usually if you run "-collect-with runsa" you want to specify a list of events that you want to profile using -knob event-config=<list_of_events>. In your case the list is empty since you simply did not order events to collect. Was that the intention?

Thanks & Regards, Dmitry

 

View solution in original post

2 Replies
Dmitry_P_Intel1
Employee
62 Views

Hello,

Could you please try to replace "runsa-knc" to "runsa" as a value of "-collect-with" option.

amplxe-cl -collect-with runsa -target-system=mic-host-launch  -target-duration-type=medium ./bin/host/vecAdd

Also - usually if you run "-collect-with runsa" you want to specify a list of events that you want to profile using -knob event-config=<list_of_events>. In your case the list is empty since you simply did not order events to collect. Was that the intention?

Thanks & Regards, Dmitry

 

View solution in original post

Jianbin_F_
Beginner
61 Views

Thanks, Dmitry. It is working now :-)