Community support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
4892 Discussions

VTune Amplifier and Hyper-V settings



I have a problem when using VTune Amplifier. Data about the system and tool:

  • Host OS: Windows 8
  • VM: HyperV
  • Guest OS: Windows 7
  • VTune Amplifier XE 2017

I am using HyperV to access guest OS on which application of interest is installed. It is a desktop service-based application. All I want to do is just a simple Basic Hotspot analysis. There is a process I want to attach to and PID is used to identify the process. Source and binary files (.exe and .pdb) files are also provided and located in the same folder (bin folder of mentioned application). 

I want to perform Basic Hotspot analysis with "Attach to Process". All I get is this fatal error: 

Collection failed
8/17/2017 10:59:30 AM  Collection failed. The data cannot be displayed. 
 [Instrumentation Engine]: Failed to allocate Injector, Error = INJECTOR_ERR_FAILED_TO_CREATE_REMOTE_THREAD Pin
isexiting due to fatal error.

I read about using VTune on guest OS i.e. using VTune on VM.  In the official documentation of VTune is described VMware but there is no information about how to set-up a HyperV VM in order to be able to perform VTune Basic Hotspot analysis. I cannot identify the equivalent setting in HyperV. Is this is a problem at all? Is cause of the error mentioned above something else then simple VM settings? 

Can anybody help me with this or share his/her experience on this topic? 

It is not an option to use host machine because all source code and application is installed on guest OS (accessed via HyperV). This is a business rule.

Thank you.


0 Kudos
1 Reply

Addition to the original post.

In the meantime I tried to analyze some already existing Windows application on my guest OS, using VTune. It was successful for Notepad application. So, VTune works fine on my VM and problem is not a VM setting. 

Also, I tried to run VTune and the application with the same (admin) account and user privileges. Still, I have the same error as mentioned in the original post. 

Now I am even more confused. Why is this error shows up? What is it about? When can I see more about the cause(s) of this error? Is there are some logs generated by VTune that will provide more information?

This error is not mentioned in "Troubleshoot" part of VTune documentation, so I will be very thankful for any kind of information/further readings/advice.


0 Kudos