Community
cancel
Showing results for 
Search instead for 
Did you mean: 
S_D_
Beginner
67 Views

VTune Data Collection automatically triggering prematurely

Hello, 

I am trying to perform Basic Hotspots analysis using VTune Amplifier XE 2015 on my win64 machine, and experiencing problems with VTune Data Collection log process triggering prematurely. 

This is my workflow. I click on the "Start" or "Start As Paused" (for Start/Resume workflow) button and am in the process of running a script in my application for profiling. However, after a few seconds VTune Data Collection Log is automatically getting triggered without my performing any other action in VTune (no "Pause" or "Stop"), and before my script is done running. 

Thus, the Data Collection Log errors out as follows. In "Finalization complete with Warnings" section it states that "Cannot load data file <data_trace_file_path> (Data is corrupted). 

FWIW, I was able to get VTune to successfully perform analysis the first time I used it with a different version of my application (using a different project) using the Start As Paused, Resume and Stop controls. 

I don't think I am doing anything different in the second scenario, but it is not working out. Can you help figure out what is wrong? Please let me know if you need any further information for debugging. 

This is probably irrelevant, but for reference, I have an install version of VTune. Initially, I had some licensing problems which was resolved by your tech support. 

thanks!

 

0 Kudos
1 Reply
Peter_W_Intel
Employee
67 Views

We can try this scenario in command line: 

amplxe-cl -collect hotspots -start-paused -r c:\temp\r001hs -- path\script1.bat

On other console (cmd):

amplxe-cl -command -resume -r c:\temp\r001hs ; wait awhile

amplxe-cl -command -stop -r c:\temp\r001hs

You can run amplxe-vars.bat under VTune_INSTALL_DIR in console first to set environment, then use amplxe-cl.

What is the outputs? I assume you run script with application longer. 

Reply