Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
4555 Discussions

VTune HS analysis exits immediately without running the process

AckoftOvak
Beginner
477 Views

I am working with Intel oneAPI VTune Profiler 2021.1.1, build 613804 on Linux.

The following changes to the system parameters were made:

sudo sysctl -w kernel.perf_event_paranoid=1
sudo sysctl -w kernel.yama.ptrace_scope=0
sudo sysctl -w dev.i915.perf_stream_paranoid=0

 

I configured a hotspot analysis with User-Mode Sampling in VTune GUI.

On hitting Start the GUI doesn't show any errors, opens a summary page almost immediately, "Collection Log" tab shows "Data collection is completed successfully", and "Finalization completed successfully". However, no process was actually run, the summary shows just 0.005s of execution, there is no stack or anything. There are following errors in the log files:

64 [140480225519168] ERROR mrtehelpers.mrteenv <> - Failed to init shared librarylib located at /opt/intel/oneapi/vtune/2021.1.1/lib64, at file: vcs/mrtehelpers3/src/mrteenv/mrte_profiling_initializer.cpp:485
64 [140480225519168] ERROR mrtehelpers.mrteenv <> - CLR support is disabled because profiler GUID is empty, at file: vcs/mrtehelpers3/src/mrteenv/mrte_profiling_initializer.cpp:308

 

I couldn't find any other errors. Hardware Sampling in contrast works.

0 Kudos
4 Replies
ChithraJ_Intel
Moderator
467 Views

Hi Slava,


Thanks for reaching out to us.

As a quick check, can you try to run the vtune-self-checker.sh script which will be available in <vtune-install-dir>/bin64 to validate that appropriate drivers are installed and the system is set up properly to collect performance data. Please share the output with us so that we can validate it from our end.


Also, could you please try to run User-mode sampling for matrix application which comes along with Vtune Profiler. You could find the matrix application in the path: /opt/intel/inteloneapi/vtune/2021.1.1/samples/en/C++/matrix. Let us know the observations.


It would be better if you will share the reproducer code, so we will investigate the issue in detail from our end.


Regards,

Chithra


ChithraJ_Intel
Moderator
450 Views

Hi Slava,


Please let us know if the issue still exists or not? If yes, could you please share the details requested. So that, we can investigate the issue in detail.


Regards,

Chithra


ChithraJ_Intel
Moderator
412 Views

Hi Slava,


We haven't heard back anything from you. We would discontinue monitoring this thread by assuming that your issue got resolved. Please feel free to raise a new thread in case of any issues/queries.


Regards,

Chithra


Kirill_U_Intel
Employee
405 Views

Hi Slava.

Looks like the known issue with permissions for not-root users from VTune sw-based hotspots analysis on systems where installation run by root/sudo. 

To check exec permissions, in the <vtune_install_dir>/bin64 dir run

   $ ls -l | grep pinbin

To fix permissions:

   $ sudo chmod o+rx <vtune_install_dir>/bin64/pinbin

Sorry for inconvenience, Kirill

Reply