Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
4559 Discussions

VTune Profiler giving Error: “The Data Cannot be displayed,there is no viewpoint available for data ”

Singh_Jasdeep
Beginner
151 Views

I want to optimize my code which is written in c++ on linux platform.For that i am using Intel VTune Performance Analyzer Profiler .When i am identifying Hotspots , then it gives Error: "The Data Cannot be displayed,there is no viewpoint available for data ".

0 Kudos
5 Replies
Peter_W_Intel
Employee
151 Views

Current product is not "VTune profiler" (VTune(TM) Performance Analyzer is old product), that is, Intel(R) VTune(TM) Amplifier XE 2013, latest update is 5. Not sure if you use same product.

Note that old product has not be test in recent Linux* Operation Systems

 

 

Singh_Jasdeep
Beginner
151 Views

Its Performance Analyser ...i.e i am using Intel(R) VTune(TM) Amplifier XE 2013  only ....i have downloaded trial version ,.,...it displaying the above mentioned error..........Sorry as it was checking performace so i had added word profiler in title.

Peter_W_Intel
Employee
151 Views

What is OS you use? Ubuntu?

Assume that you use Hotspots collection - did you run target application in short time?

Singh_Jasdeep
Beginner
151 Views

Yes i am using Ubuntu 11.04 ....basically i think target application's executable is not getting executed.For Executable which we have to dump in that i have made with the help of gcc -o "name of executable "  "name of source" .this executable i am dumping in vtune and vtune is made to start then it gives the above mentioned error.

Peter_W_Intel
Employee
151 Views

Please consider to verify:

1. In a console, run your application without VTune(TM) Amplifier XE - does it work smoothly?

2. In same console, run "/opt/intel/vtune_xe_2013/amplifier-var.sh"

3. Run "amplxe-cl -collect hotspots -- app" or "amplxe-gui" to verify it works.

Note: In Ubuntu 11.4, you may need to disable ptrace_scope. 

cat /proc/sys/kernel/yama/ptrace_scope; "0" is expected, if it is "1",

Then do

$echo 0 | sudo tee /proc/sys/kernel/yama/ptrace_scope

Reply