Community
cancel
Showing results for 
Search instead for 
Did you mean: 
jvong
Beginner
71 Views

VTune Stopped Running

Hi all,
My VTune stop running and I cannot run any "vtl" command, for example,
[root@SDV900 a3]# vtl show
VTune Performance Analyzer 2.0 for Linux*
Copyright (C) 2000-2003 Intel Corporation. All rights reserved.
The project is already open and cannot be used. Another VTune Performance Environment session has opened it.
When I tried to use ActivityController to stop the running project.

You are controlling the following Activity:
clamav_callgraph2
Please select one of the following actions to use with the Activity:
1. Stop Activity
2. Cancel Activity
3. Pause Activity
4. Resume Activity
5. Activity Status
6. Activity Information
7. Quit
> 1
The Activity (clamav_callgraph2) is no longer running!
I have tried to restart vtune but did not help solve the problem. Following is the output.
[root@SDV900 init.d]# ./vtune restart
Unloading VTune analyzer sampling driver:
Shutting down the following vtl.bin process(es):
8180 vtl.bin 8208 vtl.bin 8209 vtl.bin 8213 vtl.bin 8219 vtl.bin 8224 vtl.bin 8225 vtl.bin 8228 vtl.bin 8233 vtl.bin 8625 vtl.bin
Removing sampling driver from the kernel ... done.
Deleting /dev/vtune_* devices ... done.
Sampling driver vtune_drv-x64-2.4.18-e.31smpsmp has been successfully unloaded.
Loading the VTune analyzer sampling driver:
Executing: insmod /opt/intel/vtune/vdk/vtune_drv-x64-2.4.18-e.31smpsmp.o
Creating /dev/vtune_* devices with major number 253 ... done.
Setting group ownership of /dev/vtune_* to group "vtune" ... done.
Sampling driver vtune_drv-x64-2.4.18-e.31smpsmp has been successfully loaded.

Now I cannot use VTune to do anything?
Does anyone have idea about why this happened?
Any help is appreciated.
Seve
0 Kudos
1 Reply
71 Views

VERY interesting report, Seve.

1) Are you the administrator, and perhaps the only user on this system. If so, it's an easy "yes" to the QUICKEST way to get things back to normal --> reboot the server:

# init 6

2) If you can't do that, do a ps command and see what vtl-related processes are running, if any. Kill them, see if they die. Try again.
# ps -ef | more
# kill -9
(No lectures on using the -9 option: if that doesn't work, nothing will. Normally we might try -3, -15, or -1 options before jumping into the -9 option.)
3) Another idea, some kind of filesystem or file corruption has been written to disk, and is confusing vtl. Maybe the working directories should be cleared?
Let us know what you find.
Oh yea, if these hints don't help you AT ALL, be sure to go to the Intel Premier website and open a case!
cheers
jdg
Reply