Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
4644 Discussions

VTune does not cache source files

softworkz
Novice
496 Views

VTune Profiler 2021.1.1 Gold (Build 613804) Windows

Hotspots View

Whenever I navigate to the Source View (eg. gfrom the Bottom-Up view), a small message is shown at the bottom right, saying "Source file is saved in the result cache".

Now I change the code, recompile and do another run in VTune.

When I go to an earlier result (to compare), and navigate to the source file, it doesn't show a cached version - it shows the current version instead with the timings not matching the code lines anymore.

I assume, this is a bug?

Thanks,
softworkz

Labels (1)
0 Kudos
5 Replies
AthiraM_Intel
Moderator
469 Views

Hi,


Thanks for reaching out to us.


Please make sure that you enabled the "cache source files". To enable it follow the below step:


Go to Tools --> Options --> Source/Assembly.


If you are still facing the issue, please share the below details:


1. Details about the application you are using.

2. Reproducer code.

3. The changes you made in the code. 

4. Finalization mode


Thanks.


softworkz
Novice
438 Views

I have activated that option for caching source files.

1. and 2.: ffmpeg source code compiled with gcc on Windows under MSYS2

3. Any change to the code file as soon as I change the code file. Which means that it loads the source file from the original location instead of a cache location.

4. Full

Thanks,
softworkz

AthiraM_Intel
Moderator
439 Views

Hi,


We are forwarding your case to Subject matter Experts.


Thanks


Mark_L_Intel
Employee
327 Views

Asked for engineering team support on your issue.


Mark_L_Intel
Employee
283 Views

Engineering team reports that it reproduced the issue on the matrix application built with gcc on Linux. Possible solutions that would fix this issue are identified.



Reply