Community
cancel
Showing results for 
Search instead for 
Did you mean: 
David_DiLaura1
Beginner
88 Views

VTune doesn't instrument with IVF 9.0

I've installed IVF 9.0 and resumed work on tuning some code. VTune no longer instruments the executable. The report at the bottom of the screen that described VTune's progress always reports that the module "has been skipped." The installation of IVF 9.0 asked if I wanted to install VTune--I clicked yes. I've since removed VTune, reinstalled it, and put the recent patched in. Same result. Has anyone had the same problem? Any suggestions. I assume that the installation of IVF 9.0 as done something, but I can't figure out what.
0 Kudos
3 Replies
Steven_L_Intel1
Employee
88 Views

The installation of IVF asked if you wanted to install VTune? I have never seen that. Did you perhaps see a message about VTune's integration with the VS.NET IDE? Normally, the Fortran install doesn't do anything with VTune.

I'm going to move your thread to the VTune forum, where you will probably get some good advice.
Boaz_T_Intel
Employee
88 Views

I can think of two possible reasons:
- it could mean that the executable doesn't have any symbols (pdb file), therefore its instrumentation level is set to 'None'. Thus, instrumentation is skipped.
- it could mean that an instrumented module exists in the call graph instrumentedcmodule cache, thus instrumentation is not needed.
To check if any of the above applies to yor problem, open the call graph advanced settings, where you can see the module list. It says there whether an executable has symbols. You can also clear the cache from this dialog.
Boaz.
David_A_Intel1
Employee
88 Views

Right. That "skipped" message is a point of confusion. :-( It typically means that instrumentation is not needed because it was already done once, the binary hasn't changed, and the instrumented copy is in the cache and will be used.
Reply