Community
cancel
Showing results for 
Search instead for 
Did you mean: 
donald
Beginner
158 Views

VTune hangs Visual Studio 2005 on XP

Two serious problems here.

On install, VTune plugged itself into Visual Studio. Now, when I starrt Visual Studio, it hangs for 6 minutes (not responding...) with the hard drive reading like crazy. Very irritating time waster, as this leads to the next problem.

After any VTune analysis (which seems to work OK), I can't compile ANY project. Every file in Visual Studio seems to be locked in read-only mode. Even if I exit VTune and Visual Studio completely, the files remain locked. I have to do a hard reboot, then back to the first problem.

I'm running XP Pro on a single-core pentium 4 HP laptop. VTune and Visual Studio are both on my C: drive. I have 1.25G of RAM.

Any solutions for these?

0 Kudos
8 Replies
Andrey_Pavlenko
Beginner
158 Views

Hi

I can't guess about the reason of this issue, but you definitely need to disable VTune integration to VS.

To do this launch Modify through Control Panel -> Add/Remove Programs or just run VTune install again and deselect the corresponding install feature from the features to install.

/Andy.

aokunev
Beginner
158 Views

Hi

What you're describing looks like a serious problem. We have not faced this dufing our testing of the product. Please submit new request to premier.intel.com with as many details as possible about your HW and environment. if it's possible please attach the output of vtqfagent.cmd and produced log files.

regards, Andrei
donald
Beginner
158 Views

Hi Andrei

Reinstalling VTune without a connection to Visual Studio fixed both problems!

Thanks for the suggestion.

Donald

ketanm
Beginner
158 Views

Hi,

We have also observed similar situation with our solution file containing 180 projects. It seems that in integrated mode VTune generates project file for each vcproj file. Hence while loading your solution IDE seems to hand when it tries to parse all and hang.

In general we have found that removing VTune integration with VS2005 works best. There is no need to reinstallas when you try to uninstall VTune you have an option to remove integration only.

Ketan

David_A_Intel1
Employee
158 Views

You can also use the Modify function to remove integration. That is, press the Change button in Add/Remove Programs with the Intel VTune Performance Analyzer selected. Then, select Modify and on the Custom Setup screen (starting with version 9.0 Update 3) select to NOT make the integration feature available (see attached image). Then complete the setup and the VTune analyzer will be un-integrated from Visual Studio.

ILevi1
Valued Contributor I
158 Views

I had the same issue people describe here with the latest version of VTune and VS2005 on Windows XP SP2. Hardware is as follows:

  • 150GB Raptor as a system drive
  • VTune work folder on 400GB partition located on RAID0 setup
  • 2GB of DDR2-800 RAM
  • Core 2 Duo E6300
  • D975XBX mainboard

For me, just modifying the installation and deselecting the integration didn't help. I had to completely uninstall VTune in order to restore Visual Studio 2005 functionality. VTune integration was hanging it regardless of the complexity of a project I attempted to load and even launching just the empty IDE did the same thing.

David_A_Intel1
Employee
158 Views

Actually, it wasn't VTune analyzer integration, at all! Unfortunately, the install somehow enabled the .NET profiling variables so that any app that loaded the CLR would generate profiling data, typically slowing the app down, significantly. I don't know how or why this happened, but it is resolved in the latest release, 9.0 Update 7.
Andrey_Pavlenko
Beginner
158 Views

Actually, not VTune install but VTune itself enables this profiling somehow.
Due to some circumstances VTune can set and leave some env. vars that cause VS performance slowdown. Please check if your system has these env. vars set:

Cor_Enable_Profiling=1
COR_PROFILER={91663010-0D1E-4ABD-8F0C-0B4B84CCA809}

BISTRO_COLLECTORS_DO_CALLGRAPH=1

If found any of them - remove.

/Andy.

Reply