Community
cancel
Showing results for 
Search instead for 
Did you mean: 
YWang84
Beginner
65 Views

Vtune issue in MacOS version

I am using MacOS version VTune gui to profile a remote process launched in a Linux box. But then got this issue:

amplxe: Error: Stack size provided to sigaltstack is too small. Please increase the stack size to 64K minimum

It looks the recommendation is to apply "-run-pass-thru=-no-altstack" follows the amplxe-cl. This option seems not working in MacOS version VTune, but how to pass it to remote Linux vtune profiler?

0 Kudos
6 Replies
Kirill_U_Intel
Employee
65 Views

Hi Yujia.

Could you share your amplxe-cl command?

I verified this one

./amplxe-cl -target-system ssh:USER@HOST_API -target-install-dir=REMOTE_VTUNE_DIR -collect hotspots -knob sampling-mode=hw -knob sampling-interval=1 -run-pass-thru=-no-altstack -- /bin/ls

and option was added without any problem.

I've just copied command line to clipboard in GUI and added -run-pass-thru=-no-altstack.

Kirill

 

YWang84
Beginner
65 Views

Hi Kirill,

Thank you for reply. It looks works with a CLI issued from Mac.

Is this option (-run-pass-thru=-no-altstack) working in GUI? Can I run this from GUI?

Another problem is that if I succeed in running a collect job with this CLI.

/amplxe-cl -target-system ssh:user@IP -target-install-dir=/home/intel/vtune_amplifier_2019.0.2.570779/ -collect hotspots -knob sampling-interval=1 -run-pass-thru=-no-altstack -target-pid 25662

After a while, I stopped this and get the result dir. I wanted to import the result from GUI, but got following errors. Do you know why?

 

Kirill_U_Intel
Employee
65 Views

Hi Yujia.

This option is not available from GUI but we are in implementation stage for automatic switching on this flow in case of such issues.

Why did you use import for results? You must to use 'Open Result' dialog (not Import)

Kirill

YWang84
Beginner
65 Views

You are right! Open result looks good. What does "import results" do?
BTW, how can I profile by launching an application?

amplxe-cl -target-system ssh:splunk@azhang-splunk2 
 -collect hotspots -run-pass-thru=-no-altstack -- "/home/MyApp start"

I tried this and it cannot be executed. What is the correct way to apply parameters to my launched app?

Kirill_U_Intel
Employee
65 Views

Some words about import

https://software.intel.com/en-us/vtune-amplifier-help-importing-results-to-gui

just remove quotes to run application with params. 

 

amplxe-cl -target-system ssh:splunk@azhang-splunk2 
 -collect hotspots -run-pass-thru=-no-altstack -- /home/MyApp start
YWang84
Beginner
65 Views

You are super!

I am afraid one potential issue is that my application's start requires a 30 seconds to start, with this profiling mode - to launch the application with amplxe cli. It get stopped with bad result finally for unknown reason. But I can use --targe-pid to work.

Reply