Community
cancel
Showing results for 
Search instead for 
Did you mean: 
lhartzman
Beginner
138 Views

WSAECONNABORTED error

With VTune 9.0 on Windows (Linux data collectors) I'm getting an error message "Could not recv bytes from a remote machine. An established connection was aborted by the software on your host machine, probably due to a data transmission timeout or protocol error. Error no.: (10053) (WSAECONNABORTED)".

Can someone tell me what is happening here? Is there a timeout on the Windows machine due to too much data being transmitted?

Thanks.

Les
0 Kudos
3 Replies
Peter_W_Intel
Employee
138 Views

Quoting - lhartzman
With VTune 9.0 on Windows (Linux data collectors) I'm getting an error message "Could not recv bytes from a remote machine. An established connection was aborted by the software on your host machine, probably due to a data transmission timeout or protocol error. Error no.: (10053) (WSAECONNABORTED)".

Can someone tell me what is happening here? Is there a timeout on the Windows machine due to too much data being transmitted?

Thanks.

Les

Version 9.0 is too old. Latest product is v9.1 Update 2. Pleasedownload and uselatest version.

I rememberthat the user should use like as "vtserver --no-auth --compat-user root -d /tmp", but for v9.1 - simply use "vtserver -d /tmp"

Hope it helps.

Regards, Peter
lhartzman
Beginner
138 Views


Version 9.0 is too old. Latest product is v9.1 Update 2. Pleasedownload and uselatest version.

I rememberthat the user should use like as "vtserver --no-auth --compat-user root -d /tmp", but for v9.1 - simply use "vtserver -d /tmp"

Hope it helps.

Regards, Peter
It turns out I was wrong. I am using v9.1, Build 210 (update 2?). I am using the older startup options. I'll try changing it to just "-d /tmp". So will the startup options have an effect on this error that I'm getting, or is the suspicion that I was using an older version the reason that I am getting this error?

Les

P.S. Tried changing the options to just "-d /tmp" and couldn't get authorized. I had to go back to the other options. I've now also managed to receive a WSAENOTSOCK error!

Peter_W_Intel
Employee
138 Views

Quoting - lhartzman
It turns out I was wrong. I am using v9.1, Build 210 (update 2?). I am using the older startup options. I'll try changing it to just "-d /tmp". So will the startup options have an effect on this error that I'm getting, or is the suspicion that I was using an older version the reason that I am getting this error?

Les

P.S. Tried changing the options to just "-d /tmp" and couldn't get authorized. I had to go back to the other options. I've now also managed to receive a WSAENOTSOCK error!


Hi Les,

It seems that you are using VTune Analyzer for Windows* v9.1, build 210 (Update 2), please use consistent VTune Analyzer for Linux* v9.1, build #226 (Update 2).

Simply use "vtserver -d /tmp_dir" or "vtserver" on Linux* side, and click "Remote" button of Wizard on Windows side - use"user:password@host:[port]"
Note that "user:password" is your using account on Linux side; "host" couldbehost name or IP address; "port" can be ignored if you use default port value "50000".

Other things I have to remind - 1) Can you ping two machines each other? 2)If you don't use "root" user, are you sure that current user is in "vtune" group?

Regards, Peter
Reply