Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Jess
Beginner
115 Views

When working on a remote machine, the help tries to open in the local (desktop) browser

Jump to solution
I use VTune on a cluster, which I access via SSH. This uses X-forwarding to display the GUI. When I try to access any of the help or getting started guides, they open in the browser on my desktop. This is unhelpful as I just end up with a 404, the software not being installed here (and it won't ever be). This seems like a bug caused by a misunderstanding of how people are likely to be using the software. Has it just not been tested in this configuration before being released? It isn't uncommon to work in this way on production systems, and the documentation is really useful to have access to.
0 Kudos
1 Solution
David_A_Intel1
Employee
115 Views

okay, actually, i have duplicated this issue.  I will submit a defect against the product.

a workaround would be to install the VTune Amplifier on your host system, as well.

View solution in original post

14 Replies
Peter_W_Intel
Employee
115 Views

I used vncserver/vncclient to ssh remote Linux* machine, which installed VTune(TM) Amplifier XE 2015 for Linux*. There was no problem that I used amplxe-gui to invoke VTune, and click on help\Get starting with VTune(TM) Amplifier XE 2015 - I saw contents in my browser "Firefox" which was installed with remote Linux* operation system, not in my Host machine. 

What was the tool that you used to ssh remote machine? Did you have internet browser such Firefox installed in remote machine?. 

 

Jess
Beginner
115 Views
Did you try it with firefox already running on the Linux desktop machine? I am using the standard ssh that comes with RHEL 6, but the problem occurs on Debian and Ubuntu too (all use openssh of differing versions).
David_A_Intel1
Employee
115 Views

If you use x-forwarding, that is what is going to happen, though I would have expected the browser to look for the content on the remote system (since it is just the graphical part that is forwarded and displayed on your client - it is still executing on the remote system).  What is the path in the address bar?  Can you show us a screenshot of the browser's address bar?

As Peter mentioned, is there anyway you can use VNC instead of ssh + x-forwarding?  This is the usage model we employ for our remote lab systems, so we know it works.

Peter_W_Intel
Employee
115 Views

You can download VNC viewer from http://www.realvnc.com/download/viewer/linux/

I have verified there is no problem to use <Getting started with VTune Amplifier XE 2015> in Firefox on the target. Steps are:

1. Run "vncserver :num" on Ubuntu* system (putty)

2. Use other Linux* system then run VNC-Viewer-5.2.1-Linux-x64 to log-on Ubuntu* system with GTK* support.

3. On Ubuntu* system, run /opt/intel/vtune_amplifier_xe_2015/bin64/amplxe-gui, then run <\Help\Getting started with VTune...>

4. You can close VNC-Viewer-5.2.1-Linux-x64, Firefox windows is closed. That means, browser was from target system, not host system.

Please see screen-shot.

vnc-client-linux.png

Jess
Beginner
115 Views
Actually, if the application (in this case the browser) is already running, then with X-forwarding the local machine browser window will always be used instead. This has been the normal behaviour for the last few years at least. VNC is not appropriate on a production HPC system, so that won't work as a workaround. This needs to work in an interactive job with X-forwarding to be useful.
David_A_Intel1
Employee
115 Views

I don't believe so.  Here is one description I found:

"You need to enable X11 forwarding/ tunneling in your ssh client in order to run an X-windows server software securely. This method tunnels your X11 packets (the data related to displaying the GUI interface on your computer screen) through your encrypted ssh connection."

and another:

"The remote X client application will then make a connection to the user's local X server, providing display and input to the user."

The X server on your local system simply renders the graphics that would normally be rendered on the remote system.  What X server are you using?

 

Jess
Beginner
115 Views
This is all standard RHEL 6 software, both on the desktop and the HPC system. I haven't gone to read any descriptions, but my experience of how it has worked for the past few years is as I have described above. If the local system browser is running, then attempting to open a link causes the local system browser to open it, not the one on the remote machine. The only way I have ever been able to change this is to close the local browser window, which is not very practical normally as I usually have applications I have to access through it for work.
David_A_Intel1
Employee
115 Views

okay, I now see that you are going Linux-to-Linux.  My setup is Windows-to-Linux.

Can you give me the ssh command you are using to start the remote connection?  Basically, how are you specifying X-forwarding?  I will test it on our lab systems and see if I get the same behavior.

David_A_Intel1
Employee
116 Views

okay, actually, i have duplicated this issue.  I will submit a defect against the product.

a workaround would be to install the VTune Amplifier on your host system, as well.

View solution in original post

Jess
Beginner
115 Views
I could install it on some of the hosts, but only those that are managed by central IT. That would only solve the problem of getting the help to display though. You can't really use hardware counters from the compute nodes on the HPC system on your local desktop, so that would mean running it in two places, and I think that could confuse a lot of people.
David_A_Intel1
Employee
115 Views

Use remote collection.  See the help topic "Collecting Data Remotely from the VTune Amplifier GUI".

David_A_Intel1
Employee
115 Views

actually, I'm not sure I understand what your last reply means.  when I remote into system A and launch VTune Amplifier, the GUI is displayed on system B, but the app has access to system A's file system and appears to be running on system A.

I have two different versions of VTune Amplifier installed on two different systems.  When I remote into system A and launch VTune Amplifier, I see the version installed on system A running on system B.  And, when I "open" a project, I see the projects on system A, not system B.  So, I don't see a problem. :(

Peter_W_Intel
Employee
115 Views

There are two approaches to collect performance on the target Linux*:

1. One is to use ssh to log on the target system (use amplxe-cl) but X11 for GTK* is usable(forwarded), VTune GUI cannot be used; Should use vnc-client from the host to connect to the target Linux* to run amplxe-gui, I posted steps at Fri, 10/10/2014 - 14:53

2. If you want to remote data collect, please read this blog for your quick reference.

Please, distinguish these two methods - first one is to run data collector on the target Linux, log-on from host Linux*; second one is to run data collector from the host, send requests to the target Linux*   

Jess
Beginner
115 Views
Well, we can't use VNC for this. For a start, the compute nodes (the target systems) are not visible from outside the cluster, so you couldn't connect to them even if you did try to use VNC. Remote data collection could work for the more advanced users. The confusion is just likely to occur simply because a surprising number of people don't understand that the remote system is remote, and become confused by the whole local/remote files thing. I'd like to avoid that if possible. I think a better workaround would be if the documentation could be installed in the same location on the desktops. That way the help would work as they expect. This would mean packaging it separately so that we can push it out to our managed desktop systems.
Reply