Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Andrey_Vladimirov
New Contributor III
258 Views

Wrong number of logical processors detected by VTune in a Skylake Xeon

I am running VTune 2018 (build 525261) on CentOS 7.4 with kernel 3.10.0-693. The processor is a 2-way Intel Xeon Gold 6128 (2 sockets, 6 cores per socket, hyper-threading enabled for a total of 24 logical CPUs). Problem: in all analysis modes other than basic hotspots, VTune thinks that I have 36 logical processors. This is not critical, but annoying because it skews the ranges and colors in concurrency histograms and in the rows of bottom-up/top-down views. Is there anything I can do to override this?

Here is basic hotspots (no problem here):

Screen Shot 2018-02-20 at 4.08.38 PM.png

 

Here is the same exact project on the same system in advanced hotspots (here is the problem: see how the Ideal range extends to 36 logical CPUs):

Screen Shot 2018-02-20 at 4.09.20 PM.png

 

This is what VTune thinks about my processor in the Summary tab of Advanced Hotspots (36 logical CPUs is wrong, I have 24):

Screen Shot 2018-02-20 at 4.09.34 PM.png

And here is what "lscpu" thinks about my processor (notice 24 logical CPUs):

Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                24
On-line CPU(s) list:   0-23
Thread(s) per core:    2
Core(s) per socket:    6
Socket(s):             2
NUMA node(s):          2
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 85
Model name:            Intel(R) Xeon(R) Gold 6128 CPU @ 3.40GHz
Stepping:              4
CPU MHz:               2219.828
CPU max MHz:           3700.0000
CPU min MHz:           1200.0000
BogoMIPS:              6800.00
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              1024K
L3 cache:              19712K
NUMA node0 CPU(s):     0-5,12-17
NUMA node1 CPU(s):     6-11,18-23
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 fma cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch epb cat_l3 cdp_l3 intel_pt tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm cqm mpx rdt_a avx512f avx512dq rdseed adx smap clflushopt clwb avx512cd avx512bw avx512vl xsaveopt xsavec xgetbv1 cqm_llc cqm_occup_llc cqm_mbm_total cqm_mbm_local dtherm ida arat pln pts hwp hwp_act_window hwp_epp hwp_pkg_req

 

0 Kudos
2 Replies
258 Views

Im seeing a similar problem running VTune on my Ubuntu 18.04 machine with a Core-i7 and I think VTune is reporting wrong number of logical cpus.

(Im using "Intel VTune Profiler 2020 - Product build: 605129")

What I have is this core with 12 logical threads(HT enabled) - https://ark.intel.com/content/www/us/en/ark/products/126686/intel-core-i7-8700-processor-12m-cache-up-to-4-60-ghz.html?wapkw=core%20i7%208700

But the VTune reports the below(see picture), saying 24 logical cpus!!

 

 

Jennifer_D_Intel
Employee
258 Views

Hi Senthil,

Your problem is similar but the root cause appears to be different, as it is not using the sampling driver. I tested on a similar system with no issues, and passed your information to the development team. It looks like you are just running a local hotspots collection with user-mode sampling? Are you able to send the full result folder via private message?

Reply