Community
cancel
Showing results for 
Search instead for 
Did you mean: 
138 Views

amplxe: Error: [Instrumentation Engine]: Pin is out of memory

amplxe: Error: [Instrumentation Engine]: Pin is out of memory
amplxe: Collection failed.
amplxe: Internal Error

Environment:

  • Ubuntu 18.04, both in VirtualBox and bare metal
  • vtune_amplifier_2019.6.0.602217
  • 128GB system RAM, not remotely close to exhausted

Source Code:

https://github.com/EOSIO/eos

Run

scripts/eosio_build.sh -o RelWithDebInfo

Run

scripts/eosio_install.sh

Run

H=`pwd`
DATE=`which date`
TIMESTAMP=`$DATE +"%Y-%m-%d-%H-%M-%S"`
NODEOS=~/eosio/2.0/bin/nodeos
NVER=`$NODEOS --version`
/opt/intel/vtune_amplifier/bin64/amplxe-cl -c hotspots -app-working-dir=$H -data-limit=2048 -finalization-mode=full \
  -inline-mode=on -mrte-mode=native -target-duration-type=veryshort \
  -r $H/hotspots-$NVER-$TIMESTAMP -- \
  ~/eosio/2.0/bin/nodeos --data-dir "$H/data" --config-dir "$H/config" \
  --wasm-runtime eos-vm --eos-vm-oc-enable --force-all-checks --disable-replay-opts \
  --terminate-at-block 1000 \
  > "$H/stdout.txt" 2> "$H/stderr.txt"

 

0 Kudos
2 Replies
138 Views

Hi Jonathan,

Can you please upgrade to the recently released VTune Profiler 2020 version (available at Intel Registration Center) and verify if the problem is reproducible? Try on bare metal first.

If the problem persists, please set the debug variables below and then re-run the amplxe-cl collection.

TPSS_DEBUG=1

AMPLXE_LOG_LEVEL=TRACE

 

Once collection failed, please zip the result folder and share here for further exploration on our side. 

Regards, Katya

138 Views

The problem did persist.  Attached is the contents of the results directory generated during a bare metal run, with the '-bad' suffix auto-appended by the software.

 

Thanks,

-Jonathan