Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
3 Views

how to view samples along timeline?

Hi,

I am using VTune for Linux to observe caches, say L1D misses. Right now I can see the total number of misses, but how can I view the number of L1D misses along time line( e.g.: time period1: 2 misses; time period2: 3 misses...)? Thanks a lot!

Aries

0 Kudos
7 Replies
Highlighted
Beginner
3 Views

Hi,

I am using VTune for Linux to observe caches, say L1D misses. Right now I can see the total number of misses, but how can I view the number of L1D misses along time line( e.g.: time period1: 2 misses; time period2: 3 misses...)? Thanks a lot!

Aries


Haha, perhaps I've got the solution after looking through the manual.

sea |
Show events as one of the following:
1 for samples
2 for event counts
8 for % Activity/run
11 for complete information

0 Kudos
Highlighted
Employee
3 Views

Hi,

I am using VTune for Linux to observe caches, say L1D misses. Right now I can see the total number of misses, but how can I view the number of L1D misses along time line( e.g.: time period1: 2 misses; time period2: 3 misses...)? Thanks a lot!

Aries

Usually I used Sampling Over Time View (SOT) in VTune? Performance Analyzer for Windows*.

This function is to provide filtered new data based on your preferred time range. However it doesn't workin VTune? Performance Analyzer for Linux.

The user could do "vtl packpack-name" to generateVXP file, which can be import into VTune? Performance Analyzer for Linux*

Regards, Peter

0 Kudos
Highlighted
3 Views

the latest version of vTune (9.1) should fix this issues on linux. However I did not test it so far. I will send out a note later today after checking this feature on linux.

0 Kudos
Highlighted
Employee
3 Views

the latest version of vTune (9.1) should fix this issues on linux. However I did not test it so far. I will send out a note later today after checking this feature on linux.

Sampling over time view is enabled by default in the VTune analyzer for Linux* 9.1. It was also available in versino 9.0 Update 7 and later by setting the VTUNE_OVER_TIME environment variable. This is documented in the Release Notes.

0 Kudos
Highlighted
Beginner
3 Views

Sampling over time view is enabled by default in the VTune analyzer for Linux* 9.1. It was also available in versino 9.0 Update 7 and later by setting the VTUNE_OVER_TIME environment variable. This is documented in the Release Notes.

Thank you all. My VTune version is 9.0 Update 7. With your helps, I have solved the problem by setting VTUNE_OVER_TIME to 1, finally got the Over Time View ( the view is really cool!).

by the way, here is the link of how to set VTUNE_OVER_TIME, which some green hand like me will find helpful:-)

http://software.intel.com/en-us/forums/showthread.php?t=58461

Thank you again!

Aries

0 Kudos
Highlighted
3 Views

Sampling over time view is enabled by default in the VTune analyzer for Linux* 9.1. It was also available in versino 9.0 Update 7 and later by setting the VTUNE_OVER_TIME environment variable. This is documented in the Release Notes.

I was referring to the drill down feature in Sampling Over Time for certaintime sub-frames. That does not work for me in VTune 9.1 for Linux. AndI still need the VTUNE_OVER_TIME variable set under Linux (SLES) otherwise there is no SOT button in the GUI.

0 Kudos
Highlighted
Employee
3 Views

Sampling over time view is enabled by default in the VTune analyzer for Linux* 9.1. It was also available in versino 9.0 Update 7 and later by setting the VTUNE_OVER_TIME environment variable. This is documented in the Release Notes.

I was referring to the drill down feature in Sampling Over Time for certain time sub-frames. That does not work for me in VTune 9.1 for Linux. And I still need the VTUNE_OVER_TIME variable set under Linux (SLES) otherwise there is no SOT button in the GUI.

Yeah, thanks. I just learned from a colleague that the fix did not get into 9.1 to enable sampling over time view, by default. :( You still need to set the variable to 1.

0 Kudos