Community
cancel
Showing results for 
Search instead for 
Did you mean: 
David_M_17
Novice
463 Views

memory access fails on knl

Jump to solution

I am trying to run VTune memory access analysis on KNL.  I have tried this on two different KNL systems - run by different organizations and it fails the same way on both systems - so it is not unique to one system or organization.   I run by entering:

amplxe-cl -collect memory-access -result-dir dir1 -user-data-dir dir2 ./a.out

When I do this I get the error:

amplxe: Warning: To profile kernel modules during the session, make sure they are available in the /lib/modules/kernel_version/ location.
amplxe: Error: Failed to execute sep process. Data collection is interrupted.
amplxe: Internal Error

(I am not interested in profiling the kernel modules.  I will be content with just analyzing my code - is it such that without profiling kernel modules memory access analysis can not be done?)

To verify that sep is loaded I followed advice from other forum thread and ran lsmod | grep.  Here is the output from that command:

lsmod | grep sep
sep4_0                767375  516
socperf2_0             33414  1 sep4_0

Here is information about VTune version:

amplxe-cl -version
Intel(R) VTune(TM) Amplifier XE 2017 Update 2 (build 499904) Command Line Tool
Copyright (C) 2009-2017 Intel Corporation. All rights reserved.

 

0 Kudos
1 Solution
463 Views

Hello David,

Please follow the administration instructions from product help:

https://software.intel.com/en-us/sep_driver

See "Managing the Sampling Driver for Linux Targets"

Regards, Katya

View solution in original post

5 Replies
463 Views

Hello,

Can you please run sep directly and provide output from below command lines?

1. sep -version

2. sep -start -app ./a.out

Regards, Katya

David_M_17
Novice
463 Views

1- sep -v version:

bash-4.2$ sep -version
Sampling Enabling Product version: 4.0 built on Feb  7 2017 02:38:12
SEP User Mode Version: 4.0.0
SEP Driver Version: Error retrieving SEP driver version
PAX Driver Version: Error retrieving PAX driver version
Platform type: 102
CPU name: Intel(R) Processor code named Knights Landing
PMU: knl

 

2- sep -start -app ./a.out

sep -start -app ./stream_c.exe
Failed to connect to PMU reservation service (PAX). Please check if driver     is loaded with appropriate permissions

 

So what needs to be changed to connect to PMU reservation service?

Thank you!

 

464 Views

Hello David,

Please follow the administration instructions from product help:

https://software.intel.com/en-us/sep_driver

See "Managing the Sampling Driver for Linux Targets"

Regards, Katya

View solution in original post

David_M_17
Novice
463 Views

Thank you.  I have this working as expected now on one of the KNL systems.  This is showing me the information I expected.

David_M_17
Novice
463 Views

Please allow me one more question.  When I run memory-access NMI is turned off during the collection.  On CentOS that generates these warning messages (they repeat until the data collection ends).   Is this normal?  Is it unique to CentOS?  (yes the kernel successfully continues along in a dazed and confused state until vtune is done)

amplxe: Warning: To enable hardware event-base sampling, VTune Amplifier has disabled the NMI watchdog timer. The watchdog timer will be re-enabled after collection completes.
amplxe: Warning: The specified data limit of 500 MB is reached. Data collection is stopped.

Message from syslogd@localhost at Apr  7 10:06:49 ...
 kernel:Uhhuh. NMI received for unknown reason 2d on CPU 5.

Message from syslogd@localhost at Apr  7 10:06:49 ...
 kernel:Do you have a strange power saving mode enabled?

Message from syslogd@localhost at Apr  7 10:06:49 ...
 kernel:Dazed and confused, but trying to continue

Reply