Community
cancel
Showing results for 
Search instead for 
Did you mean: 
benjamin_gu
Beginner
46 Views

resolving for gcc takes forever

Hi, my vtune finalization step takes forever to run with a message "resolving for gcc". In beginning of my program, i generate some c-code and use gcc to compile it. is this a show-stopper? Is there anyway i can work around this? for example, force vtune to stop resolving for gcc symbols?
thanks,
Ben
0 Kudos
3 Replies
Peter_W_Intel
Employee
46 Views

Ben,

The possibility is that you ran VTune Amplifier XE for long time, so it took many time to finalize results.Thetoo allows us to stop data collection, butnot in finalizing stage.

You can use "duration" to control time of data collection, if your application is forever running. For example,

amplxe-cl -collect concurrency -duration 30 -r result-directory -- app

BTW, please use latestVTune Amplifier XE 2011 Update 2.

Regards,Peter
benjamin_gu
Beginner
46 Views

Hi Peter,
thanks a lot for the quick reply. No i didn't run vtune for long time, only a couple of minutes maybe it is considered long already?). I did a few experiments, and found out that vtune runs ok as long as my program doesn't invoke gcc to compile generated c-code. So you think my problem will go away by running the newer version of vtune?
thanks,
Ben
Peter_W_Intel
Employee
46 Views

If you ran program shortly, you don't need to specify "-duration" option.

I still suggest you to upgrade to latest Update 2 - as I know the performanceon finalizing is better than before.

Regards, Peter