Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
13 Views

some issues using vtune 7.2

Hi,

I am running intel vtune version 7.2 for Windows. My OS is windows XP. I'm using visual studio .NET 2005.

1) I just ran into an error while trying to drill down into function profiling:

"A serious error occurred in file D:Vtune5.0analyzersrcSVDPVTSvdp.cpp at line 3623 (Unrecognized architecture for this module. Check if the file uses Intel Architecture, if it does, it may be corrupted. The Source View window will now be closed.). The failed HRESULT that produced this error is 0x80004005. Please contact technical support."

2) I found what appears to be a vtune API in C:Program FilesIntelVTuneAnalyzer. There are some include files and libraries there. Is there documentation for this API anywhere other than the header files?

3) I used the API as best as I could considering the missing documentation. It produced a "tb5" file. When I open this in vtune, if I don't create a project, vtune hangs when I try to drill down to see what functions were taking up time. If I do create a new project, then the first time I drill down into my executable, VTune crashes. If I reopen the project, it works.

4) I'm having some trouble with VTune not getting the function names.. It's just showing me function addresses. I'm not sure why this is; the symbols are in the same folder as my executable. I don't see any error in vtune. How can I find out why it can't see my symbols?

thanks,
sam

0 Kudos
2 Replies
Highlighted
Employee
13 Views

Hi sam:

A quick review of the Release Notes (available from the Help menu) will show that Visual Studio* 2005 is not supported by version 7.2 of the VTune analyzer for Windows*. Also, if you are running Windows* XP Service Pack 2, this was not supported by version 7.2, either. :-(

Currently, version 9.0 Update 7 of the VTune analyzer for Windows* is available at the Intel Registration Center to registered users whose support agreement is current. Version 9.0 supports both Windows XP SP2, as well as Vista*, and Visual Studio 2005. If you update your installation and still have problems, please report them at Intel Premier Support.

Also, the APIs are documented in the online help, see "Pause/Resume APIs."

0 Kudos
Highlighted
Beginner
13 Views

Dear Intel-

So I've upgraded my vtune. Here is my new version:

Intel VTune Performance Analyzer 9.0
Build:719

I'm still running into the following issues:

1) Sometimes when I create a new project, after going through the wizard and clicking the "finish" button, I receive this error: "An unhandled exception occurred while processing the command." This happens when I create a "Sampling Wizard" application, and seems to be related to having the "Modify default configuration when done with wizard" check box clicked, but it doesn't happen 100% of the time. When it does happen, the project isn't saved, so you can't run anything.

2) When I finally was able to create a project, I ran the profile and collected about 20 seconds worth of profiling data. Afterwards, vtune became inactive for about 3 minutes. My CPU was pegged. Why is this phase so slow? I've used AMDs code analyst to do profiles of similar length, and the code analyst UI is snappy. Can we at least get some sort of progress bar here?

3) After vtune finally woke back up, it still didn't load any of the symbols for my executable. I'm not sure what I have to do; the symbols are sitting in the same folder as the executable. I don't see any error messages about the symbols--it's just showing me raw addresses, no function names. What do I have to do here? I switched to code analyst after trying to use vtune, and it located the symbols and source code without problems.

-sam

0 Kudos