Analyzers
Talk to fellow users of Intel Analyzer tools (Intel VTune™ Profiler, Intel Advisor)
5064 Discussions

vtune opening wrong source code file

Sylvain
Beginner
2,252 Views

I use vtune 2021 to analyze a c++ program I wrote compiled with gcc under linux. Problem is when editing the main function, the source code file opened is an header file and not the ccp file.
I added the source file path but does not help.
I checked that I compiled with -g.
I tried adding all those flags, but did not help :
-shared-libgcc
-gdwarf-3
-fno-eliminate-unused-debug-symbols
-femit-class-debug-always
-fno-merge-debug-strings
-fvar-tracking
-pipe
-fvar-tracking-assignments
-gcolumn-info
-gstatement-frontiers
-gvariable-location-views
-fno-eliminate-unused-debug-types
-fno-omit-frame-pointer

 

Any idea what I did wrong ? Or is it a bug ?

 

For example on command line I get

vtune -report hotspots -column=source,instructions,cpi -r /home/sylvain/intel/vtune/projects/Test\ SIMD/r007hs -source-search-dir=/home/sylvain/Recherche/Development/optim_robot_linux/test_vector_matrix_simd/ -search-dir=/home/sylvain/Recherche/Development/optim_robot_linux/test_vector_matrix_simd/bin/Release/ -search-dir=/home/sylvain/Recherche/Development/optim_robot_linux/test_vector_matrix_simd/obj/Release/
vtune: Using result path `/home/sylvain/intel/vtune/projects/Test SIMD/r007hs'
vtune: Executing actions 75 % Generating a report Column filter is ON.
Function Instructions Retired Microarchitecture Usage:CPI Rate Source File
----------------------------------------------------------------------------------------------------------------------------------- -------------------- -------------------------------- ---------------------
main 29,952,000,000 0.433 DenseStorage.h
_mm256_fmadd_pd 894,400,000 0.477 fmaintrin.h
_mm256_fmadd_pd 405,600,000 0.782 fmaintrin.h
_mm256_load_pd 270,400,000 1.240 avxintrin.h
Eigen::internal::scalar_sum_op<double, double>::operator() 444,600,000 0.462 BinaryFunctors.h
_mm_add_sd 361,400,000 0.367 emmintrin.h
_mm256_add_pd 195,000,000 0.467 avxintrin.h
boost::numeric::ublas::vector<double, boost::numeric::ublas::unbounded_array<double, std::allocator<double>>>::iterator::operator= 0 vector.hpp
UME::SIMD::SIMDVec_f<double, (unsigned int)4>::assign 423,800,000 0.239 UMESimdVecFloat64_4.h
_mm256_add_pd 241,800,000 0.344 avxintrin.h
boost::numeric::ublas::vector<double, boost::numeric::ublas::unbounded_array<double, std::allocator<double>>>::iterator::operator++ 0 vector.hpp
boost::numeric::ublas::vector<double, boost::numeric::ublas::unbounded_array<double, std::allocator<double>>>::iterator::operator= 5,200,000 3.500 vector.hpp
boost::numeric::ublas::vector<double, boost::numeric::ublas::unbounded_array<double, std::allocator<double>>>::iterator::operator+= 15,600,000 1.000 vector.hpp
prepare_exit_to_usermode 0 [Unknown]
__do_softirq 0 0.000 [Unknown]
boost::numeric::ublas::vector<double, boost::numeric::ublas::unbounded_array<double, std::allocator<double>>>::iterator::operator+= 2,600,000 1.000 vector.hpp

...

0 Kudos
8 Replies
Denis_M_Intel
Employee
2,242 Views

It could be caused by 2 possible reasons:
 1. quality of the debugging information generated by compiler (What compiler version is used?);
or
 2. improper handling of the debug info in VTune in some cases;
To understand what is wrong exactly we need a reproducer: this binary file + VTune result directory.

You can also try to verify correctness of the debug information in your executable file with Linux tools like addr2line.

0 Kudos
Sylvain
Beginner
2,229 Views

Thank you for your quick answer

 

Find attached like proposed the binary and the vtune result directory. I looked at addr2line, but do not know which address I should check.

 

Best regards,

 

Sylvain

0 Kudos
Denis_M_Intel
Employee
2,205 Views

Thank you.
I've downloaded the attachments and reproduced this issue. I'll open an internal bug request on VTune.

 

Denis. 

0 Kudos
AthiraM_Intel
Moderator
2,103 Views

Hi,


Sorry for the delay.


The issue will be fixed in future release.



Thanks.



0 Kudos
AthiraM_Intel
Moderator
1,781 Views

Hi,

 

The issue is resolved with the latest release.

 

VTune 2021.9.0 is available for download as a standalone tool at https://www.intel.com/content/www/us/en/developer/articles/tool/oneapi-standalone-components.html#vtune or as part of oneAPI Base Toolkit 2021.4 at  https://www.intel.com/content/www/us/en/developer/tools/oneapi/base-toolkit-download.html

 

Could you please try with the latest release and let us know whether your issue is resolved?

 

Thanks.

 

0 Kudos
AthiraM_Intel
Moderator
1,699 Views

Hi,


Is your issue resolved? Could you please give us an update?



Thanks.


0 Kudos
AthiraM_Intel
Moderator
1,589 Views

Hi,


I have not heard back from you. This thread will no longer be monitored by Intel. If you need further assistance, please post a new question. 



Thanks


0 Kudos
Sylvain
Beginner
1,256 Views

Hello,

Sorry for the late answer, I was busy on other work.

The new version indeed solves the problem.

Thanks, best regards,

Sylvain

0 Kudos
Reply