Embedded Connectivity
Intel network controllers, Firmware, and drivers support systems
867 Discussions

can not disable autoneg on i225 device under linux with kernel 5.10.52

bsan83
Beginner
1,110 Views

Hi, 

 

I tried to set the speed at 100Mbit/s and autonegatiation off on a i225 under linux using ethtool.

I am running these commands:

 

/* Check out the link/autoneg/speed status */

root@board:~# ethtool enP1p6s0 |grep Auto-neg
Auto-negotiation: on
root@board:~# ethtool enP1p6s0 |grep Link
Link detected: yes
root@board:~# ethtool enP1p6s0 |grep Speed
Speed: 1000Mb/s

 

/* Set the link/autoneg/speed to desired values */

root@board:~# ethtool -s enP1p6s0 speed 100 autoneg off

 

/* ReCheck out the link/autoneg/speed status */

root@board:~# ethtool enP1p6s0 |grep Auto-neg
Auto-negotiation: on
root@board:~# ethtool enP1p6s0 |grep Link
Link detected: yes
root@board:~# ethtool enP1p6s0 |grep Speed
Speed: 1000Mb/s

 

Please Note that the ehttool command runs well on a i210 device.

 

Thanks in advance for your answer

 

0 Kudos
3 Replies
CarlosAM_INTEL
Moderator
1,101 Views

Hello,  @bsan83:

Thank you for contacting Intel Embedded Community.

We want to address the following questions to understand this situation:

Could you please clarify if this request is related to an Intel® Ethernet Controller I225-V design developed by you or is a NIC or add-in card developed by a third-party company?

What is the name of the manufacturer, the part number, and where we can find the information if this request is related to a third-party design?

Could you please let us know the Operating System (OS) related to this situation and its version?

What is the "ethtool" related to this situation, its document number, and its version?

We are waiting for your answer.

Best regards,

@CarlosAM_INTEL.

0 Kudos
anz123
Beginner
763 Views

I have the same issue.

Its the i225-V controller with built in PHY. 

Without supporting the autoneg off the link comes up as half-duplex if the peer port does not have auto-neg on. And therefore not functional for any practical purpose.

thanks.

 

0 Kudos
Diego_INTEL
Moderator
709 Views

Hello @anz123,

 

Thank you for contacting Intel Embedded Community.

 

Looking internally it seems that is related to the driver that it doesn't have force mode as with the i210.

 

Best regards,

 

@Diego_INTEL 

0 Kudos
Reply