Embedded Intel Atom® Processors
Intel Atom® Hardware, Software, Firmware, Graphics
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
1007 Discussions

Problem in getting GPIO Interrupt from Intel(R) Celeron(R) CPU J1900

Shathish
Beginner
492 Views

Hi,

 we currently using a board with "Intel Bay Trail Celeron J1900 CPU" processor.

 Below is the OS and other information we are using on the board

  • CPU Model name "Intel(R) Celeron(R) CPU J1900 @ 1.99GHz"
  • OS NAME "Ubuntu"
  • OS VERSION "20.04.1 LTS (Focal Fossa)"
  • LINUX VERSION "5.4.0-74-generic "

 We try to build an application to get the automatic trigger from GPIO input and to act upon that

 We try the application build using ".NetCore" which we already test in Raspberry PI board for the above functionality in this board but it is not working and it is working correctly in the Raspberry PI Board

 While we try to export the GPIO Pin it show us error "bash - echo: write error: invalid argument"

 Kindly inform us what we have to do in order to get interrupt from the system

 Hereby I attach the GPIO Pin information given by the board manufacturer for your reference

 

Thanks in advance for any help to get through this.

Regards,

Shathish

0 Kudos
3 Replies
CarlosAM_INTEL
Moderator
459 Views

Hello, @Shathish:

Thank you for contacting Intel Embedded Community.

You need to have a Resource and Design Center (RDC) privileged account to provide you the information that may help you.

The RDC Account Support form is the channel to process your account update process by filling out the form stated on the following website:

https://www.intel.com/content/www/us/en/forms/support/my-intel-sign-on-support.html

Best regards,

@CarlosAM_INTEL.

Shathish
Beginner
450 Views

Hello @CarlosAM_INTEL.

Thanks for your reply 

i tried to fill the support form oh the link you given below

https://www.intel.com/content/www/us/en/forms/support/my-intel-sign-on-support.html

 

But after submit the form it always show me site can't be reached error 

Kindly advice me what can I do in order to get support for my query 

Thanks in advance

CarlosAM_INTEL
Moderator
412 Views

Hello, @Shathish:

Thanks for your reply.

You should ensure that all features work using the latest version of one of the following browsers: Microsoft Edge, Mozilla Firefox*, Google Chrome. Also, enabling cookies in your browser and clearing your browser cache. Refer to your browser help for instructions.

In case that you want more support with the reported situation, you should use the chat support that can be found on the following website:

https://intelsupportchat.secure.force.com/icslivechat/ICS_A_E_English_Chat_Page

You should verify the status of support for the processor related to your questions via chat support portal.

Best regards,

@CarlosAM_INTEL.

Reply