Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,050 Views

need advice from intel embedded community

Jump to solution

I have an Acer A0751h, I only run linux on my machines, and prefer to keep the software up to date. I run the latest stable kernel (currently 2.6.32.8), and would prefer to run latest X server (I am currently forced to stay on 1.6.3, but would really like to move to 1.7)

I just have one question. Should I cut my losses and try to return/sell this netbook, or should I hold out for IEGD drivers that will fit my platform?

I was able to compile the latest 10.3 driver, but ran into issues with the driver's drm not matching up with the kernels drm. I understand the enormity of what you are trying to do. I just need to know cause if I wait too long, I will not be able to recover any portion of the investment I made on this hardware.

I appreaciate your time and advice,

cgriffith

0 Kudos

Accepted Solutions
Highlighted
Employee
52 Views

Hi,

Here is the shortest path to get this working:

1) Connect external monitor w/ your Netbook

2) Download the Moblin-IVI image with IEGD from: http://moblin.org/projects/2.1-ivi-project-releases http://moblin.org/projects/2.1-ivi-project-releases" target="_blank">http://moblin.org/projects/2.1-ivi-project-releases

3) Copy the enclosed xorg.conf file to /etc/X11/xorg.conf

4) Reboot w/o external monitor

Let me know how it goes.

ishu

View solution in original post

0 Kudos
7 Replies
Highlighted
Employee
52 Views

I've Moblin 2.1 (2.6.31 kernel, 1.6.4 X server) and IEGD 10.2/10.3 working on this Acer Netbook perfectly fine. You should be able to get this working with 1.7 X server as welll but mileage may vary.

The trick is to make sure you modify your xorg.conf file for the LVDS panel for this Netbook.

For porting IEGD to any other distro, make sure you follow: http://edc.intel.com/Download.aspx?id=2796&returnurl=/Software/Downloads/IEGD/default.aspx http://edc.intel.com/Download.aspx?id=2796&returnurl=/Software/Downloads/IEGD/default.aspx" rel="nofollow" target="_blank">http://edc.intel.com/Download.aspx?id=2796&returnurl=/Software/Downloads/IEGD/default.aspx

ishu

0 Kudos
Highlighted
Beginner
52 Views

Ishu,

I sincerely appreciate your response. So I will give it a few more go's before I throw in the towel. Just a few points I need to get clarified from your post.

I tried to follow the instructions in the pdf document you suggested. That is how I even got them installed on my system. I also followed the add on instructions provided at nanoant.com. I think that the intel document is well written and very helpful. Eventually everything compiled, but drm_test would fail.

1.) you say you have Moblin 2.1 installed: I have just downloaded moblin-2.1-final-20091103-002.img, but the release notes for that say it is not supported on my hardware. I will see if I can install it, then install the IEGD 10.3 drivers with it. As an asside, a few weeks ago I downloaded the moblin-2.1-PR-Final-ivi-201002090924.img and tried that, but ran into many issues.

2.) can you recommend/supply your xorg.conf.

3.) You say I should be able to get this working with 1.7 X server, but I really don't see how you can say that. The x server driver is binary and is not compatible with 1.7.x X server. I have tried X server 1.7 and the server crashes on startup.

thank you for your time,

cgriffith

0 Kudos
Highlighted
Beginner
52 Views

@ishu

Still hoping you can take a second and answer my questions. I am not gonna install moblin unless I understand which one and why.

0 Kudos
Highlighted
Employee
53 Views

Hi,

Here is the shortest path to get this working:

1) Connect external monitor w/ your Netbook

2) Download the Moblin-IVI image with IEGD from: http://moblin.org/projects/2.1-ivi-project-releases http://moblin.org/projects/2.1-ivi-project-releases" target="_blank">http://moblin.org/projects/2.1-ivi-project-releases

3) Copy the enclosed xorg.conf file to /etc/X11/xorg.conf

4) Reboot w/o external monitor

Let me know how it goes.

ishu

View solution in original post

0 Kudos
Highlighted
Beginner
52 Views

Since moblin repo is shut down, can someone forward me 'moblin-2.1-pr-final-ivi-201002090924.img' or direct me to another place where I can download it? Many thanks.

0 Kudos
Highlighted
Beginner
52 Views

@ishu

Just wanted to give you an update as you had asked. I did install the moblin ivi final release with iegd drivers installed. But I struggled to long getting a version of mplayer installed that I could use that I abandoned it.

Instead, I started with a fresh install of Archlinux. With help from community, we got the IEGD 10.3.1 drivers installed on kernel 2.6.31 and xserver 1.6.3.901. Although these software products are considered out-of-date for this distro, the rest of my install is up to date. I then found an mplayer-vaapi and libva provided by the splitted-desktop folks. As of now, I am very satisfied except for one issue.

I am not able to suspend/hibernate. I have seen other posts on this forum that notes this is a known issue. I was wondering if I should contiue try different suspend hooks to see if I can make that work, or it the driver just not able to handle it at this time.

Also, I am early awaiting the next release. Thank you all for what you have provided. It is very close to being everything I need.

0 Kudos
Highlighted
Employee
52 Views
0 Kudos