Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
255 Views

82599ES virtual-function unicast promisc mode

Dear all,

 

I am running a VNF using SR-IOV with the 82599ES NIC.

The VNF needs to receive traffic, which is unequal to the adapters MAC.

As of now, the VNF is not receiving a single unicast-packet due to the mac-mismatch.

 

So to me I do need promisc-mode for given virtual-function.

 

My tries to get the same configured are failing, so kindly asking for help.

 

root@ubuntu-cg:~# dev=ens4f0

root@ubuntu-cg:~# vf=0

root@ubuntu-cg:~# ethtool -i $dev

driver: ixgbe

version: 5.6.3

firmware-version: 0x681b0001, 1.853.0

expansion-rom-version: 

bus-info: 0000:81:00.0

supports-statistics: yes

supports-test: yes

supports-eeprom-access: yes

supports-register-dump: yes

supports-priv-flags: yes

 

 

root@ubuntu-cg:~# ethtool -k $dev

Features for ens4f0:

rx-checksumming: on

tx-checksumming: on

    tx-checksum-ipv4: on

    tx-checksum-ip-generic: off [fixed]

    tx-checksum-ipv6: on

    tx-checksum-fcoe-crc: on [fixed]

    tx-checksum-sctp: off [fixed]

scatter-gather: on

    tx-scatter-gather: on

    tx-scatter-gather-fraglist: off [fixed]

tcp-segmentation-offload: on

    tx-tcp-segmentation: on

    tx-tcp-ecn-segmentation: off [fixed]

    tx-tcp6-segmentation: on

udp-fragmentation-offload: off [fixed]

generic-segmentation-offload: on

generic-receive-offload: on

large-receive-offload: off [fixed]

rx-vlan-offload: on

tx-vlan-offload: on

ntuple-filters: off

receive-hashing: on

highdma: on [fixed]

rx-vlan-filter: on

vlan-challenged: off [fixed]

tx-lockless: off [fixed]

netns-local: off [fixed]

tx-gso-robust: off [fixed]

tx-fcoe-segmentation: on [fixed]

tx-gre-segmentation: off [fixed]

tx-ipip-segmentation: off [fixed]

tx-sit-segmentation: off [fixed]

tx-udp_tnl-segmentation: off [fixed]

fcoe-mtu: off [fixed]

tx-nocache-copy: off

loopback: off [fixed]

rx-fcs: off [fixed]

rx-all: off [fixed]

tx-vlan-stag-hw-insert: off [fixed]

rx-vlan-stag-hw-parse: off [fixed]

rx-vlan-stag-filter: off [fixed]

l2-fwd-offload: off [fixed]

busy-poll: on [fixed]

hw-tc-offload: off

 

I am wondering why the privacy-flags only show the flow-director and nothing more??

 

root@ubuntu-cg:~# ethtool --show-priv-flags $dev

Private flags for ens4f0:

flow-director-atr: off

 

virtual-functions are enabled

===================

root@ubuntu-cg:~# virsh nodedev-dumpxml pci_0000_81_00_0

<device>

 <name>pci_0000_81_00_0</name>

 <path>/sys/devices/pci0000:80/0000:80:01.0/0000:81:00.0</path>

 <parent>pci_0000_80_01_0</parent>

 <driver>

  <name>ixgbe</name>

 </driver>

 <capability type='pci'>

  <domain>0</domain>

  <bus>129</bus>

  <slot>0</slot>

  <function>0</function>

  <product id='0x10fb'>82599ES 10-Gigabit SFI/SFP+ Network Connection</product>

  <vendor id='0x8086'>Intel Corporation</vendor>

  <capability type='virt_functions' maxCount='63'>

   <address domain='0x0000' bus='0x81' slot='0x10' function='0x0'/>

   <address domain='0x0000' bus='0x81' slot='0x10' function='0x2'/>

   <address domain='0x0000' bus='0x81' slot='0x10' function='0x4'/>

   <address domain='0x0000' bus='0x81' slot='0x10' function='0x6'/>

   <address domain='0x0000' bus='0x81' slot='0x11' function='0x0'/>

   <address domain='0x0000' bus='0x81' slot='0x11' function='0x2'/>

   <address domain='0x0000' bus='0x81' slot='0x11' function='0x4'/>

   <address domain='0x0000' bus='0x81' slot='0x11' function='0x6'/>

  </capability>

  <iommuGroup number='55'>

   <address domain='0x0000' bus='0x81' slot='0x00' function='0x0'/>

  </iommuGroup>

  <numa node='1'/>

  <pci-express>

   <link validity='cap' port='0' speed='5' width='8'/>

   <link validity='sta' speed='5' width='8'/>

  </pci-express>

 </capability>

</device>

 

 

I tried the below commands to get it fixed:

 

root@ubuntu-cg:~# ip link set dev $dev vf $vf trust on

root@ubuntu-cg:~# ip link set dev $dev vf $vf spoofchk off

root@ubuntu-cg:~# ethtool --set-priv-flags $dev vf-true-promisc-support on

ethtool: bad command line argument(s)

 

I thought that the --set-priv-flags "vf-true-promisc-support" should be the solution, somehow the command fails when trying to execute it.

 

Any pointer how to proceed here very much appreciated.

If promisc-mode for the vf is not the right approach, kindly let me know.

 

OS is ubuntu 16.04

 

 

many thanks

 

christian

 

0 Kudos
7 Replies
Highlighted
33 Views

Hello cgraf2,

 

Thank you for posting in Intel Ethernet Communities. 

 

Kindly provide the following details for us to check on your query.

1.) Exact model of your adapter. You may share the PBA number of the adapter so we can double check on the model. Please refer to the link below on where to find the PBA.

https://www.intel.com/content/www/us/en/support/articles/000007022/network-and-io/ethernet-products....

2.) Kernel version information.

 

Looking forward to your response.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

0 Kudos
Highlighted
33 Views

Hello cgraf2,

 

Good day!

 

Please provide the requested information for us to check on your query. Just in case you have additional questions and clarifications on this matter, please let us know.

 

Hoping to hear from you soon.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

0 Kudos
Highlighted
Beginner
33 Views

x520-pba.pngDear Crisselle,

 

thanks for your help. Please find the info below:

 

Last login: Thu Oct 31 08:35:46 2019 from xx

lab@ubuntu-cg:~$ uname -a

Linux ubuntu-cg 4.15.0-66-generic #75~16.04.1-Ubuntu SMP Tue Oct 1 14:01:08 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

lab@ubuntu-cg:~$ lsb_release -a

No LSB modules are available.

Distributor ID: Ubuntu

Description:  Ubuntu 16.04.6 LTS

Release:    16.04

Codename:    xenial

 

 

The PBA if I read it correctly is: G93555

 

many thanks

 

christian

 

0 Kudos
Highlighted
33 Views

Hello Christian,

 

Thank you for the reply.

 

Please allow us to check on this. Rest assured that we will provide an update within 1-3 business days.

 

Hoping for your patience.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

0 Kudos
Highlighted
33 Views

Hello Christian,

 

Thank you for the patience on this matter.

 

After checking, please be informed that unicast promiscuous mode is not supported in Intel 82599 VFs. We would suggest to submit a feature request on sourceforge through the link below. 

https://sourceforge.net/p/e1000/feature-requests/

 

Let us know if you have additional questions and clarifications on this request.

 

We look forward to hear from you.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

0 Kudos
Highlighted
Beginner
33 Views

Dear Criselle,

 

many thanks for clarification on this matter. I understand its not supported.

 

We can close this one here - thanks alot

 

christian

 

0 Kudos
Highlighted
33 Views

Hello Christian,

 

You are welcome.

 

As advised, we will now proceed with closure. Thank you very much for your patience and kind understanding on this matter.  Should you have any other concerns or assistance needed in the future, feel free to post a new question.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

0 Kudos