Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MFu
Beginner
3,242 Views

Disconnect and reconnect cable drop speed from 1000baseT to 10baseT.

Hi,

 

I have a Lenovo M920Q mini desktop with onboard intel 1G ethernet. If I unplug the cable and plug it back, the auto negotiation will not work. The interface is left at 10Mbps. It will stay at this speed forever.

 

Commands "ifconfig eth0 down; ifconfig eth0 up" will make the interface to renegotiate and become 1000Mbps.

 

Stock ubuntu driver and the latest from Intel behave the same.

 

OS: Ubuntu 16.04

 

Linux version:

Linux machine 4.15.0-42-generic #45~16.04.1-Ubuntu SMP Mon Nov 19 13:02:27 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

 

driver: e1000e

version: 3.4.2.1-NAPI

firmware-version: 0.5-4

expansion-rom-version: 

bus-info: 0000:00:1f.6

supports-statistics: yes

supports-test: yes

supports-eeprom-access: yes

supports-register-dump: yes

supports-priv-flags: no

 

ethtool eth0

Settings for eth0:

Supported ports: [ TP ]

Supported link modes:  10baseT/Half 10baseT/Full 

            100baseT/Half 100baseT/Full 

            1000baseT/Full 

Supported pause frame use: No

Supports auto-negotiation: Yes

Advertised link modes: 10baseT/Half 10baseT/Full 

            100baseT/Half 100baseT/Full 

            1000baseT/Full 

Advertised pause frame use: No

Advertised auto-negotiation: Yes

Speed: 10Mb/s

Duplex: Full

Port: Twisted Pair

PHYAD: 1

Transceiver: internal

Auto-negotiation: on

MDI-X: off (auto)

Supports Wake-on: pumbg

Wake-on: g

Current message level: 0x00000007 (7)

    drv probe link

Link detected: yes

 

 

lspci -v | grep Ethernet -A 1

00:1f.6 Ethernet controller: Intel Corporation Device 15bb (rev 10)

DeviceName: Onboard - Ethernet

Subsystem: Lenovo Device 3136

 

Dynamic Debug output.

 

Dec 17 20:21:28 cyclops-9921 kernel: [ 8287.450869] [18735] __e1000_read_phy_reg_hv:2781: e1000e 0000:00:1f.6 sniff1: reading PHY page 0 (or 0x0 shifted) reg 0x1

Dec 17 20:21:28 cyclops-9921 kernel: [ 8287.451164] [18735] __e1000_read_phy_reg_hv:2781: e1000e 0000:00:1f.6 sniff1: reading PHY page 0 (or 0x0 shifted) reg 0x1

Dec 17 20:21:28 cyclops-9921 kernel: [ 8287.451455] [18735] e1000_check_for_copper_link_ich8lan:1428: e1000e 0000:00:1f.6 sniff1: pch2lan /* My added line */

Dec 17 20:21:28 cyclops-9921 kernel: [ 8287.451463] [18735] e1000e_get_speed_and_duplex_copper:1326: e1000e 0000:00:1f.6 sniff1: 10 Mbps, Full Duplex

 

Regards,

Ming

0 Kudos
14 Replies
Daniel_D_Intel1
Employee
549 Views

Hello MFu, Thank you for posting in Intel Ethernet Communities. Please identify the Ethernet controller being used on the system. It appears to be a I219-V connection, but we want to confirm this. What type of device is the cable connecting to? There may be a power saving feature on the device that is setting the unplugged interface to a lower speed upon re-connection. Do you have another cable you can try on this system to make sure the issue is not with the cable? Let us know if you have any other questions. Best regards, Daniel D Intel Customer Support
MFu
Beginner
549 Views

Hi Daniel,

The chip is according to Lenovo "Gigabit ethernet, Intel Ethernet Connection I219-V, Wake on LAN". I have changed three cable to make sure the cable is not the problem. I will look for the power option in bios.

 

Thanks

Ming

Daniel_D_Intel1
Employee
549 Views

Hello MFu, Thank you for the reply. Please let us know the switch, router, or modem type device you are connecting to. If you can connect to another device, or can make a point to point connection to another gigabit adapter this may be useful to test the interface. Have you checked with Lenovo on this issue? This may be a known issue, or there may be a BIOS update that will resolve the issue. We would recommend speaking to Lenovo support as well. Let us know if you have any questions. Best regards, Daniel D Intel Customer Support
Daniel_D_Intel1
Employee
549 Views

Hello MFu, Please let us know if you still need assistance with this issue. If you have any questions please do not hesitate to ask. Best regards, Daniel D Intel Customer Support
Daniel_D_Intel1
Employee
549 Views

Hello MFu, Please inform us if you still require assistance with this issue. Best regards, Daniel D Intel Customer Support
MFu
Beginner
549 Views

The device the cable connects to is a D-Link web smart switch (DGS-1210-10). I also tested cross connecting to another Intel NIC on an older Lenovo (M910Q) with Intel 1G NIC. The same problem happens as well on M920Q, but not the older M910Q. I updated Lenovo Bios to their newest without successfully address the problem. I didn't find any bios power saving features particular to network interfaces.

 

For CPU Setup:

EIST enabled

CIE enabled

C state: C1 only

Turbo Enabled

 

The M920Q and M910Q lenovo seem to use different NIC chips.

 

The lspci for the Lenovo M920Q which has the problem.

0:1f.6 Ethernet controller: Intel Corporation Device 15bb (rev 10)

    DeviceName: Onboard - Ethernet

    Subsystem: Lenovo Device 3136

    Flags: bus master, fast devsel, latency 0, IRQ 122

    Memory at b1100000 (32-bit, non-prefetchable) [size=128K]

    Capabilities: [c8] Power Management version 3

    Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+

    Kernel driver in use: e1000e

    Kernel modules: e1000e

 

The lspci for an Older Lenovo M910Q which does not have the problem

00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-LM

    Subsystem: Lenovo Ethernet Connection (2) I219-LM

    Flags: bus master, fast devsel, latency 0, IRQ 123

    Memory at f7100000 (32-bit, non-prefetchable) [size=128K]

    Capabilities: [c8] Power Management version 3

    Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+

    Capabilities: [e0] PCI Advanced Features

    Kernel driver in use: e1000e

    Kernel modules: e1000e

 

Regards,

Ming

Daniel_D_Intel1
Employee
549 Views

Hello MFu, Thank you for the information. Is the older Lenovo using the same version of Ubuntu and driver? Would you be able to post the "ethtool -i <interface>" and "ethtool <interface>" for it? Please check if energy efficient Ethernet is enabled in ethtool using the command "ethtool --show-eee eth0". If it is enabled use "ethtool --set-eee eth0 eee off" to disable it. See if this keeps the connection speed stable. If you have any questions let us know. Best regards, Daniel D Intel Customer Support
MFu
Beginner
549 Views

Hi Daniel,

 

The following is a sequence of command and cable connect/disconnect to show the status you requested. Looks just change the state of eee with (either on or off) will set the system to the correct network speed. I am running ubuntu xenial kernel 4.15.0-42-generic.

~$ ethtool sniff1

Settings for sniff1:

Supported ports: [ TP ]

Supported link modes:  10baseT/Half 10baseT/Full 

            100baseT/Half 100baseT/Full 

            1000baseT/Full 

Supported pause frame use: No

Supports auto-negotiation: Yes

Advertised link modes: 10baseT/Half 10baseT/Full 

            100baseT/Half 100baseT/Full 

            1000baseT/Full 

Advertised pause frame use: No

Advertised auto-negotiation: Yes

Speed: 1000Mb/s

Duplex: Full

Port: Twisted Pair

PHYAD: 2

Transceiver: internal

Auto-negotiation: on

MDI-X: off (auto)

Supports Wake-on: pumbg

Wake-on: g

Current message level: 0x00000007 (7)

    drv probe link

Link detected: yes

~$ ethtool --show-eee sniff1 

EEE Settings for sniff1:

EEE status: disabled

Tx LPI: 17 (us)

Supported EEE link modes: 100baseT/Full 

              1000baseT/Full 

Advertised EEE link modes: 100baseT/Full 

              1000baseT/Full 

Link partner advertised EEE link modes: 100baseT/Full 

                     1000baseT/Full 

 

~$ ethtool -i sniff1

driver: e1000e

version: 3.2.6-k

firmware-version: 0.5-4

expansion-rom-version: 

bus-info: 0000:00:1f.6

supports-statistics: yes

supports-test: yes

supports-eeprom-access: yes

supports-register-dump: yes

supports-priv-flags: no

 

 

UNPLUG CABLE and PLUG BACK

 

 

~$ ethtool sniff1

Settings for sniff1:

Supported ports: [ TP ]

Supported link modes:  10baseT/Half 10baseT/Full 

            100baseT/Half 100baseT/Full 

            1000baseT/Full 

Supported pause frame use: No

Supports auto-negotiation: Yes

Advertised link modes: 10baseT/Half 10baseT/Full 

            100baseT/Half 100baseT/Full 

            1000baseT/Full 

Advertised pause frame use: No

Advertised auto-negotiation: Yes

Speed: 10Mb/s

Duplex: Full

Port: Twisted Pair

PHYAD: 1

Transceiver: internal

Auto-negotiation: on

MDI-X: off (auto)

Supports Wake-on: pumbg

Wake-on: g

Current message level: 0x00000007 (7)

    drv probe link

Link detected: yes

 

~$ ethtool --show-eee sniff1 

EEE Settings for sniff1:

EEE status: disabled

Tx LPI: 17 (us)

Supported EEE link modes: 100baseT/Full 

              1000baseT/Full 

Advertised EEE link modes: 100baseT/Full 

              1000baseT/Full 

Link partner advertised EEE link modes: 100baseT/Full 

                     1000baseT/Full

 

 

~$ ethtool --set-eee sniff1 eee on 

~$ ethtool sniff1

Settings for sniff1:

Supported ports: [ TP ]

Supported link modes:  10baseT/Half 10baseT/Full 

            100baseT/Half 100baseT/Full 

            1000baseT/Full 

Supported pause frame use: No

Supports auto-negotiation: Yes

Advertised link modes: 10baseT/Half 10baseT/Full 

            100baseT/Half 100baseT/Full 

            1000baseT/Full 

Advertised pause frame use: No

Advertised auto-negotiation: Yes

Speed: 1000Mb/s

Duplex: Full

Port: Twisted Pair

PHYAD: 2

Transceiver: internal

Auto-negotiation: on

MDI-X: off (auto)

Supports Wake-on: pumbg

Wake-on: g

Current message level: 0x00000007 (7)

    drv probe link

Link detected: yes

 

Thanks

Ming

MFu
Beginner
549 Views

There is one new finding, The Linux 4.13.0-1032-oem of ubuntu xenial does not have the problem.

 

~$ uname -a

Linux cyclops-9921 4.13.0-1032-oem #36-Ubuntu SMP Thu Jul 5 12:49:44 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

 

~$ ethtool -i sniff1

driver: e1000e

version: 3.2.6-k

firmware-version: 0.5-4

expansion-rom-version: 

bus-info: 0000:00:1f.6

supports-statistics: yes

supports-test: yes

supports-eeprom-access: yes

supports-register-dump: yes

supports-priv-flags: no

 

~$ ethtool --show-eee sniff1

EEE Settings for sniff1:

EEE status: enabled - active

Tx LPI: 17 (us)

Supported EEE link modes: 100baseT/Full 

              1000baseT/Full 

Advertised EEE link modes: 100baseT/Full 

              1000baseT/Full 

Link partner advertised EEE link modes: 100baseT/Full 

                     1000baseT/Full 

 

Daniel_D_Intel1
Employee
549 Views

Hello Mfu, Thank you for the update. Are all of these new outputs from the M920Q? Ubuntu linux 4.13.0-1032 has a stable connection on M920Q? Was the older M910Q using 4.13.0 or was it using 4.15.0 when you tested it as working? Does 4.13.0 also work with the Intel version of the e1000e driver? We would like to further isolate the issue, to see if the connection is stable in only the older linux kernel. Let us know if you have any questions. Best regards, Daniel D Intel Customer Support
MFu
Beginner
549 Views

Hi Daniel, Yes, all output are from M920Q. The M910Q works for both version of kernel. If you look at the lspci output, the M910Q and M920Q seems to have difference chip for the Ethernet adaptor. M920Q with 4.13.0-1032-oem works fine. I can reconnect the cable and the auto negotiation restores the speed to 1000. I tried the e1000e-3.4.2.1 from Intel download center on M920Q running Linux 4.13.0-1032-oem. It works fine too. Tried e1000e-3.4.2.1 from Intel Download center on M920Q running 4.15.0-42-generic, in either eee on and off, the interface drop speed to 10Mbites/s after reconnect. The lspci for the Lenovo M920Q which has the problem. 0:1f.6 Ethernet controller: Intel Corporation Device 15bb (rev 10) DeviceName: Onboard - Ethernet Subsystem: Lenovo Device 3136 Flags: bus master, fast devsel, latency 0, IRQ 122 Memory at b1100000 (32-bit, non-prefetchable) [size=128K] Capabilities: [c8] Power Management version 3 Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+ Kernel driver in use: e1000e Kernel modules: e1000e The lspci for an Older Lenovo M910Q which does not have the problem 00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-LM Subsystem: Lenovo Ethernet Connection (2) I219-LM Flags: bus master, fast devsel, latency 0, IRQ 123 Memory at f7100000 (32-bit, non-prefetchable) [size=128K] Capabilities: [c8] Power Management version 3 Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+ Capabilities: [e0] PCI Advanced Features Kernel driver in use: e1000e Kernel modules: e1000e Regards, Ming
Daniel_D_Intel1
Employee
549 Views

Hello Mfu, Thank you for the information. The M920Q is using an OEM version of the i219-V controller and the M910Q is using an OEM version of the I219-LM. These controllers have different features which could be the reason for the different behavior. Please provide the output of ethtool -k <interface> from both systems, so we can check if a feature may be interfering in the connection speed. You may also check if Lenovo support is aware of any issues, as it may be something in the board design. We will check on this and update you with more information soon. Let us know if any other questions come up. Best regards, Daniel D Intel Customer Support
MFu
Beginner
549 Views

Hi Daniel, Ubuntu released a new kernel 4.15.0-43-generic. The problem is gone. Thanks for the help. Ming
Daniel_D_Intel1
Employee
549 Views

Hello Mfu, Thank you for the update. Please let us know if you have further questions, or the issue occurs again. Best regards, Daniel D Intel Customer Support
Reply