Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4986 Discussions

Intel(R) Ethernet Connection (12) I219-V disconnects randomly

bpatters69
Beginner
5,660 Views

Hello All,

 

I have an Asus TUF_GAMING_B460M-PLUS_Wi-Fi motherboard. I am using the following driver for the network card:

 

Intel(R) Ethernet Connection (12) I219-V

 

I have been having issues where my Internet\Network connection drops every 10 or 15 minutes. Sometimes it is better than others. Sometimes it disconnect a few times and it is then stable. So it is very random and intermittant. 

 

I went to the ASUS support site and according to their downloads, I should be using the following driver:

Intel_LAN_Driver_V12.18.9.14_WIN10_64-bit (Yes, its an older driver but what ASUS recommends)

 

I went into Device Manager and uninstalled the Intel(R) Ethernet Connection (12) I219-V. I also said "yes" to deleting the related software. I then tried to install Intel_LAN_Driver_V12.18.9.14_WIN10_64-bit but nothing happened. I heard my hard disk working but I did not get any messages saying the older driver was installed. I confirmed that Intel(R) Ethernet Connection (12) I219-V was removed and restarted my PC. When the PC restarts, It automtiacally adds the Intel(R) Ethernet Connection (12) I219-V. 

 

How do I prevent my PC from reinstalling the newer driver of Intel(R) Ethernet Connection (12) I219-V? Is there a removal tool?

 

Thanks, Bill

0 Kudos
8 Replies
bpatters69
Beginner
5,636 Views

As an update, I was finally able to remove the Intel(R) Ethernet Connection (12) I219-V by going into device manager and showing hidden devices. There was a second entry or ghost entry as Intel calls it for Intel(R) Ethernet Connection (12) I219-V.

 

I re-started my PC and I tried to install Intel_LAN_Driver_V12.18.9.14_WIN10_64-bit but the driver program will not run.


Thanks, Bill

0 Kudos
B_Y
Employee
5,621 Views

Hi bpatters69,


Thank you for posting in Intel Ethernet Communities.

In order for us to investigate further, please provide the information below:

- Your operating system(OS) and build version

- Is it an integrated I219-V or an I219-V card purchased separately?

- Is there any error message?

- When the issue start happening?

- Any software or hardware changes to your system and network router/switch recently?

- Do you have another system to test the I219-V to ensure network is working accordingly without interruption.


1) Next, kindly try following settings for testing purpose:

-Right click on the network / Wi-Fi icon at system tray.

-Choose Open Network & Internet Settings and navigate to Advanced Network Settings.

-Select Change Adapter Options to view all network cards installed on computer.

-Right click on Intel® Ethernet Connection I219-V and select Properties.

-Find Internet Protocol v6 (TCP/IPv6) from the list under Networking tab, and disable it.


2) You can also try to disable or change the values for mentioned property with the following steps:

a. Open Device Manager.

b. Double-click Network adapter: Intel Ethernet Connection I219-V

c. Click on the "Advanced" tab, change values for following property-

- Energy Efficient Ethernet (EEE) to "Off"

- Ultra Low Power Mode to "Disabled"

- Large Send Offload V2 (IPv4) to "Disabled"

- Large Send Offload V2 (IPv6) to "Disabled"

- TCP Checksum Offload (IPv4) to "Tx Enabled"

- TCP Checksum Offload (IPv6) to "Tx Enabled"


We would like to share some tips on How to Manually Install Intel® Network Adapter Drivers in Windows:

https://www.intel.com/content/www/us/en/support/articles/000022174/ethernet-products.html


Kindly share the configuration, OS version and system board info with us to further check if issue still persist.

How to get the Intel® System Support Utility Logs on Windows*

https://www.intel.com/content/www/us/en/support/articles/000057926/memory-and-storage.html


I look forward to your reply.


Best regards,

BY_Intel

Intel Customer Support


0 Kudos
bpatters69
Beginner
5,569 Views

Thanks. My replies are in bold

 

- Your operating system(OS) and build version

- Is it an integrated I219-V or an I219-V card purchased separately?

- Is there any error message?

- When the issue start happening?

- Any software or hardware changes to your system and network router/switch recently?

- Do you have another system to test the I219-V to ensure network is working accordingly without interruption.

 

1) Next, kindly try following settings for testing purpose:

-Right click on the network / Wi-Fi icon at system tray.

-Choose Open Network & Internet Settings and navigate to Advanced Network Settings.

-Select Change Adapter Options to view all network cards installed on computer.

-Right click on Intel® Ethernet Connection I219-V and select Properties. The I219-V driver is not listed. I do have an "Ethernet 2" icon which is my Ethernet Card.

-Find Internet Protocol v6 (TCP/IPv6) from the list under Networking tab, and disable it.

By disabling it, do you mean uncheck the box? 

 

2) You can also try to disable or change the values for mentioned property with the following steps:

a. Open Device Manager.

b. Double-click Network adapter: Intel Ethernet Connection I219-V The problem is the driver is not loaded. I removed it in an attempt to install the Asus recommended driver from the ASUS site.

c. Click on the "Advanced" tab, change values for following property- I cannot perform any of the items below as the Driver is not installed

- Energy Efficient Ethernet (EEE) to "Off"

- Ultra Low Power Mode to "Disabled"

- Large Send Offload V2 (IPv4) to "Disabled"

- Large Send Offload V2 (IPv6) to "Disabled"

- TCP Checksum Offload (IPv4) to "Tx Enabled"

- TCP Checksum Offload (IPv6) to "Tx Enabled"

 

Can you post a link to the driver I need? 

0 Kudos
B_Y
Employee
5,551 Views

Hi bpatters69,


Thank you for your feedback. If I understand correctly, the system's I219-V is as PCIE.

You can do clean driver installation here

https://www.intel.com/content/www/us/en/support/articles/000058304/ethernet-products.html


Install new generic driver from here: 

https://www.intel.com/content/www/us/en/download/15084/intel-ethernet-adapter-complete-driver-pack.html


We would like to share some tips on How to Manually Install Intel® Network Adapter Drivers in Windows:

https://www.intel.com/content/www/us/en/support/articles/000022174/ethernet-products.html


Then try:

-Find Internet Protocol v6 (TCP/IPv6) from the list under Networking tab, and disable it by uncheck. 

-You can also try to disable or change the values for mentioned property with the following steps:

a. Open Device Manager.

b. Double-click Network adapter: Intel Ethernet Connection I219-V The problem is the driver is not loaded. I removed it in an attempt to install the Asus recommended driver from the ASUS site.

c. Click on the "Advanced" tab, change values for following property- I cannot perform any of the items below as the Driver is not installed

- Energy Efficient Ethernet (EEE) to "Off"

- Ultra Low Power Mode to "Disabled"

- Large Send Offload V2 (IPv4) to "Disabled"

- Large Send Offload V2 (IPv6) to "Disabled"

- TCP Checksum Offload (IPv4) to "Tx Enabled"

- TCP Checksum Offload (IPv6) to "Tx Enabled"


Best regards,

BY_Intel

Intel Customer Support


0 Kudos
bpatters69
Beginner
5,518 Views

Thanks. I added the driver and applied the changes. So far so good - no disconnects! I want to monitor it for the next day or two before I claim victory. 

0 Kudos
B_Y
Employee
5,492 Views

Hi bpatters69,


I appreciate the status update. For the next two business days, we will keep this thread available while monitoring it to make sure everything is functioning as it should. I'm eager to hear from you by Thursday night.


Best regards,

BY_Intel

Intel Customer Support


0 Kudos
bpatters69
Beginner
5,486 Views

@B_Y  Thanks. So far so good. After reviewing the changes, my guess is it was the energy efficient change. It seems like the disconnects would occur when I was watching a video online so there were no keystrokes and the PC would go into energy saving mode.

0 Kudos
B_Y
Employee
5,404 Views

Hi bpatters69,


Hope this message finds you well.

Please be informed that we will now close this request by EOD since we don't see any issue reoccur. Just feel free to post a new question if you may have any other inquiry in the future as this thread will no longer be monitored.


Best regards,

BY_Intel

Intel Customer Support


0 Kudos
Reply