Ethernet Products
Intel® Ethernet products and technologies
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
3699 Discussions

Intel(R) ProSet Monitoring Service: Generates multiple WMI errors because of incorrect WQL query

ovgolovin
Beginner
813 Views

After analyzing high CPU utilization by WMI Provider Host service , I found out that every 15 seconds Intel ProSet Monitoring Service generates this error event. Those events affect WMI Provider Host.

ovgolovin_0-1609363043956.png

 

 

Id = {00000000-0000-0000-0000-000000000000}; ClientMachine = OLEG-HOME-PC; User = NT AUTHORITY\SYSTEM; ClientProcessId = 23112; Component = Unknown; Operation = Start IWbemServices::ExecNotificationQuery - root\virtualization\v2 : SELECT * FROM __InstanceOperationEvent WITHIN 10 WHERE (TargetInstance ISA 'Msvm_ExternalEthernetPort') OR (TargetInstance ISA 'Msvm_VLANEndpoint') OR (TargetInstance ISA 'Msvm_SyntheticEthernetPort') OR (TargetInstance ISA 'Msvm_ComputerSystem') OR (TargetInstance ISA 'Msvm_EthernetSwitchPortVlanSettingData'); ResultCode = 0x80041032; PossibleCause = Unknown

 

 

 

After investigation I found out that Intel ProSet Monitoring Service makes invalid WMI query:

 

PS C:\Users\ovgol> Get-WmiObject -Query "SELECT * FROM __InstanceOperationEvent WITHIN 10 WHERE (TargetInstance ISA 'Msvm_ExternalEthernetPort') OR (TargetInstance ISA 'Msvm_VLANEndpoint') OR (TargetInstance ISA 'Msvm_SyntheticEthernetPort') OR (TargetInstance ISA 'Msvm_ComputerSystem') OR (TargetInstance ISA 'Msvm_EthernetSwitchPortVlanSettingData')"
Get-WmiObject : Invalid query "SELECT * FROM __InstanceOperationEvent WITHIN 10 WHERE (TargetInstance ISA
'Msvm_ExternalEthernetPort') OR (TargetInstance ISA 'Msvm_VLANEndpoint') OR (TargetInstance ISA
'Msvm_SyntheticEthernetPort') OR (TargetInstance ISA 'Msvm_ComputerSystem') OR (TargetInstance ISA
'Msvm_EthernetSwitchPortVlanSettingData')"
At line:1 char:1
+ Get-WmiObject -Query "SELECT * FROM __InstanceOperationEvent WITHIN 1 ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidArgument: (:) [Get-WmiObject], ManagementException
    + FullyQualifiedErrorId : GetWMIManagementException,Microsoft.PowerShell.Commands.GetWmiObjectCommand

 

 

 

 

Looks like WITHIN cannot be used in this type of query. From what I understand from brief docs reading, WITHIN is intended for wmi event subscriptions and not for direct quires.

This query (without WITHIN) is executed successfully.

Screenshot 2020-12-30 133025.png

 

PS C:\Users\ovgol> Get-WmiObject -Query "SELECT * FROM __InstanceOperationEvent WHERE (TargetInstance ISA 'Msvm_ExternalEthernetPort') OR (TargetInstance ISA 'Msvm_VLANEndpoint') OR (TargetInstance ISA 'Msvm_SyntheticEthernetPort') OR (TargetInstance ISA 'Msvm_ComputerSystem') OR (TargetInstance ISA 'Msvm_EthernetSwitchPortVlanSettingData')"

 

 

I'm using the latest ProSetMonitoring service:

Screenshot 2020-12-30 134914.png

Network adapter driver is also the latest:

Screenshot 2020-12-30 135412.png

How to submit this bug to Intel(R) ProSet Monitoring Service developers for them to fix it?

 

0 Kudos
15 Replies
Michael_L_Intel2
Moderator
796 Views

Hello ovgolovin,


Thank you for posting in Intel Ethernet Communities. 


For us to further check the issue, please provide the following details.


  1. What is your OS?
  2. Are you using an onboard network card or a PCIe card?
  3. If you are using a PCIe card, kindly send a photo on both sides of the card focusing on the markings.
  4. Can you share the link of the latest driver that you installed?


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support


ovgolovin
Beginner
786 Views

Hey Michael,

The answers are bellow.

1. Windows 10 Pro 64bit

2. It is an onboard network card (Asus ROG MAXIMUS VII IMPACT)

4.  The driver I have installed: https://downloadcenter.intel.com/downloads/eula/25016/Intel-Network-Adapter-Driver-for-Windows-10?ht... 

 

Also, a bit more stats from Configuration Utility:

Screenshot 2021-01-03 184108.png

 

Oleg

Michael_L_Intel2
Moderator
778 Views

Hello ovgolovin,


Thank you for the quick reply. I can see that you are already using Intel's latest generic driver for your network card and you are still having issues. Have you tried asking Asus if the have an updated appropriate driver that may fix the issue?


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support


ovgolovin
Beginner
773 Views

Hey,

The first thing I did was looking the most updated driers on Asus website. But I found out the latest drivers they have for onboard Intel Network card are very old. So I installed the most recent ones from Intel website.

I problem I raised in this thread is about ProSet Monitoring Service. This problem also existed in the  Network drivers I installed with the motherboard. 

ProSet Monitoring Service is not the driver itself, but a supplementary software:

"The Intel(R) PROSet Monitoring Service actively monitors changes to the system and updates affected network devices to keep them running in optimal condition. Stopping this service may negatively affect the performance of the network devices on the system."

And the problem I describe appears to have been in this service for a long time. It is about how this tool works with Windows Events for logging its activity and dumps a lot of events about errors which is actually a bug in the  PROSet Monitoring Service itself (it makes incorrect WMI query).

Michael, I don't think this error is related to particular drivers I use or my setup. It is just a bug in Intel(R) PROSet Monitoring Service itself and it needs to be fixed by the team who wrote this service. Given that the service version is being updated between drivers version, I believe there are still developers who own this tool and keep updating it, so they can fix this bug. I collected all the needed stats about what WMI query they need to fix in the code.

 

Michael_L_Intel2
Moderator
769 Views

Hello ovgolovin,


Thank you for the clarification. Can you share the link where you downloaded the version of your The Intel(R) PROSet Monitoring Service for us to check. And also, to clarify, you don't have issues with the connection, just the error in the monitoring service, right?


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support


ovgolovin
Beginner
763 Views

I shared the link above already. Posting it here once again. https://downloadcenter.intel.com/downloads/eula/25016/Intel-Network-Adapter-Driver-for-Windows-10?ht... 

I don't have issues with a connection. I was investigating constant CPU usage, and found out on the Internet it is common issue that Intel(R) PROSet Monitoring Service creates unreasonable amount of Windows Events. And my investigation showed it is actually a bug in this service.

Michael_L_Intel2
Moderator
759 Views

Hello ovgolovin,


By the way, have you tried checking with Asus if this software will work for their board and if they have a similar software that you can use? Let me also ask if you tried updating the firmware of your board that may help in this issue since the network card is onboard.


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support


ovgolovin
Beginner
754 Views

Michael,

You keep asking the same questions. I already replied to them.

Oleg

Michael_L_Intel2
Moderator
730 Views

Hello ovgolovin,


Yes, we are already checking the bug that you reported. We I have forwarded the details that you sent to our Engineers for checking as we speak. I just asked those details since we are dealing an onboard network card which may have altered by the board manufacturers. For now, please give us 3 to 4 days to provide an update on this issue.


Thank you.


Best regards,

Michael L.

Intel® Customer Support


Michael_L_Intel2
Moderator
720 Views

Hello ovgolovin,


As part of our data gathering, please provide the following details that would help is to check the bug the you reported.


  1. Can you provide the specific error id?
  2. What is the exact version of his Windows 10?
  3. Did it happen after the Windows upgrade?
  4. Did it also happen on a previous version of Intel Proset Utility?
  5. Please help generate the SSU of your system, kindly download the SSU on the link below:


https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support


ovgolovin
Beginner
713 Views

Can you provide the specific error id?

Id = {00000000-0000-0000-0000-000000000000}; ClientMachine = OLEG-HOME-PC; User = NT AUTHORITY\SYSTEM; ClientProcessId = 5208; Component = Unknown; Operation = Start IWbemServices::ExecNotificationQuery - root\virtualization\v2 : SELECT * FROM __InstanceOperationEvent WITHIN 10 WHERE (TargetInstance ISA 'Msvm_ExternalEthernetPort') OR (TargetInstance ISA 'Msvm_VLANEndpoint') OR (TargetInstance ISA 'Msvm_SyntheticEthernetPort') OR (TargetInstance ISA 'Msvm_ComputerSystem') OR (TargetInstance ISA 'Msvm_EthernetSwitchPortVlanSettingData'); ResultCode = 0x80041032; PossibleCause = Unknown

What is the exact version of his Windows 10?

10.0.18363 Build 18363

Did it happen after the Windows upgrade?

No. Happened always.

Did it also happen on a previous version of Intel Proset Utility?

Yes.

I found errors in the previous utility version. Then updated the utility, but errors are still there.

Please help generate the SSU of your system, kindly download the SSU on the link below.

Attached

Michael_L_Intel2
Moderator
705 Views

Hello ovgolovin,


Thank you for providing the information that we requested. We need to check these information and get back to you once we have an update. Please give us 3 to 4 days to provide an update on this issue.


Thank you.


Best regards,

Michael L.

Intel® Customer Support


Michael_L_Intel2
Moderator
681 Views

Hello ovgolovin,


Thank you for patiently waiting for our update.


Upon further checking, there are no known issues with Intel PROSet utility. However, you may try the following steps to possible fix the issue.

1. Complete remove Ethernet Drivers and Software from system (Delete files where installed if necessary)

2. Install 25.6 drivers only (not PROSET)

3. See if error still occurs

4. Now install PROSET SW and check if error occurs.

 

You can also stop/prevent the service from running. Please also keep in mind that this service is also installed with Wireless.

In addition: If you are not using Hyper-V or teaming, the monitoring service is not needed.

 

 Information on PROSet monitoring service:

1) It monitors virtual switch port changes when you have a Team configured. 

2) Monitors Windows Hyper V status changes

3) Completes a DCB upgrade when a user upgrades the software from one version of DCB to another and a reboot is required.

4) Displays warning messages after a reboot when device and or system status changes have occurred.

 

Lastly, we also recommend that you should be using drivers provided by your OEM which is ASUS. They should have the appropriate drivers for their system


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support


Michael_L_Intel2
Moderator
661 Views

Hello ovgolovin,


I hope you are having a good day. I just want to check if you tried our last recommendations.


If you have questions, please let us know. In case we do not hear from you, we will make a follow up after 3 workings days. Thank you.


Best regards,

Michael L.

Intel® Customer Support


Michael_L_Intel2
Moderator
644 Views

Hello ovgolovin,


I am just sending another follow up checking if you already tried contacting the manufacturer of your board regarding the issue. 

Since we have not heard back from you, I need to close this inquiry. 


If you need further assistance, please post a new question. Thank you.


Best regards,

Michael L.

Intel® Customer Support


Reply