Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
1,362 Views

Intel i Series machines set to auto-negotiate not connecting to Catalyst 2950 with "down-when-looped"

We've been having an issue with the i Series machines with the Intel 82579LM Gigabit Ethernet Adapter.

We use the "down-when-looped" command on our Cisco Catalyst 2950 series switches due to some unauthorized hubs attached to the network being looped.

I'm using your drivers 11.16.96.0 updated 3/15/2012 on my i5 Laptop that I've been testing with.

Our i3 Dell PCs are using Dell's driver. (Not sure of the version)

Our helpdesk found that if they set the PC's ethernet adapter to Speed 100 & Full Duplex it works fine, but this isn't a fix.

I can turn off the "down-when-looped" command in the switch, but we're talking about several hundred switches & I'd prefer to leave that feature off.

Has anyone else found another solution?

Thanks

Stas

Here's our Cisco Switch Port Setup.

!

 

interface FastEthernet0/2

 

switchport access vlan 2

 

switchport mode access

 

storm-control action shutdown

 

down-when-looped

 

spanning-tree portfast trunk

!

0 Kudos
5 Replies
Highlighted
Employee
26 Views

I have not heard of any issues with negotiating a link related to that switch configuration. The driver version you are using is the latest, so no driver update will help. I will check with my contacts to see if I can find out anything that might be related and post anything I find out here.

Please check out my post at /message/148594# 148594 http://communities.intel.com/message/148594# 148594. I am not sure if this will apply to your situation, but you might want to try disabling Power over Ethernet as an experiment to see if you can connect with auto negotiate. Let me know what you find out.

Mark H

0 Kudos
Highlighted
Community Manager
26 Views

I setup a 2960G with the same configuration and it worked fine.

I also tried using a Cross-Over cable with the 2950, and it still didn't work. (not that I expected it to)

The 2960 is an auto-sensing 1000/100/10Base-T Switch and the 2950 is nonauto-sensing and only has 100/10Base-T ports for the PCs.

0 Kudos
Highlighted
Employee
26 Views

What is the client OS?

0 Kudos
Highlighted
Community Manager
26 Views

Windows 7sp1 32 bit & 64bit.

0 Kudos
Highlighted
Employee
26 Views

Our engineers have tracked this issue down to an issue with the way the switch negotiates the speed. When this switch was manufactured, a "reserved" bit in the Ethernet negotiation was apparently used for proprietary purposes. Using this reserved bit is not an issue when communicating with 100 Mbps adapters, but causes an issue with gigabit negotiation.

There is another potential workaround that would allow you to keep the "down-when-looped" configuration. You could force the port speed to 100 Mbps to bypass the gigabit negotiation issue.

In the lab we got these results when manually configuring the speed and duplex settings:

Setting speed to 100 and duplex to full on the switch does establish a link even with down-when-looped enabled, however, the connection shows as 100/half on the client side when the client speed and duplex is set to auto.

Configuring 100/full on both sides shows a 100/full duplex connection.

Mark H

0 Kudos