Community
cancel
Showing results for 
Search instead for 
Did you mean: 
yzhou37
Beginner
1,475 Views

XL710 QDA2 - link not

Hi,

I have two XL710 QDA2 nics each is installed on a server (ubt 18.04, kernel 4.15.0-43-generic), then use QSFP+ DAC 3.0m cable to connect them back to back. The i40e driver has been updated to latest 2.7.26. But ethtool still shows link not detected, and all LEDs on both nics are black.

 

$ ethtool ens5f0

Settings for ens5f0:

Supported ports: [ ]

Supported link modes:  40000baseCR4/Full 

            40000baseSR4/Full 

            40000baseLR4/Full 

Supported pause frame use: Symmetric

Supports auto-negotiation: Yes

Supported FEC modes: Not reported

Advertised link modes: 40000baseCR4/Full 

Advertised pause frame use: No

Advertised auto-negotiation: Yes

Advertised FEC modes: Not reported

Speed: Unknown!

Duplex: Unknown! (255)

Port: Other

PHYAD: 0

Transceiver: internal

Auto-negotiation: off

Cannot get wake-on-lan settings: Operation not permitted

Current message level: 0x0000000f (15)

    drv probe link timer

Link detected: no

 

 

$ modinfo i40e

filename:    /lib/modules/4.15.0-43-generic/updates/drivers/net/ethernet/intel/i40e/i40e.ko

version:    2.7.26

license:    GPL

description:  Intel(R) 40-10 Gigabit Ethernet Connection Network Driver

author:     Intel Corporation, <e1000-devel@lists.sourceforge.net>

srcversion:   7B91C68FBC788EFDF1D32BF

alias:     pci:v00008086d0000158Bsv*sd*bc*sc*i*

alias:     pci:v00008086d0000158Asv*sd*bc*sc*i*

alias:     pci:v00008086d000037D3sv*sd*bc*sc*i*

alias:     pci:v00008086d000037D2sv*sd*bc*sc*i*

alias:     pci:v00008086d000037D1sv*sd*bc*sc*i*

alias:     pci:v00008086d000037D0sv*sd*bc*sc*i*

alias:     pci:v00008086d000037CFsv*sd*bc*sc*i*

alias:     pci:v00008086d000037CEsv*sd*bc*sc*i*

alias:     pci:v00008086d00001588sv*sd*bc*sc*i*

alias:     pci:v00008086d00001587sv*sd*bc*sc*i*

alias:     pci:v00008086d000015FFsv*sd*bc*sc*i*

alias:     pci:v00008086d00001589sv*sd*bc*sc*i*

alias:     pci:v00008086d00001586sv*sd*bc*sc*i*

alias:     pci:v00008086d00001585sv*sd*bc*sc*i*

alias:     pci:v00008086d00001584sv*sd*bc*sc*i*

alias:     pci:v00008086d00001583sv*sd*bc*sc*i*

alias:     pci:v00008086d00001581sv*sd*bc*sc*i*

alias:     pci:v00008086d00001580sv*sd*bc*sc*i*

alias:     pci:v00008086d00001574sv*sd*bc*sc*i*

alias:     pci:v00008086d00001572sv*sd*bc*sc*i*

depends:    ptp

retpoline:   Y

name:      i40e

vermagic:    4.15.0-43-generic SMP mod_unload 

parm:      debug:Debug level (0=none,...,16=all) (int)

 

The DAC cable we are using: https://www.dustinhome.se/product/5010976356/ethernet-qsfp-twinaxial

0 Kudos
6 Replies
Daniel_D_Intel1
Employee
468 Views

Hello Yzhou37, Thank you for posting in Intel Ethernet Communities. Have the adapters worked previously with other operating systems or kernels? Please confirm the PCIe ports on the server are supplying 8x of power. Do other adapters or devices work on the PCIe ports? Is the adapter detected using (lspci -nn | grep -i 'Ethernet Controller')? Please provide the output of the lspci command and (ethtool -i ens5f0) to display the firmware. Please supply the markings from the adapter if you have physical access. Let us know if you have any other questions. Best regards, Daniel D Intel Customer Support
Daniel_D_Intel1
Employee
468 Views

Hello Yzhou37, Please let us know if you still need assistance with this issue. Please provide the outputs and markings requested. Let us know if you have any other questions. Best regards, Daniel D Intel Customer Support Under contract to Intel Corporation
Daniel_D_Intel1
Employee
468 Views

Hello Yzhou37, Please let us know if you have any other questions. Best regards, Daniel D Intel Customer Support Under contract to Intel Corporation
Shubhakar
Beginner
397 Views

Hi ,

 

I am Facing the same issues with Intel XL710 After Updating the Firmware to 2.7.27

 

 

 

 

yzhou37
Beginner
468 Views

Hi Daniel,

 

Sorry for late reply, some problem when login my account. It works now with latest driver  2.7.26 and latest firmware version.

 

BR

Yu

Daniel_D_Intel1
Employee
468 Views

Hello Yzhou37, Thank you for the reply. Updating the firmware solved the issue? Please let us know if you have any other questions. Best regards, Daniel D Intel Customer Support Under contract to Intel Corporation
Reply