Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
4741 Discussions

killer Intelligence center 3.1322.1101.2 issue

beguna
Beginner
1,121 Views

After installing killer Intelligence center 3.1322.1101.2 today, upload speed was reduced to almost zero.  Download speed was close to gigabit as normal.   I fixed the issue by turning off prioritization on the dashboard.  Two different Dell desktops XPS 8930 experienced the issue using Win 10 and Killer E2400 card.  Intel needs to fix this.

0 Kudos
5 Replies
quiricocarl
Beginner
1,094 Views

Thanks for posting your fix for this issue.

 

My download speed was 0.03mb (speed test by Ookia) after this "update" with prioritization off on the dashboard i am back to 44.56mb.

E2500 -  Intel to add to the fix list. 

0 Kudos
beguna
Beginner
1,085 Views

Actually, after further testing I found that you will need to uninstall all of the Intel/Killer apps off your computer.  Prioritization keeps on turning on and the upload problem will return.  I even tried disabling the one Intel Killer app listed in startup apps and that didn't not work permanently.  I had to uninstall all of the Intel/Killer apps for a permanent solution.  Unless you are playing games, they are useless anyway.

0 Kudos
WLR
Beginner
724 Views

I have the same issue with my Dell XPS 8930.  Upload speeds suddenly fell to 1-2 Mbps (instead on 20 Mbps) while download is routinely >500 Mbps.  After a couple days diagnosing the issue, I discovered it was the Killer Intelligence Center prioritization.  If I manually turn prioritization off, then upload speeds jump back to 20-25 Mbps.  I tried uninstalling everything connected with Killer and for a day, everything seemed fine again.  Then I noticed the problem recurred.  I was forced to reinstall Killer Performance Suite and the Intelligence Center and manually turn off prioritization to get upload speeds back to normal.  But now I'm forced to manually change the prioritization every time I need to upload a large file.  There doesn't seem to be a way to set the default to "off" in the KIC....

 

I'm trapped.  Is there any solution to this problem?

0 Kudos
beguna
Beginner
707 Views

I found that every time there was a window update, prioritization in the Intelligence Center had to be turned off (and like you I had to reinstall the Intel software at some point).  I got tired of it and bought a new ethernet card (non Intel chip) and disabled the on board Intel ethernet chip.  Problem solved.  $30 for 2.5 gig card.  Bought 2 for my 2 8930's. 

0 Kudos
WLR
Beginner
685 Views
0 Kudos
Reply