Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
865 Views

USB byte blaster not working

Hi all , 

I have designed a USB blaster cable using a FT245BM as USB to parallel conveter and a CPLD.  

i have also installed the driver necessary for FT245BM from the website. I have also programmed the CPLD accordingly.  

The cpld code is in such a fashion that a read (RXF#) signal has to go low , then only the state machine inside the cpld would work, but inspite of installing the driver (ft245bm), this signal doesnot go low. 

also in the programmer window , only byteblaster hardware shows up and not usb blaster. 

I have also loaded the EEPROM neccessary for the ft245bm chip. 

please find the schematic for the ckit attached. 

 

Please help me in this regard 

Your co-operation is highly appreciated. 

 

regards 

Niraj
0 Kudos
3 Replies
Altera_Forum
Honored Contributor I
82 Views

Hi Niraj, 

what does the Windows control panel say about the device? 

Regards, 

Harald
Altera_Forum
Honored Contributor I
82 Views

You may want to check, if you have programmed a VID/PID combination to the EEPROM, that's recognized by the USB Blaster driver. See quartus\drivers\usb-blaster\usbblstr.inf.

Altera_Forum
Honored Contributor I
82 Views

Hi, 

When I insert the device through a usb cable , it gets displayed in the device manager as USB serial port with communication port as shown in the attachements. 

So the device gets added as a serial port device rather than a USB device. 

And so it doesnt gets displayed in the Programmer window. 

 

can u plz throw some light on the problem. 

 

thanks and sincere regards 

Niraj
Reply