GPU Compute Software
Ask questions about Intel® Graphics Compute software technologies, such as OpenCL* GPU driver and oneAPI Level Zero
74 Discussions

Fixed--cannot detect GPU

Scout
Beginner
597 Views

I have a PC and newly installed ubuntu 22.04. CLpeak reports no GPU. Below packages are installed:

intel-opencl-icd

intel-level-zero-gpu

 

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
intel-opencl-icd is already the newest version (22.43.24558).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
intel-level-zero-gpu : Depends: libigdgmm12 (>= 22.2.0) but it is not going to be installed
intel-opencl-icd : Depends: libigdgmm12 (>= 22.2.0) but it is not going to be installed
Depends: ocl-icd-libopencl1 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

 

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
intel-opencl-icd is already the newest version (22.43.24558).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
intel-level-zero-gpu : Depends: libigdgmm12 (>= 22.2.0) but it is not going to be installed
intel-opencl-icd : Depends: libigdgmm12 (>= 22.2.0) but it is not going to be installed
Depends: ocl-icd-libopencl1 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

 

Tried to install libigdm12, and it reported failure as below:

 

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
intel-level-zero-gpu : Depends: libigdgmm12 (>= 22.2.0) but 22.1.2+ds1-1 is to be installed
intel-opencl-icd : Depends: libigdgmm12 (>= 22.2.0) but 22.1.2+ds1-1 is to be installed
Depends: ocl-icd-libopencl1 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

 

 

system info:

GPU: AlderLake S GT1

OS: ubuntu 22.04

root@moffett95:/home/work/frank/clpeak-master/build# cat /proc/version

Linux version 5.15.0-43-generic (buildd@lcy02-amd64-076) (gcc (Ubuntu 11.2.0-19ubuntu1) 11.2.0, GNU ld (GNU Binutils for Ubuntu) 2.38) #46-Ubuntu SMP Tue Jul 12 10:30:17 UTC 2022

 

00:02.0 VGA compatible controller: Intel Corporation AlderLake-S GT1 (rev 0c) (prog-if 00 [VGA controller])
DeviceName: Onboard - Video
Subsystem: ASUSTeK Computer Inc. AlderLake-S GT1
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 166
Region 0: Memory at 6002000000 (64-bit, non-prefetchable) [size=16M]
Region 2: Memory at 4000000000 (64-bit, prefetchable) [size=256M]
Region 4: I/O ports at 6000 [size=64]
Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
Capabilities: [40] Vendor Specific Information: Len=0c <?>
Capabilities: [70] Express (v2) Root Complex Integrated Endpoint, MSI 00
DevCap: MaxPayload 128 bytes, PhantFunc 0
ExtTag- RBE+ FLReset+
DevCtl: CorrErr- NonFatalErr- FatalErr- UnsupReq-
RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop- FLReset-
MaxPayload 128 bytes, MaxReadReq 128 bytes
DevSta: CorrErr- NonFatalErr- FatalErr- UnsupReq- AuxPwr- TransPend-
DevCap2: Completion Timeout: Not Supported, TimeoutDis- NROPrPrP- LTR-
10BitTagComp- 10BitTagReq- OBFF Not Supported, ExtFmt- EETLPPrefix-
EmergencyPowerReduction Not Supported, EmergencyPowerReductionInit-
FRS-
AtomicOpsCap: 32bit- 64bit- 128bitCAS-
DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis- LTR- OBFF Disabled,
AtomicOpsCtl: ReqEn-
Capabilities: [ac] MSI: Enable+ Count=1/1 Maskable+ 64bit-
Address: fee00018 Data: 0000
Masking: 00000000 Pending: 00000000
Capabilities: [d0] Power Management version 2
Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [100 v1] Process Address Space ID (PASID)
PASIDCap: Exec- Priv-, Max PASID Width: 14
PASIDCtl: Enable- Exec- Priv-
Capabilities: [200 v1] Address Translation Service (ATS)
ATSCap: Invalidate Queue Depth: 00
ATSCtl: Enable-, Smallest Translation Unit: 00
Capabilities: [300 v1] Page Request Interface (PRI)
PRICtl: Enable- Reset-
PRISta: RF- UPRGI- Stopped+
Page Request Capacity: 00008000, Page Request Allocation: 00000000
Capabilities: [320 v1] Single Root I/O Virtualization (SR-IOV)
IOVCap: Migration-, Interrupt Message Number: 000
IOVCtl: Enable- Migration- Interrupt- MSE- ARIHierarchy-
IOVSta: Migration-
Initial VFs: 7, Total VFs: 7, Number of VFs: 0, Function Dependency Link: 00
VF offset: 1, stride: 1, Device ID: 4680
Supported Page Size: 00000553, System Page Size: 00000001
Region 0: Memory at 0000004010000000 (64-bit, non-prefetchable)
Region 2: Memory at 0000004020000000 (64-bit, prefetchable)
VF Migration: offset: 00000000, BIR: 0
Kernel driver in use: i915
Kernel modules: i915

 

Issue is fixed by: apt --fix-broken install

 

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
ocl-icd-libopencl1
The following NEW packages will be installed:
ocl-icd-libopencl1
0 upgraded, 1 newly installed, 0 to remove and 216 not upgraded.
2 not fully installed or removed.
Need to get 39.1 kB of archives.
After this operation, 143 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://cn.archive.ubuntu.com/ubuntu jammy/universe amd64 ocl-icd-libopencl1 amd64 2.2.14-3 [39.1 kB]
Fetched 39.1 kB in 1s (42.3 kB/s)
Selecting previously unselected package ocl-icd-libopencl1:amd64.
(Reading database ... 171962 files and directories currently installed.)
Preparing to unpack .../ocl-icd-libopencl1_2.2.14-3_amd64.deb ...
Unpacking ocl-icd-libopencl1:amd64 (2.2.14-3) ...
Setting up intel-level-zero-gpu (1.3.24558) ...
Setting up ocl-icd-libopencl1:amd64 (2.2.14-3) ...
Setting up intel-opencl-icd (22.43.24558) ...
Processing triggers for libc-bin (2.35-0ubuntu3.1) ...
/sbin/ldconfig.real: /lib/libOpenCL.so.1 is not a symbolic link

Processing triggers for man-db (2.10.2-1) ...

Labels (1)
0 Kudos
1 Reply
SantoshY_Intel
Moderator
566 Views

Hi,


Thanks for posting in the Intel forums.


Glad to know that your issue is resolved. Thanks for sharing the solution with us. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.

 

Thanks & Regards,

Santosh


Reply