Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20761 Discussions

A750 Enabling Temporary NR in DaVinci Resolve results in frame corruption

JasonYi
Beginner
2,658 Views

Driver:31.0.101.4146

CPU:12th Gen Intel® Core™ i5-12490F

DaVinci Resolve:VERSION 18.1.3 BUILD 8

System: Windows 11 21H2  22000.1696

Ram:  32 Gb

 

Enabling Temporary NR in DaVinci Resolve MUST results in frame corruption,no matter in monitoring or rendering.

JasonYi_0-1679038602931.png

This problem can be reproduced in any video footages, anytime, anywhere.

As long as Temporary NR is turned off, the bad frame problem disappears immediately.

JasonYi_1-1679039302801.png

Ps: I tried to turn off all GPU decoding acceleration options, but the problem still exists. I think this may be because the Temporary NR feature must rely on GPU rendering.

 

 

Labels (1)
0 Kudos
12 Replies
Hugo_Intel
Employee
2,609 Views

Hello JasonYi


Thank you for posting on the Intel Communities. I am sorry you are experiencing graphical corruption when using Davinci Resolve 18 on your Intel® Arc™ A750 Graphics.


As a first approach to this issue, please let's try the following:


1.-Uninstall Davinci Resolve 18 from your system and reinstall it.

2.-Use Display Driver Uninstaller to uninstall the current driver from your system. Once uninstalled, install the latest driver version 30.0.101.4148.


If the issue persists, please create a log file with the Intel® System Support Utility and attach it to your reply.


Best Regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
JasonYi
Beginner
2,583 Views

Hello Hugo O.

 

Thank you for your reply. I've already reinstalled Davinci Resolve 18 and Use Display Driver Uninstaller to uninstall and install the latest driver version 30.0.101.4148, However the issue persists.

 

The report is attached.

 

Best Regards,

 

Jason Yi

0 Kudos
Hugo_Intel
Employee
2,559 Views

Hello JasonYi


Thank you for letting us know and for sharing the log files with us. I see that you don't have the latest Windows 11 build installed on your system. In order to ensure full compatibility between the software, OS and GPU, please update to the latest Windows 11 version 22H2 Build 22621.


Best Regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
JasonYi
Beginner
2,533 Views

Hello Hugo O.

 

Thank you for your reply.  I‘ve already update to the latest Windows 11 version 22H2 Build 23403.ni_prerelease. This issue has been improved a bit, but not completely. For now, instead of every frame would have graphical corruption, some certain frame would have a graphical corruption after exporting.

 

JasonYi_0-1679481438580.png

 

It took me some time to capture this picture.

 

I'll look forward to hearing from you soon.

 

Best Regards,

 

Jason Yi

 

0 Kudos
Hugo_Intel
Employee
2,521 Views

Hello JasonYi


The Windows version that you updated is a Windows Insider Preview Build. We would need that you test the software in the latest stable Windows version which is 22621 to make sure that we have full compatibility between the driver and Operating System. Please let us know if the same issue happens after installing this stable version.


Best Regards,


Hugo O.

intel Customer Support Technician.


0 Kudos
Hugo_Intel
Employee
2,477 Views

Hello JasonYi

  

I hope you are doing fine. 

  

Were you able to check the previous post? 

Let us know if you still need assistance. 

  

Best regards,  


Hugo O.  

Intel Customer Support Technician. 


0 Kudos
JasonYi
Beginner
2,461 Views

Hello Hugo O.

 

Thanks for your follow up.

 

This issue always happens. However, I found the answer in Intel Arc driver's release notes: It says that DaVinci Resolve may exhibit color corruption with Optical Flow, which has already been a known issue. 

 

This Driver ReleaseNotes document explains why I turn on temporal noise reduction would have a graphical corruption and turn on spatial noise reduction would not.  DaVinci Resolve should have used the same Optical Flow algorithm for temporal noise reduction.

 

The only thing I can do now is expect Intel to fix this known issue as soon as possible.

 

Best Regards,

 

Jason Yi

0 Kudos
Hugo_Intel
Employee
2,442 Views

Hello JasonYi


As you mentioned we recently identified an issue with Davinci's resolved Optical Flow option outline in the driver that recently came out. since this issue that you are experiencing is with Temporary Noise Reduction, allow me to check if the behavior might be the same as the issue in the release notes. Once I have this information I will post back.


Best Regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
Hugo_Intel
Employee
2,383 Views

Hello JasonYi


Thank you for your patience. I want to let you know that after reviewing the information that you have provided we can confirm that this behavior as we have been reported for some other users as well and we are currently working on this issue to come up with a fix as soon as possible, however, please know that there is no an estimated time for the fix to be available but it should be soon.


In case you want to check the status of this issue later on you can reference the Bug ID 14018949626. Let us know if you have further questions.


Best regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
Hugo_Intel
Employee
2,277 Views

Hello JasonYi


Since there are no further questions we will be closing this thread. Feel free to open a new topic or to contact us in case you want to get an update on the status of this issue using the Bug ID provide in my previous post. Thank you for the information that you have provided on this thread since it helps to fix these types of bugs. Please note this thread will no longer be monitored by Intel. Thank you for your understanding.


Best Regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
Esteban_Intel
Moderator
2,154 Views

Hi JasonYi,

 

A fix for this issue was included with driver version 31.0.101.4314. Can you please test it?

0 Kudos
JasonYi
Beginner
2,081 Views

Hi Esteban,

 

Thank you for letting me know that a fix for the issue I reported was included with driver version 31.0.101.4314. I have installed the latest version and have not experienced any further issues related to the bug I reported.

 

Thank you again for your support and quick response in resolving this matter.

 

Best Regards,

Jason Yi

0 Kudos
Reply