Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20970 Discussions

Anno 1800 DX12 Foliage/Grass (LOD?) Bug

E-Rex
Beginner
1,838 Views

Hi Team,

under Dx12 in Anno 1800 the lod grass and foliage textures are loaded incorrectly. The issue is not present in Dx11.

 

DX11 correct foliage:

DX11 correct foliage and grassDX11 correct foliage and grass

DX11 correct wide viewDX11 correct wide view 

 

DX12 incorrect foliage:

DX12 incorrect foliage and grassDX12 incorrect foliage and grassDX12 incorrect wide viewDX12 incorrect wide view

 

System:

Ryzen 7700

32gb DDR5 6000

Intel Arc A770 @ Beta Driver 31.0.101.4148 (Latest)

Game installed on m.2 SSD

 

Thank you for your time 🙂

0 Kudos
5 Replies
Jean_Intel
Employee
1,792 Views

Hello E-Rex,

 

Thank you for posting on the Intel️® communities. We understand that you are experiencing issues when playing Anno 1800 under Dx12.

 

In order to have a better understanding of your issue, please provide me with the following:

 

  • Does the issue occur on other Graphics Driver versions?
  • Did the game use to work as expected before?
  • Are you running the latest Game version?
  • What is the game distribution service? ( Blizzard, Epic, Origin, Steam, Xbox, Ubisoft connect)

 

We also would like to recommend you perform a clean driver installation for our latest production driver 31.0.101.4255. Doing a clean install of the software/drivers for any hardware can help to fix specific issues that can be associated so any additional software that might be causing malfunction.

 

Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
E-Rex
Beginner
1,784 Views

Hello Jean,

 

1) yes, error also occurs in 31.0.101.4255 (clean install conducted)

2) did run as expected not with the A770 in DX12 before (worked with previous GPU from different GPU vendor)

3) yes, running the latest version

4) Runs via Ubisoft Connect

 

Best Regards,

E-Rex 

🦖

0 Kudos
Jean_Intel
Employee
1,765 Views

Hello E-Rex,

 

Thanks for the information provided.

 

Since you mentioned that you had a previous GPU, we want to recommend you use the Display Driver Uninstaller (DDU). This tool will uninstall all graphics drivers and all leftovers (including registry keys, folders, and files store) and install driver 31.0.101.4255 one more time. You can check the following article for the steps to use the software.

 

Also, in case the issue persists, we would like to further investigate this matter, so please, provide us a system report using the following applications:

  • Intel®️ System Support Utility (Intel®️ SSU) 
    • Download the Intel SSU
    • Open the application and click "Scan" to see the system and device information. By default, Intel®️ SSU will take you to the "Summary View."
    • Click on the menu where it says: "Summary" to change it to "Detailed View."
    • To save your scan: click "Next"; then "Save."
  • Intel® Graphics Command Center:
    • Open the Intel Graphics Command Center
    • Navigate to the Support tab
    • Select System Diagnostic
    • Click Generate Report
    • Select Save and name the output file.

 

Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
1,720 Views

Hello E-Rex,


We hope you are doing fine.


Were you able to check the previous post?

Let us know if you still need assistance.


Best regards, 

Jean O.  

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
1,697 Views

Hello E-Rex,

 

We hope you are doing fine.

 

We have not heard back from you. So we will close this thread. If you need any additional information, submit a new question, as this thread will no longer be monitored.

 

Best regards.

Jean O. 

Intel Customer Support Technician.


0 Kudos
Reply