Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
131 Views

Bug: High CPU usage at idle caused by system interrupts on MacBook laptop

Hi All,

 

I have an issue with a clean Windows 10 (1909) installation running on my MacBook laptop.

 

In Windows Task Manager I see a constant 7-8% "System interrupts" usage and CPU0 is 100% busy when the machine is idle.

 

In Process Explorer I see that ACPI.sys is putting the CPU under load.

 

Hardware:

MacBook Pro (Retina, 15-inch, Mid 2014)

Model: A1398 (EMC 2876)

ID: MacBookPro11,2

CPU: 2.2 GHz Core i7 (I7-4770HQ) (4 cores, 8 logical processors)

RAM: 16 GB

Video Card: Intel Iris Pro 5200

Storage: 256 GB SSD

 

Software:

BIOS Version/Date: 159.0.0.0.0, 2020-02-05

macOS version: 10.15.4 (19E287)

Windows version: Windows 10 Pro 1909 (Build 18363, 64 bit, English)

 

If I put the computer to sleep and wake it, CPU0 usage goes down to 0%, but after a restart it goes back to 100%.

 

Uninstalling the Intel Graphics Driver also fixes the issue, but this is not a permanent solution as I can only use my external monitor with the Intel driver.

 

I tried several Intel Drivers, but the issue persists with all of them:

1. 10.18.10.3345 (Oct 31, 2013) (this one gets installed with Windows)

2. 10.18.15.4240 (Jun 16, 2015) (this one gets installed with the Apple Boot Camp Support Software)

3. 20.19.15.4531 (Sep 29, 2016) (this one gets installed with Windows Update)

4. 20.19.15.5126 (Jan 21, 2020) (this one is the latest on Intel's website)

 

I attached several screenshots and diagnostics information.

 

Can someone please advise how to get this fixed?

 

0 Kudos
2 Replies
Highlighted
Super User
46 Views

Apple has requested all questions regarding their hardware be directed to apple support.

 

Doc

 

Doc (not an Intel employee or contractor)
0 Kudos
Highlighted
Beginner
46 Views

I see, thank you.

0 Kudos