Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20954 Discussions

Citra opengl error

Bhavya
Beginner
2,485 Views

When ever i try to use citra it says that opengl 4.3 is missing but my drivers are up to date and i have intel hd 4000 graphics and when the error  is shown it also says that my graphics driver intel hd 2500 might not be compatible with open gl 4.3 or its drivers are not up-to-date but this is should not be the case because my graphics are intel hd 4000 which supports open gl 4.3. Please help i really want to play 3ds games on citra i have also uploaded a picture for reference and a system information file image_2023-05-25_180808509.png

Labels (1)
0 Kudos
4 Replies
AlHill
Super User
2,477 Views

Your system is too old.  The best you can get is OpenGL 4.0:

https://www.intel.com/content/www/us/en/support/articles/000005524/graphics.html?eu-cookie-notice

 

Doc (not an Intel employee or contractor)
[Maybe Windows 12 will be better]

0 Kudos
Bhavya
Beginner
2,474 Views

Well do you know a solution for this that does not include buying a whole new system and also do you think that i can just upgrade to intel 5100/5200 as it is compatible with open gl 4.3

 

 

 

0 Kudos
AlHill
Super User
2,469 Views

If you are a desktop, you might try installing an older nvidia card, like GTX1060 for example, and use that for your graphics.  I would not use AMD cards, as they typically do not work.

 

Doc (not an Intel employee or contractor)
[Maybe Windows 12 will be better]

 

 

0 Kudos
AlHill
Super User
2,468 Views

No, you cannot upgrade as the graphics are built into the processor.

 

Doc (not an Intel employee or contractor)
[Maybe Windows 12 will be better]

0 Kudos
Reply