Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
114 Views

Custom Scale Factor is always set

Hello everybody, trying to setup multiple monitors and custom scale factor is not going away.

If I turn off and sign out for few seconds I can setup that, then something else is overriding to a certain value and if I sign out and in again everything is screwed.

I would like to have different scaling options for the monitors (built in in 4k, the other one is 1440p).

Here are my specs:

 

HP Spectre x360 Convertible 15-bl1XX

 

Windows 10 home 1909

Intel® Core™ i7-8550U CPU @ 1.80GHz

 

NVIDIA GeForce MX150

 

Intel® UHD Graphics 620

Drivers: 26.20.100.8141

Using latest Intel Graphics Command Center

 

The scale on both monitor is set to 'maintain aspect ratio'.

 

I don't know what more informations I can give you to help me.

Thank you!

0 Kudos
5 Replies
Highlighted
Super User Retired Employee
14 Views

Is it actually reverting within IGCC as well? Or is it just in what you are seeing by looking at the display?

...S

0 Kudos
Highlighted
Beginner
14 Views

Nope -IGCC is always the same as I changed - it is set to "Maintain Aspect Ratio". There is no 'override settings' as the previous Intel's software though.

I suspect it could be a third party software maybe, but not sure how to catch it!

0 Kudos
Highlighted
Super User Retired Employee
14 Views

This is a laptop, right? For laptops, you are supposed to be running the drivers provided by your laptop manufacturer. You are not supposed to be upgrading the intel driver to anything else. While it is true that the new 8141 build is unlocked and can be installed over top of OEM drivers, the customized drivers have to be installed before doing so.

 

Do the following:

 

  1. Uninstall this Intel Graphics driver package from Apps & Features.
  2. Reboot.
  3. Check what driver is assigned to the graphics device in Device Manager. If Microsoft driver, skip to step 7.
  4. Uninstall the driver by right-clicking on entry and selecting Uninstall Device. Check the option to remove associated software.
  5. Reboot.
  6. Go back to Step 3.
  7. If you upgraded the NVIDIA driver using the NVIDIA site, repeat steps 1 through 6 but this time WRT the NVIDIA Graphics device.
  8. Download the Intel and NVIDIA drivers from the HP site.
  9. Install these drivers.
  10. Reboot.
  11. Check if you can use the IGCC app to set aspect ratio and have it remain set to what you set it to.

 

If you can (i.e. it works right), STOP. Do not install any drivers from the Intel or NVIDIA sites until you have discussed these upgrades with HP Customer Support and they have indicated that this is supported.

 

...S

0 Kudos
Highlighted
Beginner
14 Views

Hello Scott!

Thanks for your help - the problem is happening both with HP drivers and with newer ones, but I found the issue.

It is not Intel related, but can be useful for other persons 🙂

 

I started disabling all the startup entries from the task manager, and one stood up: boot.cmd .

I opened the file and it adds entries to the registry:

 

 

REG ADD "HKCU\Control Panel\Desktop" /v DpiScalingVer /t REG_DWORD /d 0x00001018 /f

REG ADD "HKCU\Control Panel\Desktop" /v Win8DpiScaling /t REG_DWORD /d 0x00000001 /f

REG ADD "HKCU\Control Panel\Desktop" /v LogPixels /t REG_DWORD /d 0x00000078 /f

 

Disabling this from the boot fixed the problem!

I found some more info on the meaning of those registry entries here:

 

https://www.tenforums.com/tutorials/5990-change-dpi-scaling-level-displays-windows-10-a.html

 

Thus all is solved!

 

Thank you for your help, luckily enough it was another problem.

 

G.

0 Kudos
Highlighted
Super User Retired Employee
14 Views

Interesting. Were you able to determine where script file came from?

...S

0 Kudos