Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
17443 Discussions

Flickering Black Screen / Glitching after waking from Hibernation

Yadobler
Beginner
2,272 Views

Greetings, 

I refer to my post on reddit https://www.reddit.com/r/intel/comments/meh3qr/flickering_black_screen_glitching_after_waking/ 

 

Uploaded are the system-information as given by the Intel Website, as well as images for reference, discussed here.

Thank you!

-----

I have:

  • Acer A514-53G

  • Intel i5-1035G1 @ 1GB (stock speed)

  • Windows 10 20H2 (19042.870)

  • 12GB ram

  • Intel UHD Graphics

    • Current Driver: 27.20.100.8280

  • NVIDIA GeForce MX350

    • Current Driver: 27.21.14.6192

I have determined it's an Intel Graphics issue from my own test that I'll elaborate below.

 

Problem:

After waking up from Hibernation, when I move the cursor, the screen flickers, causes a Black Bar across the screen or glitches. This depends on what is under the cursor. Sometimes this doesnt matter since everything is black.

Screen Glitching out

 

when screen is between flickering/glitching out, the cursor appears fuzzy

Trigger:

After boot, (regardless of uptime), hibernate the computer. (using shutdown -h or for me, using wox / launchy / MS powertools run. yes ive tried all 3). Start up computer again. Issue begins.

does not happen when lid closed and opened / after waking from sleep. only hibernating

This has happened once when I newly bought this computer but after an upgrade using acer drivers, everything was ok until recently. I can't pint-point what caused it, but it was before upgrading to windows 20H2, and still persists.

Attempted solutions:

So i've done the following:

  1. Uninstall and reinstall both Nvidia and Intel graphics from above acer website

  2. Step 1 but from respective vendor websites

  3. downgrading to older drivers

  4. deleting the drivers in Device Manager and restarting to let the computer reinstall the stock graphics drivers that came with this

  5. run Windows Update to reinstall drivers and version

  6. updated all non-MS drivers

  7. Tried to find and disable Fast Sleep (but option not found)

  8. Disable Intel UHD graphics alone but leave Nvidia graphics alone in Device manager. This is the current situation I'm in right now, and it works but some apps are sloooww like MS Word.

 

Regarding step 7, I ran powercfg /A:

The following sleep states are available on this system:
    Hibernate
    Fast Startup

The following sleep states are not available on this system:
    Standby (S1)
        The system firmware does not support this standby state.
        An internal system component has disabled this standby state.
                Graphics

    Standby (S2)
        The system firmware does not support this standby state.
        An internal system component has disabled this standby state.
                Graphics

    Standby (S3)
        An internal system component has disabled this standby state.
                Graphics

    Standby (S0 Low Power Idle)
        The system firmware does not support this standby state.

    Hybrid Sleep
        Standby (S3) is not available.
        The hypervisor does not support this standby state.

Trobleshooting:

  • for one, none of window's troubleshooters give any errors.

  • This is not a software issue since even Task Manager is affected, and taking a screenshot with PrnScr and Snipping tool both give proper images while the physical display is black

  • This is not a hardware issue because booting and BSOD displays properly, and this only occurs when after hibernating (might be a ACPI power issue)

  • Looking in Event Viewer, this pops up whenever the screen glitching occurs. (and spams EV with this over and over):

https://preview.redd.it/21moeqn6clp61.png?width=1278&format=png&auto=webp&s=e491ccf735e30f5942aae331...

  • The error is logged by HAL.dll (Hardware Abstraction Layer), so this must be a driver issue

    • "Error Event ID: 15" yields nothing in google, in the context of Event Viewer and HAL.

    • "The iommu has detected an error" suggests something wrong with the virtual address <-> physical address of the hardware.

  • So I used Driver Verifier:

    • For each test (and also every iteration of upgrading drivers and whatnot) I reboot the computer, then wait for a few minutes, open Word to trigger whatever is causing the graphics issue. Then I hibernate the computer, and then wake it up. If no visible glitch is present, I switch to Word / Open a new instance and move it around. This always causes a black bar to appear below Word App at least (or else the entire screen flickers black or glitches). Then I wait for awhile and eventually a BSOD crashes the computer.

    • All test settings, except DDI compliance because this told me not to

    • First: testing NVIDIA driver:

      • I selected NVLDDMKM.SYS and also some runs I try all NVIDIA drivers

      • After Restart: Uneventful

      • After Hibernating and waking up: Computer slows down, cursor draggy. after a minute, BSOD

      • BSOD - always 0x10e (VIDEO_MEMORY_MANAGEMENT_INTERNAL), with Parameter one = 0x2e. Now I couldn't find anything on google about 0x2e. offending process: dxgmms2.sys & watchdog.sys

      • repeated testing yields same BSOD

    • Second testing Intel driver:

      • I selected IGKMDN64.SYS and also some runs I try all Intel Drivers, even the other components

      • After Restart: Some runs are uneventful. Some really screw the screen up (boot screen was ok, but login screen and beyond is unusable). Basically the screencap above where everything's rainbow. If you ask me, it's like some beginner programmer forgot to multiply the screen width by the size of each pixel bit value, so the addresses are misaligned and everything is wrongly coloured and all shifted to alternating lines, to the left.

      • After Hibernating (for those uneventful ones) and waking up: Computer slows down, cursor draggy. after a hot minute, BSOD

      • BSOD - most common: 0x1000007E SYSTEM_THREAD_EXCEPTION_NOT_HANDLED. for this example, i noticed that my beautiful pink cursor was actually visible on the screen. this would indicate something wrong with updating the screen when cursor moves, which ties in with having the screen glitch depending on what's under the cursor and the cursor looking glitchy. Parameter 1 - 0xC0000420 which is NTSTATUS STATUS_ASSERTION_FAILURE. This one is by ndis.sys and ntoskrnl.exe which doesn't make sense.

      • repeated testing yields 0x1000007E most of the time, but sometimes IRQL_NOT_LESS_OR_EQUAL and even DRIVER_VERIFIER_DETECTED_VIOLATION (0xC4) with violation in perimeter 1: 0x10 (The driver attempted to free an address that was not returned from an allocate call.) this was from "esif_lf.sys+2e596 and ntoskrnl.exe" and the bad address is 0x0.

Why Intel?

  • Frustrated by the lack of Google and ideas, I went to Device manager and disabled the drivers and tested:

    • Disabling NVIDIA did not stop the glitching. After restart and hibernate, issue comes back

    • Disabling Intel UHD stopped the glitching and the screen zoom+resolution was reset. Night Light does not work. I restarted, the screen resolution and zoom became normal. I ensured the device was still disabled, and i hibernated. waking up, no glitches and problems. this is the status right now.

Help:

has anyone have any idea of this?

  1. what is HAL event ID:15

  2. what other debugging can I do?

  3. any recorded instances of this happening?

  4. anymore information needed?

what I don't want since i've tried it:

  1. reboot

  2. clean reset of everything

  3. reinstall driver

  4. downgrade drivers

  5. use OEM drivers

  6. use Vendor drivers

  7. cool Device

  8. cry / cry in fetal position

  9. sfc /scannow or any permutations

  10. MRT, malwarebytes, etc.

  11. Windows integrity check

 

System Information:

Spoiler

Intel® Driver & Support Assistant

Detailed Report

Last scan: 3/29/2021 1:00 AM

Computer

Acer Aspire A514-53G
System Manufacturer Acer
System Model Aspire A514-53G
System Type Mobile
Motherboard Manufacturer IL
Motherboard Product Sneezy_IL
Version V1.13
BIOS Version V1.13
Date 12/30/2020
SMBIOS Version 3.2
Secure Boot On

Operating System

Microsoft Windows 10 Home (64-bit)
Version 2009
OS Build 10.0.19042
Build Branch vb_release
Locale English (United States)
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
.NET Framework Versions 2.0.50727.4927, 3.0.30729.4926, 3.5.30729.4926, 3.5.30729.5003, 4.0.0.0, 4.8.04084
Installed Internet Browsers Mozilla Firefox, Google Chrome, Internet Explorer 11.789.19041.0, Microsoft Edge

Processor

Intel® Core™ i5-1035G1 CPU @ 1.00GHz
Device Details
Manufacturer GenuineIntel
Description Intel64 Family 6 Model 126 Stepping 5
Architecture x64
# of Cores 4
# of Threads 8
Processor Base Frequency 991 MHz
Current Voltage 1.7
Level 2 Cache 2048 Kb
Level 3 Cache 6144 Kb
Processor Id 0x706E5
Revision 32261
Availability Running at full power

Graphics

NVIDIA GeForce MX350
Device Details
Adapter Compatibility NVIDIA
Video Processor GeForce MX350
Provider NVIDIA
Version 27.21.14.6192
Date 3/10/2021
Adapter DAC Type Integrated RAMDAC
Adapter RAM 2.00 GB
Availability Offline
Status This device is working properly.
Location PCI bus 1, device 0, function 0
Device Id PCI\VEN_10DE&DEV_1C94&SUBSYS_14841025&REV_A1\4&1687E756&0&00E0
Intel® UHD Graphics
Device Details
Adapter Compatibility Intel Corporation
Video Processor Intel® UHD Graphics Family
Resolution 1920 x 1080
Bits Per Pixel 32
Number of Colors 4294967296
Refresh Rate - Current 1 Hz
Refresh Rate - Maximum 64 Hz
Refresh Rate - Minimum 64 Hz
Provider Intel Corporation
Version 27.20.100.8280
Date 5/19/2020
Adapter DAC Type Internal
Adapter RAM 1.00 GB
Availability Running at full power
Status This device is disabled.
Location PCI bus 0, device 2, function 0
Device Id PCI\VEN_8086&DEV_8A56&SUBSYS_14841025&REV_07\3&11583659&0&10

Audio

Intel® Display Audio
Device Details
Provider Intel® Corporation
Name IntcDAud.sys
Version 11.1.0.17
Date 6/16/2020
Device Id INTELAUDIO\FUNC_01&VEN_8086&DEV_280F&SUBSYS_80860101&REV_1000\5&824FE8D&5&0201
Realtek Audio
Device Details
Provider Realtek Semiconductor Corp.
Name RTKVHD64.sys
Version 6.0.8838.1
Date 11/12/2019
Device Id INTELAUDIO\FUNC_01&VEN_10EC&DEV_0256&SUBSYS_10251454&REV_1000\5&824FE8D&5&0001
NVIDIA Virtual Audio Device (Wave Extensible) (WDM)
Device Details
Provider NVIDIA
Name nvvad64v.sys
Version 4.13.0.0
Date 3/14/2019
Device Id ROOT\UNNAMED_DEVICE\0000

Networking and I/O

Intel® Wi-Fi 6 AX201 160MHz
Device Details
Manufacturer Intel Corporation
Availability Running at full power
Status This device is working properly.
Installed True
MAC Address 9C:FC:E8:2F:B7:28
Service Name Netwtw10
Provider Intel
Version 22.30.0.11
Date 1/20/2021
Device Id PCI\VEN_8086&DEV_34F0&SUBSYS_00748086&REV_30\3&11583659&0&A3
Revision 30
Realtek PCIe GbE Family Controller
Device Details
Manufacturer Realtek
Availability Running at full power
Status This device is working properly.
Installed True
MAC Address F4:69:D5:C2:E7:23
Service Name rt640x64
Provider Realtek
Version 10.38.1118.2019
Date 11/18/2019
Device Id PCI\VEN_10EC&DEV_8168&SUBSYS_14841025&REV_15\01000000684CE00000
Revision 15

Memory

12 GB
Device Details
Physical Memory - Total 12 GB
Physical Memory - Available 5.70 GB
Virtual Memory - Total 23.32 GB
Virtual Memory - Available 15.06 GB
Page File C:\pagefile.sys
Page File Space 11.50 GB

Storage

WDC PC SN530 SDBPNPZ-1T00-1014
Device Details
Capacity 953.86 GB
Version 21103900
Serial Number E823_8FA6_BF53_0001_001B_448B_46EA_19C5.
Partitions 4
Provider Microsoft
Version 10.0.19041.789
Date 6/21/2006
Device Id SCSI\DISK&VEN_NVME&PROD_WDC_PC_SN530_SDB\4&3846E378&0&030000
Device Path \\.\PHYSICALDRIVE0
C:
File System NTFS
Compressed False
Capacity 476.37 GB
Free Space 333.21 GB
😧
File System NTFS
Compressed False
Capacity 476.38 GB
Free Space 380.17 GB
0 Kudos
3 Replies
Shvm_ReX
New Contributor I
2,144 Views

Hi @Yadobler 

 

Hope you are doing well, thanks for posting your query in so much detail.

 

You could really try the following steps :

 

1. Visit this link : Windows 10 Flickering with Mouse Movement  

 

2.Try contacting the manufacturer  acer support   if you have tried updating both the graphics driver already have updated the BIOS.

 

Hope this information helps.


Please let me know how it goes.


Regards,

Shvm_ReX

 

MarcoK73
Beginner
1,499 Views

Didy come up with a solution for this issue yet?

 

I have the same issue on my Lenovo Yoga C940 laptop and after reinstalling the whole system and updating all drivers and BIOS to the latest versions I found out that in my case it is caused by enabeling Hyper-V on my laptop. 

When Hyper-V is enabled and I resume the laptop from hibernation the screen flickering starts. 

When Hyper-V is disabled and I resume from hibernation all is ok. 

The issue is causing the eventlog to flood with EventID 15 messages "The iommu has detected an error" 

 

Can Intel create a sulution for this?

GerardF
Beginner
626 Views

Hi,

 

I have a very similar issue, on my Lenovo Yoga C940. The screen flickering happens for me when I boot an the laptop is not plugged-in. It only happens on the internal screen, not on the external screens when they are connected. As soon as I move the mouse (trackpad or bluetooth mouse), the screen starts flickering at a very fast rate, and gets black most of the time.

I contacted the Lenovo support, they told me it could be an issue with Windows 11. So I installed a fresh copy of Windows 10 in a second partition on my disk, then upgraded to 11, no issue.

I was almost ready to reinstall the whole system on the initial partition when I found the first link in Shvm_ReX's post above. One of the solution seemed totally crazy, but it was simple, so I tried it and it worked!

I simply turned on the mouse trails (with the shortest possible value, I don't even notice it), and no flickering anymore.

Hope that helps.

Reply