Community
cancel
Showing results for 
Search instead for 
Did you mean: 
dd12
Beginner
2,360 Views

High GPU usage with Microsoft Magnifier

Jump to solution

Category

Questions

Answers (N/A if not applicable)

Description

Provide a detailed description of the issue

When using Microsoft Windows Magnifier for regular non-intensive desktop tasks (navigating the GUI, browsing the web etc.), GPU usage is as high as 99-100%, resulting in the feeling that the display is running at 30 fps instead of 60 fps, laggy input etc. This wasn't as noticeable at 1200p, but after switching to a new monitor (1440p), it has become an issue. Decreasing the resolution under Display Settings to a sub-natiive 1080p alleviates the problem (GPU usage is now about 80% - still too high in my opinion).

Please place an X to the right of the option showing how often you see this issue using specific steps. (Ex: 'Every few times a game is started it flickers.' <- This would be "Often")<p> 

Always (100%): X

Often (51-99%):

Sporadic (20-50%):

Very Sporadic (<20%):

Hardware (HW)

Brand and Model of the system.

Asus H270M-PLUS, Intel i5 7500

Hybrid or switchable graphics system?

 

ie Does it have AMD or NV graphics too?

No

Make and model of any Displays that are used to see the issue (see note2 below). 

LFP = Local Flat Panel (Laptop panel)

 

<strong style="font-style: inherit; font-size: 13.3333px; font-family: intel-clear, arial, helvetic...
0 Kudos
1 Solution
Bryce__Intel
Employee
974 Views

We received a response from MSFT on this:

- With run Magnifier with "Smooth edges of images and text" option enabled, OS runs complex shaders that likely are not exactly optimized for Intel GPU's. If Smooth Images and Text is checked, it will use the GPU to make things smoother.

Optimizations are being investigated for future OS releases, though this observation is currently considered expected behavior and as such, we'll be closing on our side.

.:Bryce:.

View solution in original post

9 Replies
idata
Community Manager
974 Views

Hello DD123,

Thank you for joining the Intel Community.

Have you tried to test our earlier versions of the Intel® HD Graphics driver? This is the oldest version in our Download Center: https://downloadcenter.intel.com/download/26772/Intel-Graphics-Driver-for-Windows-15-45-?product=989... https://downloadcenter.intel.com/download/26772/Intel-Graphics-Driver-for-Windows-15-45-?product=989.... I would also recommend to install the driver for your monitor: https://www.dell.com/support/home/us/en/04/drivers/driversdetails?driverId=FF3XW Dell U2715H 27" Monitor with LED Driver | Dell US

Regards,

Amy C.

dd12
Beginner
974 Views

Thank you, Amy C.

I've tried both of your suggestions.

Installing the Dell monitor driver didn't change anything.

After installing the older GPU driver from your link, performance with Magnifier enabled remains the same - choppy, not smooth.

This issue should be fairly easy to replicate.

Edit: Just had a remote session with Microsoft Accessibility Helpdesk. They determined that it isn't the Magnifier app that's causing high GPU usage, but rather the Desktop Window Manager process (that involves Aero, themes etc.). They hinted that this is most likely a compatibility issue with the GPU and that I should contact Intel.

Regards,

D.

idata
Community Manager
974 Views

D, can you please try with the Windows inbox driver? Remove the Intel graphics driver.

Let me know the results.

Regards,

Amy C.

dd12
Beginner
974 Views

Hi Amy C.,

when the generic display driver is used, the load gets transferred to the CPU. This results in huge lag - after moving the mouse rapidly, I can easily sit back and watch the cursor catching up for the next 10 seconds ...

Regards,

D.

idata
Community Manager
974 Views

D, thank you for trying the suggestion.

Let me review this, I will update the thread as soon as possible.

Regards,

Amy C.

idata
Community Manager
974 Views

Hi D,

Can you please try other resolutions with different refresh rates and see if the behavior persists?

Regards,

Amy C.

dd12
Beginner
974 Views

Hi Amy C.,

I have tried it with 1440p and 1080p (the only two viable resolutions for me), at both 59 and 60 Hz.

As mentioned, GPU load reaches 100% at 1440p, and about 80% at 1080p.

However, I find it hard to believe that Magnifier in combination with the Desktop Window Manager service is simply too demanding for the iGPU to handle.

There must be a compatibility issue somewhere, either with Windows or Intel drivers.

Regards,

D.

idata
Community Manager
974 Views

Thanks.

 

 

I will continue doing some research. I will update the thread as soon as possible.

 

 

Regards,

 

Amy C.
Bryce__Intel
Employee
975 Views

We received a response from MSFT on this:

- With run Magnifier with "Smooth edges of images and text" option enabled, OS runs complex shaders that likely are not exactly optimized for Intel GPU's. If Smooth Images and Text is checked, it will use the GPU to make things smoother.

Optimizations are being investigated for future OS releases, though this observation is currently considered expected behavior and as such, we'll be closing on our side.

.:Bryce:.

View solution in original post

Reply