Community
cancel
Showing results for 
Search instead for 
Did you mean: 
PKhou
Beginner
9,714 Views

How to enable Radeon Vega M

Category

Questions

Answers (N/A if not applicable)

Description

Provide a detailed description of the issue

I just got my new HP Spectre 360 with the Radon Vega M GPU. I was playing Minecraft as my first game on the laptop. I noticed it only played on the Intel GPU and not the Vega. I confirmed this by looking at the task manager Performance viewer. How do I switch the game to use the Vega GPU?

Please place an X to the right of the option showing how often you see this issue using specific steps. (Ex: 'Every few times a game is started it flickers.' <- This would be "Often")<p> 

Always (100%): X

Often (51-99%):

Sporadic (20-50%):

Very Sporadic (<20%):

Hardware (HW)

Brand and Model of the system.

2018 HP Spectre 15 360

Hybrid or switchable graphics system?

 

ie Does it have AMD or NV graphics too?

Switchable I think. AMD and Intel

Make and model of any Displays that are used to see the issue (see note2 below). 

LFP = Local Flat Panel (Laptop panel)

 

EFP = External Flat Pan...
0 Kudos
21 Replies
idata
Community Manager
827 Views

Hello buddhasai,

 

 

Thank you for joining the Intel Community Support.

 

 

Your computer should automatically use Radeon Graphics to open games such as Minecraft, but I will do further research about this issue.

 

 

I am still missing some information about your system. Please run the Intel® System Support Utility.

 

 

Follow these steps:

 

 

1.Download the Intel® System Support Utility and save the application to your system.

 

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91...

 

2.Open the application and click Scan to see system and device information. The Intel® System Support Utility defaults to the Summary View on the output screen following the scan. Click the menu where it says summary to change to Detailed View.

 

3.To save your scan, click Next and click Save. You can save the file to any accessible location on your computer.

 

4. Attach the report to this thread.

 

 

Wanner G.
PKhou
Beginner
827 Views

Hey Wanner!

Thanks for the swift response. I've attached scan report here.

idata
Community Manager
827 Views

Hello buddhasai,

 

 

Thank you for your response.

 

 

I will replicate this issue. I will provide the results once available.

 

 

Wanner G.
idata
Community Manager
827 Views

Hello buddhasai,

 

 

I am sorry for the delay.

 

 

We are trying to reproduce your issue to provide further information about it.

 

 

I will get back to you soon.

 

 

Wanner G.
TLang7
Novice
827 Views

Hi,

I have had the exact same issue with 2 other games (I haven't tried any others) on my Dell XPS 9575. Dark Souls Remastered (DSR) and TES III: Morrowind (Morrowind) both do not detect the Radeon Vega M GPU and instead default to the Intel HD 630. As above with OP, adding profiles doesn't work but even trying to manually add the applications via the "switchable graphics" menu in Radeon Settings doesn't work out. In trying to manually add it will freeze the Radeon Settings menu.

Here's what I have tried:

1: uninstalled and reinstalled the Vega GPU driver.

2: uninstalled and reinstalled the applications in question.

3: tried using Morrowind's launcher options use the Vega GPU (did not show up in there, there's no such option in DSR).

4: tried disabling the intel GPU (they just switched to microsoft's basic display adapter)

5: tried disabling the ms basic display adapter (they still only wanted that adapter, even though it was disabled).

6: tried steps 5 and 6, but the the relevant display drivers uninstalled as opposed to disabled.

I tried contacting dell's support on this, but they ended up taking me through the above steps again. So I'm a bit at a loss here. Programs like Blender detect it just fine, but DSR and Morrowind seem to have difficulty actually just detecting the Vega GPU. I went ahead a attached my XPS system information.

idata
Community Manager
827 Views

Hello devilslayersbane,

 

 

I understand that you are having issues with Radeon™ RX Vega M GL Graphics. I will assist you with this.

 

 

First, try installing this driver for Radeon™ RX Vega M GL Graphics:

 

https://downloadcenter.intel.com/download/27881/Graphics-Radeon-RX-Vega-M-Graphics?product=136865

 

 

Then, please follow these steps to force your computer to open games with Radeon RX Vega M.

 

 

1. Right click on desktop and select Radeon RX Vega M Settings

 

2. Click on Gaming

 

3. Click Add option on the right hand corner

 

4. Click on browse, then look for the desire application

 

5. Once the application has been added, click on the 3 dots next to it and click on Launch.

 

 

If you are unable to resolve the issue by performing these steps, please fill out this information and attach all the reports, too.

 

https://communities.intel.com/thread/77761 https://communities.intel.com/thread/77761

 

 

Wanner G.
TLang7
Novice
827 Views

You're right. I hadn't reinstalled the drivers. Still, I went ahead and did that and the attached picture is what I got after following your instructions.

I definitely appreciate you all looking into this.

TLang7
Novice
827 Views

Category

Questions

Answers (N/A if not applicable)

Description

Provide a detailed description of the issue

Games do not detect Vega GPU on XPS 15 w/ Kaby Lake G, manual entry of games via Radeon Settings freezes program (note that computer still functions).

Please place an X to the right of the option showing how often you see this issue using specific steps. (Ex: 'Every few times a game is started it flickers.' <- This would be "Often")<br style="font-family: &font-size:13.33px; font-style: normal; font-weight: 400; border-color: # 3d3d3d; border-style: none;"/>

Always (100%): X

Often (51-99%):

Sporadic (20-50%):

Very Sporadic (<20%):<p style="font-family: &font-size:14px; font-style: normal; font-weight: 400; border-color: # 3d3d3d; ...

idata
Community Manager
827 Views

Hello devilslayersbane,

 

 

Thank you for your response and the information provided.

 

 

We are working on reproducing this issue to provide further steps about the behavior of Radeon™ RX Vega M Graphics when opening games.

 

 

Wanner G.
RSrin3
Beginner
827 Views

I would like to add on that I am having the same issues with my Dell XPS 15 2 in 1. In addition to that, I am unable to switch graphics for applications outside gaming, such as CAD software.

idata
Community Manager
827 Views

Hello rikshi,

 

 

Thank you for joining the Intel Community Support.

 

 

I would like to have more information about your system and the games you are playing as well.

 

 

Please fill out this information and attach all the reports.

 

 

https://communities.intel.com/thread/77761 https://communities.intel.com/thread/77761

 

 

Wanner G.
DGrav3
Beginner
827 Views

I am also having this same issue with Dell XPS 9575. It won't use the RX Vega M graphics card with "Rise of the Tomb Raider". That's the only game I've tested so far. I've done updates, installed drivers, un-installed/re-installed the game. Even tried Intel's suggestion to right click on desktop, and go to Radeon RX Vega M settings, and click on "Gaming", click "add", and I can click on "Rise of the Tomb Raider" app, but it won't even add it. It does nothing.

DGrav3
Beginner
827 Views

system info attached

TLang7
Novice
827 Views

Ok, so I figured out my issue. It was due to a bit of an assumption on my part. I decided to try and get the games working one more time when I realized that the dialog box to search for programs was looking at my desktop. The shortcuts that steam puts on one's desktop are internet shortcuts (kind of) and just confused the radeon settings menu when I tried to use those. I was able to navigate to my steam app library and use the actual executable to activate the radeon gpu for the games.

I think to avoid this confusion in the future, it would be wise to set the default location of browser for the switchable graphics to "C:\programfiles(x86)\" as opposed to the desktop. Or you can work with Valve to resolve this issue of the shortcuts not directing to the application properly. Hopefully this solves it for everyone else here, too.

Just for clarity, here's my resolution steps that I tried and found successful:

1: navigate to the radeon settings menu

2: click system then switchable graphics

3: click running applications and change it to installed profiled applications

4: click browse, navigate to the proper .exe in your respective steam folder

5: profit.

Thank you for investigating this Intel!

DGrav3
Beginner
827 Views

Thanks for the sharing! I did what you said and got it working! Mine was through the xbox app though and was difficult to find the source file for the game. Turns out, for anyone else who is having this issue with a game from the xbox app, my game's source file is located in "WindowsApp" file. C:\Program Files\WindowsApps\. However, the"WindowsApps" file is a hidden file, so you can't see it until you "un-hide" it. Then, you'll have to grant yourself access to it because it is also a locked file. Pretty complicated process for me and I had to look up how to do those things. I feel I shouldn't be having to do this just so the Radeon Graphics card will kick in. I don't know why this new Intel chip doesn't automatically know when it needs to run the Radeon graphics. Hopefully there will be a fix for this soon!

Here's a link to how to find a game's source file if it's from the xbox app:

https://www.thewindowsclub.com/windows-8-metro-apps-folder-location https://www.thewindowsclub.com/windows-8-metro-apps-folder-location

idata
Community Manager
827 Views

Hello all,

 

 

I am glad to hear that you were able to resolve the issues discussed at the beginning.

 

 

I would like to mention that I provided a few steps to force your computer to open games with Radeon RX Vega M at the beginning. The troubleshooting steps you provided were also reviewed.

 

I will forward your request about the default folder change to the proper department and update this thread as soon as I have additional information about it.

 

 

Wanner G.
JDesp
Beginner
827 Views

I have the same problem with being unable to force my XPS 15 2 in 1 to use the Radeon graphics card in "Railroad Empire". I have tried all the steps in this thread, even launching the game from the Radeon control panel, but the game will not recognize the Radeon card. The Intel graphics card will not support the game. The game will load but does not run well. I can reduce the resolution in the game's "options"- "graphics". In the Railroad Empire community forum on Steam, it was recommended to open the game as administrator and that helps to make the game playable but still does not resolve the graphics card issue.

idata
Community Manager
827 Views

Hello, jwd3. Thank you for joining this thread.

 

 

If the troubleshooting steps above did not work for you, please create a new thread explaining your problem. Make sure you include your system configuration and a clear explanation about the issue so we can give you a solution as soon as possible.

 

 

 

Antony S.
POcam
Beginner
827 Views

devilsayersbane ,

You're a blessing in disguise, intel should hire you just based on intuition. Followed step by step your suggestion and worked as a pop, Intel should work more with HP & DELL and roll more updates that actually work for the Radeon RX Vega M, such as the one you devised.