Community
cancel
Showing results for 
Search instead for 
Did you mean: 
TBrew2
Beginner
2,487 Views

I have a Lenovo T480 with a UHD 620 integrated card. I am trying to run SolidWorks 2016 and the option for Software Open GL is checked and

The dynamic highlighting is what is slow and you can watch the lines generate it is so slow in Software Open GL.

 

I have a Lenovo T480 with a UHD 620 integrated card. I am trying to run SolidWorks 2016 and the option for Software Open GL is checked and grayed out. With software Open GL, it runs too slow. I can run Solidworks in the safe mode and the check box for Software OpenGL is left unchecked and it runs fine. I run it everyday for several weeks this way and it's great except I have to setup Solidworks every time I run it. Why is this setting being forced to Software Open GL? Thanks

0 Kudos
20 Replies
AlHill
Super User
970 Views

You failed to mention what OS you are using. Also, you should use ONLY the drivers provided by lenovo and not the generic Intel drives.

 

Download, run, AND ATTACH the results of this utility, and an Intel support engineer will be able to assist you.

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility

 

Doc

TBrew2
Beginner
970 Views

Hi Al, I wasn’t 100% sure that the driver was from so I installed the latest from Lenovo and retested SolidWorks with the exact same results. I’ve attached the report from SSU and I am running Win Pro 10 64 Bit. Thanks, Tracy
Amy_C_Intel1
Employee
970 Views

Hello TBrew2, Thank you for posting on the Intel® Communities. Please, double check the file you attached. I am unable to see it in your thread. Have you checked with https://www.solidworks.com/sw/support/customer-software-support.htm regarding this box? Since it also happens with Lenovo's driver, it's possible that is related to settings configuration and not the drivers. Check with their support regarding this feature and how to enable it. Let me know their response. Amy C Intel Customer Support Technician Under Contract to Intel Corporation
TBrew2
Beginner
970 Views

Hi, I've attached the file (previously attached to the email that was sent to me). I have contacted SolidWorks support and they quickly traced it to the Open GL setting. There is a software lock which prevents SolidWorks from using hardware Open GL. So my understanding is that this is in the driver which they have no control over.

 

Tracy

Amy_C_Intel1
Employee
970 Views

What is the full report from SolidWorks support? When did the issue started? Amy C Intel Customer Support Technician Under Contract to Intel Corporation
TBrew2
Beginner
970 Views

Hi Amy, It was actually Hawk Ridge Systems. They did not provide a report but walked me through the diagnostics. The issue started when first installing SolidWorks on this computer.
Amy_C_Intel1
Employee
970 Views

Which driver versions have you tested so far? Amy C Intel Customer Support Technician Under Contract to Intel Corporation
TBrew2
Beginner
970 Views

Hi Amy, First attempt: Source: https://support.lenovo.com/us/en/downloads/ds502213 (I notice this link is no longer valid) n24dt12w = Intel HD Graphics Ver 24.20.100.6344 Second attempt (Currently in use): Source: https://pcsupport.lenovo.com/sa/en/downloads/DS502224 n24da12w = NVIDIA N17S Intel 24.20.100.6223 / Nvidia 24.21.13.9836 Tracy
Amy_C_Intel1
Employee
970 Views

Thanks Tracy. Please, try the following version: https://downloadcenter.intel.com/download/27199/Intel-Graphics-Driver-for-Windows-15-47-?product=126... Use this method to install the driver:https://www.intel.com/content/www/us/en/support/articles/000005629/graphics-drivers.html Use the "Device Manager Method" to uninstall the current driver installed: https://www.intel.com/content/www/us/en/support/articles/000005598/graphics-drivers.html Amy C Intel Customer Support Technician Under Contract to Intel Corporation
TBrew2
Beginner
970 Views

Hi Amy, I performed the uninstall per the directions provided. Then installed the driver Ver. 22.20.16.4815 all per the clear instructions you provided. I then tested SolidWorks to find that Dynamic Highlighting is still extremely slow and the Software Open GL is still checked and greyed out as before (SolidWorks Options). So basically, no difference. Tracy
Amy_C_Intel1
Employee
970 Views

Try the same uninstallation and reinstallation steps for this driver version: https://downloadcenter.intel.com/download/27058/Intel-Graphics-Driver-for-Windows-15-46-?product=126...
TBrew2
Beginner
970 Views

This version (22.20.16.4771) behaves exactly the same when testing for Dynamic Highlighting and greyed/checked Software Open GL in the options.
TBrew2
Beginner
970 Views

Hi Amy, Tried those two and still cannot uncheck “Use software Open GL” and the Dynamic Highlighting is slow same as with all the other drivers so far. Thanks, Tracy
Amy_C_Intel1
Employee
970 Views

Our driver versions are generic and they may not work as expected in some third-party computers. At this stage, I would recommend to contact Lenovo to double check if they have more drivers (apart from the ones you tested) for your computer model. Amy C Intel Customer Support Technician Under Contract to Intel Corporation
TBrew2
Beginner
970 Views

Thanks Amy, Tracy
Amy_C_Intel1
Employee
970 Views

Additionally, make sure that you are running the latest Windows 10 updates. I also researched and found some suggestions for this issue in the https://forum.solidworks.com/ that include some registry tweaks. You can try posting there for peer to peer assistance. Let us know how it goes. Amy C Intel Customer Support Technician Under Contract to Intel Corporation
TBrew2
Beginner
970 Views

Hi Amy, I performed the following steps to check that SW Open GL was still checked/greyed and it was. It may be useful to others trying to solve this problem. 1. Open regedit. 2. Navigate to HKEY_CURRENT_USER\Software\SolidWorks\Solidworks 2016\Performance\Graphics\Hardware\Current. 3. Right-click on the "Current" key folder, then click "Permissions...". 4. Click "Advanced". 5. Click "Disable Inheritance" and then click "Remove all inherited permissions from this object." 6. Check the box titled "replace all child object permission entries with inheritable permission entries from this object." 7. Press OK to save the changes. 8. Restart SOLIDWORKS and see if OpenGL mode is still enabled. Thanks, Tracy
Amy_C_Intel1
Employee
970 Views

Let's hope is helpful for other users. Thanks to you Tracy! Amy C Intel Customer Support Technician Under Contract to Intel Corporation
TBrew2
Beginner
303 Views

Hopefully. I’ll keep an eye out for any activity and may pitch in if it helps. Thanks, Tracy
Reply